Batctl, batman-adv unter Debian

Hallo Zusammen,

kurze einfache Frage: Wie installiert ihr Batman etc. momentan unter Debian und mit Welcher Version?

1 Like

@phip hat selbst gebaute Paketet für v2015.0 compat v15 auf http://firmware.freifunk-wuppertal.net/deb/

Oh sehr schön, das wusste ich nicht!

Wir haben ein dkms-Paket gebaut, falls dich das interessiert. Aber ab Kernel 4.X ist Batman ohnehin direkt im Kernel.

https://github.com/FreiFunkMuenster/ansible-ffms/blob/entwicklungszweig/roles/interfaces_batman/files/dkms.conf

Der baut es nach jedem Kernelupdate neu.

Grüße
Matthias

1 Like

mittlerweile (seit einer Woche) kompiliere ich Batman direkt aus Git, um ihn Debuggen zu können. Du kannst auch den 4.2er Backports-Kernel verwenden, da ist das richtige Modul direkt da drin.

Eeks. Bedeutet also zwangsweise v15, wenn man einen 4er Kernel fahren will?