"bind: address not available"

Auf einer СPE 210 see ich im Sekundentakt die Logmeldung:

Adding interface wlan0-adhoc-2
bind: Address not available

Mir ist nur klar, dass wlan0-adhoc-2 das Mesh-Netzwerk ist

Dazu steht in /etc/config/network:

config interface ‚wireless0‘
option netmask ‚255.255.0.0‘
option proto ‚static‘
option ipaddr ‚10.22.16.5‘

config rule ‚olsr_tunnel_wireless0_ipv4‘
option lookup ‚olsr-tunnel‘
option priority ‚19999‘
option in ‚wireless0‘

config rule ‚olsr_default_wireless0_ipv4‘
option lookup ‚olsr-default‘
option priority ‚20000‘
option in ‚wireless0‘

config rule ‚olsr_default_unreachable_wireless0_ipv4‘
option action ‚unreachable‘
option priority ‚20001‘
option in ‚wireless0‘

und in /etc/config/wireless

config wifi-iface
option ifname ‚wlan0-adhoc-2‘
option network ‚wireless0‘
option device ‚radio0‘
option mode ‚adhoc‘
option ssid ‚Mesh23‘
option bssid ‚02:ca:ff:ee:ba:be‘
option encryption ‚none‘

Hat jemand einen Tipp was da los sein kann?

Hallo,

welche Firmware welcher Community nutzt du ?

Hedy com Freifunk Berlin

Hallo,

die Berliner sind hier kaum Vertreten.

Es gibt aber ein HowTo Berlin:Firmware/HowTo – wiki.freifunk.net

Alternativ musst du wohl bei einem Treffen dort vorbeischauen. Freifunk Berlin

Viel Erfolg

Ich weiß. Ich dachte, vielleicht hat hier jemand eine Idee.

schoen waere, wenn Du eine Idee haettest, wer die Meldung auswirft. das sind nicht vielleicht noch mehr Meldungen, die einen Prozessnamen mit auswerfen ? Aber das wuerde auch Leuten, die von OLSR Ahnung haben vllt weiterhelfen.
Davon habe Ich keine Ahnung, aber der klassische Einsatz des bind ist die Bekanntgabe ans Kernel, dass ein Prozess an einem NW-Socket horchen moechte und dazu einen Parametersatz wie
AFINET, IPv4, Port 22, INADDRANY
uebergibt, sodass das Kernel entscheiden kann, welche Libraries, Sockets und Netzwerkinterfaces in Frage kommen. Hierbei bedeutet INADDRANY mir ist egal wo der v4 Request an port 22 reinkommt, ich horche ueberall. Das kann man aber genauer spezifizieren, in dem man explizit Adressvorgaben macht. Die kritische Anwendung soll moeglicherweise nicht am Internetport horchen.
Wenn die Adressvorgaben nicht mit der aktuellen NW Config in Einklang zu bringen sind, dann steht das Kernel dumm da und gibt eine Errorcondition an den Aufrufer von bind(2), der dann diese Meldung auswirft.

Es kann sein, dass irgendwo Adressen drin stehen, die es nicht gibt. zB /etc/hosts wenn ein Name verwendet wird und der auf eine grottige Adresse abgebildet wird.
Ich wuerde aber auch alle kritischen Files auf moegliche (unsichtbare) Schmierzeichen untersuchen, das defacto einen Syntaxfehler bedeutet und resultierend der Prozess dann auch Muell an den bind uebergibt.

Das ist glaube ich das einzige, was man so vom gruenen Tisch ohne Kenntnis der Firmware empfehlen kann. Und natuerlich im Netz suchen… aber evtl ergeben sich aus meinem Hinweis weitere Suchmoeglichkeiten. Du kannst mein Geschreibsel auch gerne den Berlinern(?) weitergeben. Manches kommt ja halt auch bei Praktikern nie vor. Aber die wissen dann besser, wo sie suchen koennen.

Huhu, vielen Dank für Deine Erläuterungen. Ich könnte mir
vorstellen, beim allgemeinen Stochern im Nebel, dass IPv6 das
Problem war. Mittlerweile ist die Meldung nämlich wegegangen,
nachdem ich etwas an der config geschraubt habe.

Mal sehen…

1 Like