Client-WLAN aus, Mesh-WLAN an: Wie geht das nochmal per SSH? Gluon2016/ffks

Kurze Frage:

Client-WLAN aus, Mesh-WLAN an: Wie geht das nochmal per SSH? Gluon2016/ffks

Ich hatte das mal irgendwo notiert, finde es aber zu meiner Schande grad nicht wieder… :-/

Hintergrund: Ich möchte den ff-Router, der den VPN-Tunnel nach draußen aufbaut, aus gewissen Gründen nicht als Client-WLAN nutzbar haben. Dieser ff-Router soll lediglich die WLAN-Mesh-Verbindung zu den anderen ff-Routern herstellen und halten.

Hallo,

die beiden UCI-Parameter dazu sind:

wireless.ibss_radio0.disabled='0'
wireless.client_radio0.disabled='0'

Danach

uci commit wireless
wifi

oder statt wifi

reboot

Viele Grüße
Matthias

1 Like

Schönen Dank, Matthias.

Das hatte ich nicht mehr parat.

LG
Jörg

1 Like

Hm, @MPW,

folgendes wirft der ff-Router aus (vor Änderung):

BusyBox v1.23.2 (2016-10-13 20:31:37 CEST) built-in shell (ash)

CHAOS CALMER (Chaos Calmer, r49261)

root@xxx:~# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type=‚mac80211‘
wireless.radio0.hwmode=‚11g‘
wireless.radio0.path=‚platform/qca955x_wmac‘
wireless.radio0.htmode=‚HT20‘
wireless.radio0.channel=‚1‘
wireless.radio0.country=‚DE‘
wireless.radio0.disabled=‚0‘
wireless.mesh_radio0=wifi-iface
wireless.mesh_radio0.ifname=‚mesh0‘
wireless.mesh_radio0.network=‚mesh_radio0‘
wireless.mesh_radio0.device=‚radio0‘
wireless.mesh_radio0.mesh_fwding=‚0‘
wireless.mesh_radio0.mesh_id=‚do-not-connect‘
wireless.mesh_radio0.mcast_rate=‚12000‘
wireless.mesh_radio0.mode=‚mesh‘
wireless.mesh_radio0.disabled=‚0‘
wireless.mesh_radio0.macaddr='xx:xx:xx:xx:xx:xx‘
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname=‚client0‘
wireless.client_radio0.network=‚client‘
wireless.client_radio0.disabled=‚0‘
wireless.client_radio0.device=‚radio0‘
wireless.client_radio0.mode=‚ap‘
wireless.client_radio0.macaddr=‚xx:xx:xx:xx:xx:xx‘
wireless.client_radio0.ssid=‚kassel.freifunk.net
root@xxx:~#

Zum einem ist der UCI-Parameter „wireless.ibss_radio0.disabled=‚0‘“ dort nicht vorhanden oder heißt zumindest dort anders, zum anderen IST da ja schon der UCI-Parameter „wireless.client_radio0.disabled=‚0‘“ schon auf „0“ (und Client-Wifi funktioniert).

Oder ist es so zu verstehen, dass „1“ für Abgeschaltet steht und „0“ für Eingeschaltet?

Also was müsste ich denn jetzt für ein UCI-Kommando absetzen, um Client-Wifi aus und Mesh-Wifi an zu haben?

Sorry, bin da nicht wirklich firm.

LG
Jörg

Also ich würde das einfach mal auf 1 setzen.
Wenn disabled 0 ist, ist es eben nicht disabled, also eingeschaltet.

Das scheint so zu funktionieren. Probiere das jetzt mal ohne

uci commit wireless

, nur

wifi

zum temporären testen mit dem zweiten ff-Router.

Schönen Dank.

Ich glaub das ist eine Firmware, die 11s nutzt, kann das sein?

Puh, Du stellst knifflige Fragen…

Freifunk Kassel · GitHub oder https://freifunk-kassel.de/Firmware beantwortet Dir das vielleicht?

Jo, das ist 11s, Zeile 48.