Crond in neuen Images / SSID-Changer

Moin.
Ich habe ein neues TestImage basierend auf dem aktuellen master gebaut.
Was mir etwas unklar ist weshalb der crond nicht mit startet.
Hintergrund ist das ich gerne den ssid-changer im image hätte - was auch problemlos zu bauen ist - jedoch muss ich im Nachgang manuell eine crontab für root anlegen und den crond über die rc.local starten damit es funktioniert.
Der SSID-Changer liefert ja eigentlich ein crontab mit (lib/gluon/cron/ssid-changer) welcher aber von dem crond nicht gelesen wird.

Folgende Fragen ergeben sich:

  • Wo kann ich dem crond beim bauen des image sagen welche crontabs er liest
  • Wo kann ich einstellen das der service cron automatisch gestartet wird

Evtl hat da jemand ne idee?

Dass der Crond umbenannt wurde, das hast Du mitbekommen?

habe ich im image gesehen…ja aber der cron ist ja trotzdem noch da…

/usr/sbin/crond - wird aber halt nicht genutzt…sieht aber so aus als ist der aus der busybox

aber guter ansatz…dann baue ich den crontab halt nach /usr/lib/micron.d

Wobei…ein full-replacement wäre es ja nur wenn der micrond dann auch die /etc/crontab xyz mit liest…

Alles klar… neue version ist gebaut und läuft. jetzt gehts in die testphase

zu finden hier im git: GitHub - AKA-47/gluon-ssid-changer: Fork of ssid-changer to work with 2015.2 and micrond

1 Like

Da ich die Aaachener Version (auch die vom Master und die vom „Chaos-Calmer“-Branch) nicht gebaut bekommen habe gegen den aktuellen Gluon-Master (konnte nicht mit integriert werden, egal auf welchem Commit-Stand), versuche ich mich jetzt mal an dieser hier.

Fix von @aka47 ist jetzt in der Aachener Version drin (Branch chaos-calmer)

Noch ungetestet

sehr schön. Testergebnisse willkommen. Meine builds laufen aber problemlos

Ich habe das gestern mal gemeinsam mit dem „autoupdater-wifi-fallback“ von ffho versucht.
Leider wollte der Knoten weder auf die offline-SSID schalten noch hat er während der letzten 24h einen Updateversuch unternommen, zumindest bleibt das syslog leer. (Bei einer Rekonfiguration des wifis sollte da eigentlich was zu lesen sein.)

Aber vermutlich ist da was schief. Siehe Freifunk Düsseldorf Flingern Firmware Seite

Bau doch mal ein logger ein unter:
/lib/gluon/ssid-changer/ssid-changer.sh

direkt oben nach #!/bin/sh
logger „EXECUTING OFFLINE CHECK“ #Write Info to Syslog

Das sollte dann jede minute per logread zu lesen sein…ansonsten läuft der cron nicht richtig

Was kommt denn wenn du folgendes machst dabei rum?
batctl gwl | grep „^=>“ | awk -F’[()]’ ‚{print $2}‘| tr -d " "

Das ssid-script läuft… allein, das Problem ist wirklich die Kombination mit Wifi-Autoupdater-Fallback. Sobald der mit drin ist, wirft der ssid-changer irgendwelche ash-fehler.
Sollte man evtl. ineinander integrieren.

1 Like

Ich habe heute ein Image mit der angepassten Version gebaut und es funktioniert:

Sat Jan 16 00:24:01 2016 user.notice gluon-offline-ssid: TQ is 133, SSID is FF_OFFLINE_ffac-MM-Testknecht, change to Freifunk

Das Problem das ist beim bauen hatte bestand primär darin den richtigen commit auszuwählen. Ich habe den Eindruck es ist notwendig die default branch zu verwenden oder kenne hier eine Option nicht?

Die Datei modules im site Verzeichnis sieht daher nun so aus und bezieht sich auf einen fork in dem die chaos chalmer Variante die default branch ist:

GLUON_SITE_FEEDS="ssidchanger"
PACKAGES_SSIDCHANGER_REPO=https://github.com/mmalte/gluon-ssid-changer.git
PACKAGES_SSIDCHANGER_COMMIT=bf47360bbee3798f4f36651e5be81fff35495b09

Am besten nach dem make update in den ordner packages/ssidchanger/ schauen ob alles richtig aktualisiert wurde.

Die Ergebnisse für Aachen liegen hier:
https://images.aachen.freifunk.net/experimental/factory/20160115-chaos-calmer/

Dort habe ich meine Antwort auf:

gefunden.

PACKAGES_SSIDCHANGER_REPO=https://github.com/ffac/gluon-ssid-changer
PACKAGES_SSIDCHANGER_COMMIT=bf47360bbee3798f4f36651e5be81fff35495b0
PACKAGES_SSIDCHANGER_BRANCH=chaos-calmer

Hätte mich auch sehr gewundert wenn das nicht möglich gewesen wäre.

Habe den ssid changer heute auch in unsere Firmware eingebaut. Hat nach Beseitigung meiner Tippfehler dann auch geklppt :wink:

Es wird jedoch nur die 2.4 GHz SSID umbenannt. Gibt es eine Version, die auch die 5 GHz SSID berücksichtigt? Oder liegt es daran, dass 2.4 und 5 GHz bei mir unterschiedliche SSID Namen haben?

An unterschiedliche Namen habe ich nicht gedacht.

Dafür muss das Skript erweitert werden.

Ich habe die 5Ghz ssid über uci Befehl jetzt angepasst. Beide ssid´s haben den gleichen Namen. Die 5GHz ssid wird aber dennoch nicht umbenannt. Getestet habe ich mit einem WDR3600. Oder muss ich die Firmware neu backen, dammit es funktioniert?

Nachtrag: Nach dem Aus- und Einschalten des Routers geht es, wenn die wifi24 und wifi5 SSIDs gleich sind. Anscheinend war ein reboot hier nicht ausreichend.

ssid changer unterstützt jetzt generische ssid … also diejenigen die aus
uci get laberlaber.client0.ssid rausfallen (oder so ähnlich) :slight_smile:

1 Like

Ich sehe da seit Dezember keinen Commit in der Richtung.

In „client0.ssid“ findet sich (davon gehe aus) die SSID für’s 2,4GHz-Band, oder schlicht die vom ersten Radio.
(Ob es Gluon-Profile mit mehreren 2,4er-Bändern gibt weiss ich nicht. Wäre Interessant, aber anderes Thema)
Die Problematik von @steneu („Freifunk“ und „Freifunk (5GHz“ als Start-SSID) ist damit noch offen, wenn ich es richtig einschätze, oder?

Schau mal ins original Repo, da sind die Änderungen drin:

Ich habe auch ein Issue für das Problem mit zwei verschiedenen SSID angelegt:

ich würde vermuten das die anderern Bänder dann auf den geräten als client1 client2 etc generiert wird und das könnte man dann leicht mit in ein array schreiben. das kann ich aber mangels hardware nicht prüfen

Ja, client1 ist das zusätzliche Interface.