EdgePoint Router

Hallo,

wir haben uns hier bei Freifunk Nordwest die neuen EdgePoint Modelle zugelegt. Konkret den EP-R6, welcher nicht wie der EP-S16 als Switch arbeitet, sondern als Router fungiert.

Nun habe ich Schwirigkeiten ihm VLANs beizubringen. Hat da schonmal jemand Erfahrungen gemacht? Die Konfiguration muss jedenfalls über CLI gehen, über das Webinterface habe ich schon alles ausprobiert. VLANs anlegen ja, aber ich bekomme leider keine Verbindung zwischen den Ports.

LG
Adrian

Du musst dir den Komfort der VLAN Konfiguration eines Switches quasi über Bridges nachbauen.

Möchtest du sagen wir mal vlan100 haben welches auf den Ports 1 und 2 untagged und auf den Ports 3 und4 tagged anliegt brauchst du folgende Konfiguration:

  • Eine Bridge mit beliebigem Namen (hier zb. br100)
  • eth1 und eth2 konfigurierst zu direkt als Bridgemember in br100
  • bei eth3 und eth4 legst du jeweils ein vif mit der vlan ID 100 an.
  • die beiden Interfaches eth3 vif100 und eth4 vif100 machst du nun ebenfalls zu Bridgemember in br100

Somit sind eth1 und eth2 nun untagged im vlan100 und eth3 und eth4 tagged.
Die Config lässt sich beliebig erweitern indem auf dem Router weitere bridges und dann VIFs je port angelegt werden.

Hoffe die Infos helfen dir soweit erstmal.

Grüße,

Mattheus

1 Like

Danke @tioan für deine antwort. So oder so ähnlich war auch mein bisheriger Ansatz, welchen ich verfolgt habe. Die Bridgen haben aber bei mir nie zueinander gefunden und ich muss sagen, dass ich nie wirklich den durchblick habe, welche Port nun zu welcher internnen Schnittstelle eine bridge macht. So gabs bei mir oft nur Fehlermeldungen, als wirkliche Resultate.

Aus Verzwiflung hab ich dann versucht ganz neue Wege zu finden und bin auf ein Tutorial gestoßen, welches bereits veraltet ist, mich aber neuen Input gegeben hat, es nochmal auf dem Webiterface es auszuprobieren.

Nach einem Update auf die Version 1.9.0 gabs sogar einen Wizard ‘Switch’, welcher den Router in die Lage versetzt, eth0 bis eth4 mit VLAN zu switchen. Leider lässt der Wizard den SFP-Port hinten rausfallen. Daher hier meine Anleitung:

  1. Zuerst legt man im Dashboard unter ‘switch0’ Action --> Config --> Vlan für sich die VLANs an. Damit man die Tags eintragen kann, Enabled man ‘VLAN Aware’ und trägt alle Werte wie gewünscht ein. pvid steht für untagged und vid für tagged. Bei mir sah das ganzen dann so aus:

Aufpassen: Damit man sich nicht selbst ausschließt, eth0 erst unkonfiguriert lassen

2 Da ich aus einer VLAN heraus gerne die Weboberfläche erreichen möchte, lege ich noch ein zusätzliches Interface an. Dazu auf dem Dashboard ‘Add Interface’ --> VLAN auswählen. VLAN ID aus der ich die WebUI erreichen möchte, Interface ‘switch0’ und als IP, die IP, unter der der Switch erreichbar sein soll. z.B. 192.168.2.17/24 …und ‘save’

3 Nun kann man den Switch unter der IP im VLAN erreichen. Sobald man wieder Zugriff hat, bei ‘eth0’ Action --> Config ‘No Adress’ auswählen und so die Standart IP löschen.

4 Unter der VLAN-config kann anschließend dann ‘eth0’ so wie in meinem ersten Screenshot konfigurieren.

Thats it, ein VLAN Outdoor PoE Switch :blush:

1 Like

Diesen Wizard gibt es allerdings nur für die ER-X Plattform also Edgerouter X, Edgerouter X SFP und den kleinen Edgestation Router, nicht für die “alten” Edgerouter Lite, PoE und Pro.

Die Variante mit den Bridges funktioniert sowohl auf ER als auch ER-X Plattform.

Hat jemand Gluon auf diesem Teil am Laufen?

hi

Sollte exakt baugleich zum ER-X-SFP sein und daher genauso wie dieser zu handeln sein.

Gruß

Christian

Im Aussenbereich haben wir hier einen EdgePoint mit Gluon für ER-X-SFP am laufen.
Wenn ich mich recht erinnere, dann hat sich die Stockfirmware gegen das Flashen der ER-X-SFP-Freifunkfirmware gewehrt.
Letztendlich haben wir den EdgePoint dann per serieller Schnittstelle und TFTP überreden können.

Danke an alle für die Info!