Freifunk und TP Link WA 850 Repeater


#27

der Button eignet sich übriges vorzüglich für ioT Anwendungen!
Wir haben mit speziell abgespeckter Firmware (ohne opkg und ohne luci; nur minimal-weboberfläche für anzeige der wlan-nachbarn) geschafft, curl inkl. polarssl zu installieren… Damit kann der Button nun schonmal Telegram Nachrichten (als bot) absetzen! Je nach Länge des Tastendruckes kann man auch unterschiedliche Dinge passieren lassen :smile:


#28

Weiß jemand was es mit dem WA860RE v2 auf sich hat? Wird der nicht in Europa ausgeliefert?


#29

zwischen meinen Testgeräte habe ich jetzt einen WA850v2 “gefunden”.
Derzeit von Openwrt noch nicht unterstützt soll es sich lt https://wiki.openwrt.org/toh/tp-link/tl-wa850re quasi um eine 841v10 handeln (natürlich mit nur einem LAN-Anschluss)
Also Vorsicht beim Einkaufen!


#30

Da wird es schlicht jemanden brauchen, der davon 1-2 Geräte als Spende(!) zur Analyse nach Schleswig-Holstein verschifft.
Zumindest hat das in Vergangenheit gut geklappt.


#31

Bestätige die Funktion eines 850RE v1, läuft seit 'nem halben Jahr stabil: https://map.md.freifunk.net/#!v:m;n:14cc200bd333

Von Reichelt hab ich heute aber 'nen 850RE v2 bekommen. Mal sehen, ob ich den die Tage halbwegs zerstörungsfrei öffnen kann?!


#32

Der 850RE v2 lässt sich nicht zerstörungsfrei öffnen. Das Gehäuse ist wohl per Ultraschall verschweißt worden. Verständlich, wenn man direkt neben den 230V operiert.

Die Stock-Software wirkt modern, im WebGUI kann man aber nur die für einen Repeater absolut nötigen Dingen einstellen. Neben dem Webserver läuft laut nmap noch ein älterer dropbear 2012.55, Verbindungsaufbau klappt mit den credentials aus der Weboberfläche, man bekommt aber keine Shell.

Muss also wohl der Dremel her …


#33

Ultraschallverschweissung ist sicher und vor allem ein besser kontrollierbarer Prozess als Kleben.
(Auch wenn das Equipment erstmal ordentlich teuer ist. Dafür hat man halt “feedback” aus dem Prozess der hinausgeht über “x Milliliter Kleber verbraucht für Gerät z”. Man kann die eingebrachte Energiemenge monitoren.
Und bei schlechtem Werkzeugkontakt (warum auch immer) ist es messbar und man kann das Stück sofort aussondern.

Was den 850RE anbelangt: “In the name of science” werden wir da wohl ein paar Geräte opfern müssen.


#34

Wenn es sich beim 850v2 wie o.g. um einen 841v10 handeln sollte, könnte man erste Testfirmwares auch ohne öffnen probieren (dem TPlink Namensschema folgend).

Dass sich das Ding nicht zerstörungsfrei öffnen läßt, können wir bestätigen: Wir hatten einen fast baugleichen 854v1 letztens öffnen müssen (immer an der Kante entlang!), da wir uns beim Testen mit den zwei Buttons (dummerweise inkl. RESET Button) ausgesperrt hatten.
Warum gleich “ein paar Geräte”? Sicher unnötig :-o

Bis dahin empfiehlt es sich, konkret den 850v1 zu verwenden/kaufen!
Für Bastelwillige sei nochmals der 854v1 erwähnt. Ohne LAN-Anschluss ist der nochmal etwas billiger, dafür kniffeliger zu installieren (mit einer firmware ohne wizard, also zb gluon mit skip-config-mode oder halt mit meshkit). ABer das gehört vielleicht in eine eigene Diskussion?


#35

Dass sich das Ding nicht zerstörungsfrei öffnen läßt, können wir
bestätigen: Wir hatten einen fast baugleichen 854v1 letztens öffnen
müssen (immer an der Kante entlang!), da wir uns beim Testen mit den
zwei Buttons (dummerweise inkl. RESET Button) ausgesperrt hatten.

Mit welchem Werkzeug habt Ihr das dann gemacht? Scharfes Cuttermesser? Dremel? Irgendwas anderes? Ging das gut?


Verschweisste Gehäuse öffnen
#36

Die Originalfirmware (EU) vom V2 verweigert (Fehler 18005 “FCC”) das Flashen einer entsprechenden Lede-Firmware (hwid 08500200 bzw. 085000002) Serielle Konsole hatten wir angeschlossen, allerdings kam da nichts (vielleicht kabelproblem bei uns)

Wer auch ein offenes Gerät hat, bitte poste mal seriellen Bootlogs der original-Firmware!


#37

Ist das »FCC« jetzt Zufall, oder das erwartete Ende von freier Firmware auf Geräten mit Funkschnittstelle?


#38

das FCC ist ein Kommentar von mir und wurde natürlich nicht so direkt in der Stock_Firmware angezeigt.

Bitte schicke mal einen bootlog der seriellen Konsole. (wahrscheinlich ist mein Seriell-Adapter ist kaputt)


#39

Nicht notwendigerweise. Ich hab grad mal mit Multimeter GND und VCC rausgefunden. Wenn man von der Schraube bzw. dem Flash (winbond 25q32fvsig) aus schaut, ist die Stiftleiste so belegt (1 der auf der Unterseite viereckige bzw. markierte Pin): VCC (4), GND (3), ?X (2), ?X (1). Im laufenden Betrieb mess ich zwischen VCC und TX/RX 0V und zwischen GND und TX/RX auch 0V, d.h. die scheinen in der Luft zu hängen. Auf meinem Board sind R101 und R105 nicht bestückt, das scheinen Serienwiderstände von den Pins aus zu sein, R101 von Pin 2 und R105 von Pin 1. R101 sieht aus wie ein 0402 (?), der andere ist noch kleiner. Von R101 aus gegen Masse ist noch ein 1k (gemessen) pull down bestückt, auch 0402 (?), aber ich kann den Print nicht direkt zuordnen, könnte R102 aber auch R80 sein. Auf der anderen Leitung ist der Pull-Down auch kleiner, also wie Staub, aber nicht bestückt. Ich würde als nächstes also den Serienwiderstand von Pin 2 aus einlöten und dann mal schauen, ob das TX ist, dann hätte man zumindest mal die Ausgabe auf der Konsole, auch wenn man nichts eingeben könnte.

Würde es alternativ helfen den Flash auszulöten und in einem anderen System einen Dump davon zu machen?


#40

Im OpenWRT Forum war da jemand schon deutlich weiter, da sieht man auch ein brauchbares Bild von der Platine: https://forum.openwrt.org/viewtopic.php?id=67530


#41

Und, hat das etwas gebracht? Was ist denn dort eigentlich?

Laut neueren Tests https://plan.leipzig.freifunk.net/issues/382 handelt es sich vielleicht um sowas ähnliches wie den Safeloader von Tplink. Da könnten wir auch mal Matzthias Schiffer befragen, oder ein lede-ticket aufmachen?


#42

hallo. ich hab so nen TL-WA850RE v2 daliegen. hat sich da was getan zwecks FF firmware flashen??


#43

Es hat vermutlich niemand Geräte gespendet.


Add Gluon Support: Aufgeteilter Prozess Meinungsabfrage
#44

Doch, doch! Wir haben mehrere Geräte der Entwicklung “gespendet” und uns an der internen seriellen Schnittstelle probiert.
Parallel dazu hat es ein anderer LEDE Entwickler geschafft, wir haben das an unseren Geräten auch schon ausprobiert.

Geht seit ca. 6 Wochen also mit LEDE-trunk… und bei uns dementsprechend auch schon direkt mit Freifunk

https://github.com/lede-project/source/pull/808

die pure LEDE Firmware inkl. Imagebuilder/SDK (wie sicher bekannt) unter https://downloads.lede-project.org/snapshots/targets/ar71xx/generic/


#45

weiss jemand, ob der wa860re v2 dem wa850re v2 entspricht?

[Update] - ich weiss, jetzt, warum der wa860re v2 images aus dem gpl-code mit checksum error ausgespuckt hat.

Die Firmware-Upgrade routine checkt das image auf:
support-list, 0x003c3000, 0x00001000, 0, 2, 2, 0, /usr/src/tp-link/860rev2_gpl_code/images/860rev2/FlashMaker/860rev2_eu/supportlist.bin

per default ist da nur:
{product_name:TL-WA860RE,product_ver:2.0.0,special_id:00000000}

eingetragen.
Nachdem die Einträge:
{product_name:TL-WA860RE,product_ver:2.0.0,special_id:55530000}
{product_name:TL-WA860RE,product_ver:2.0.0,special_id:45550000}
{product_name:TL-WA860RE,product_ver:2.0.0,special_id:4B520000}
{product_name:TL-WA860RE,product_ver:2.0.0,special_id:42520000}
{product_name:TL-WA860RE,product_ver:2.0.0,special_id:4A500000}
{product_name:TL-WA860RE,product_ver:2.0.0,special_id:43410000}

dazukamen, liess sich der WA860RE v2 klaglos über das Webinterface flashen.

binwalk:
DECIMAL HEXADECIMAL DESCRIPTION

22148 0x5684 U-Boot version string, "U-Boot 1.1.4 (Apr 22 2017 - 15:57:06)"
22196 0x56B4 CRC32 polynomial table, big endian
23500 0x5BCC uImage header, header size: 64 bytes, header CRC: 0x9666173D, created: 2017-04-22 13:57:08, image size: 33758 bytes, Data Address: 0x80010000, Entry Point: 0x80010000, data CRC: 0x347EB005, OS: Linux, CPU: MIPS, image type: Firmware Image, compression type: lzma, image name: "u-boot image"
23564 0x5C0C LZMA compressed data, properties: 0x5D, dictionary size: 33554432 bytes, uncompressed size: 87356 bytes
57323 0xDFEB TP-Link firmware header, firmware version: 0.0.0, image version: “”, product ID: 0x0, product version: 0, kernel load address: 0x0, kernel entry point: 0x80002000, kernel offset: 0, kernel length: 512, rootfs offset: 733076, rootfs length: 0, bootloader offset: 0, bootloader length: 0
57835 0xE1EB LZMA compressed data, properties: 0x5D, dictionary size: 33554432 bytes, uncompressed size: 2093448 bytes
790912 0xC1180 Squashfs filesystem, little endian, version 4.0, compression:lzma, size: 2737777 bytes, 581 inodes, blocksize: 1048576 bytes, created: 2017-04-22 14:17:16


#46

ich habe gestern bei Saturn im Laden neben dem 850v2 einen ersten 850v4 gesehen :-/

Upps, und mit einem peinlichen Tippfehler direkt auf der Verpackung, das läßt vielleicht auch nichts gutes in Bezug auf die Firmware/Flash ahnen!