[Gelöst] MeshViewer lädt nicht - sieht jemand den Fehler?

Moin,

ich habe gerade analog zum Münsteraner Kartenserver, einen für das Emscherland aufgesetzt. Wider erwarten will das Ding aber nicht: https://karte.freifunk-emscherland.de/maps/map01/

  • Im Log das nginx sind keine Fehler zu sehen, es fällt allerdings auf, dass er die graph- und nodes.json gar nicht probiert zu laden. Die error.log hat keine Einträge dazu.
  • In der Konsole des Browsers sehe ich keine Fehlermeldung

Mir fehlt gerade etwas der Ansatzpunkt. Hat jemand eine Idee, woran es hängen könnte?

Grüße
Matthias

ich bin mir gerade nicht sicher, ob dataPath in der config.json relative Pfade erlaubt…
hast du mal ne komplette Base-URI dort reingeschrieben?

"dataPath": "https://karte.freifunk-emscherland.de/maps/data01/"

Ja, das dürfte es sein. Am besten den absoluten Pfad zum Datenverzeichnis angeben, dann sollte es gehen.

Interessante Idee. Aber das ist bei uns auch so, funktioniert eigentlich ohne Probleme:

https://karte.freifunk-muensterland.org/map01/config.json
https://karte.freifunk-muensterland.org/map01/

Grüße
Matthias

Man soll ja Tipps, die einem gegeben werden, nicht ignorieren. Ich habe es gerade einfach mal kurz reingeschrieben, behebt das Problem leider nicht:

https://karte.freifunk-emscherland.de/maps/map01/config.json
https://karte.freifunk-emscherland.de/maps/map01/

Euer Datenverzeichnis, in dem die nodes.json liegt, liegt nicht unterhalb des Ordners „map01“. Bei eurer Konfiguration müsst ihr wahrscheinlich CORS aktivieren oder den Datenpfad anders legen.

CORS

Also die Gesamtkarte geht jetzt schon mal:

https://karte.freifunk-emscherland.de/map/

Die Einzelkarten immer noch nicht.

Okay, ich hab mal ein wenig experimentiert:

https://karte.freifunk-emscherland.de/map_test/

Geht auch. Das ist die Karte der Domäne 01, allerdings ohne Symlinks. Die mapXX-Ordner haben nur Symlinks auf die Hauptkarte, damit das eigentliche Programm nicht mehrfach vorgehalten werden muss. Scheinbar kommt nginx in dieser Konfiguration damit nicht klar. Auf unserem Server ist das kein Problem gewesen.

Weiß jemand, wie ich nginx beibringe, dass es auch Symlinks folgen darf?

root@services /var/www/html/maps # ls -al map
insgesamt 4,5M
drwxr-xr-x  6 root root 4,0K Sep  7 15:03 .
drwxr-xr-x 24 root root 4,0K Sep  7 15:34 ..
-rw-r--r--  1 root root 599K Sep  7 11:59 app.js
-rw-r--r--  1 root root 5,0K Sep  7 15:03 config.json
drwxr-xr-x  2 root root 4,0K Sep  7 11:41 css
drwxr-xr-x  2 root root 4,0K Sep  7 11:41 fonts
drwxr-xr-x  2 root root 4,0K Sep  7 11:41 images
-rw-r--r--  1 root root  553 Sep  7 11:59 index.html
-rw-r--r--  1 root root 3,8M Sep  7 11:59 nodes.json
-rw-r--r--  1 root root  11K Sep  7 11:59 roboto-fontface.css
-rw-r--r--  1 root root 2,1K Sep  7 11:59 roboto-slab-fontface.css
-rw-r--r--  1 root root  16K Sep  7 11:59 style.css
-rw-r--r--  1 root root  14K Sep  7 11:59 style.css.map
drwxr-xr-x  3 root root 4,0K Sep  7 11:41 vendor
root@services /var/www/html/maps # ls -al map_test/
insgesamt 4,5M
drwxr-xr-x  6 root root 4,0K Sep  7 15:35 .
drwxr-xr-x 24 root root 4,0K Sep  7 15:34 ..
-rw-r--r--  1 root root 599K Sep  7 15:34 app.js
-rw-r--r--  1 root root 5,0K Sep  7 15:34 config.json
drwxr-xr-x  2 root root 4,0K Sep  7 15:34 css
drwxr-xr-x  2 root root 4,0K Sep  7 15:34 fonts
drwxr-xr-x  2 root root 4,0K Sep  7 15:34 images
-rw-r--r--  1 root root  553 Sep  7 15:34 index.html
-rw-r--r--  1 root root 3,8M Sep  7 15:34 nodes.json
-rw-r--r--  1 root root  11K Sep  7 15:34 roboto-fontface.css
-rw-r--r--  1 root root 2,1K Sep  7 15:34 roboto-slab-fontface.css
-rw-r--r--  1 root root  16K Sep  7 15:34 style.css
-rw-r--r--  1 root root  14K Sep  7 15:34 style.css.map
drwxr-xr-x  3 root root 4,0K Sep  7 15:34 vendor
root@services /var/www/html/maps # ls -al map01
insgesamt 12K
drwxr-xr-x  2 root root 4,0K Sep  7 15:32 .
drwxr-xr-x 24 root root 4,0K Sep  7 15:34 ..
lrwxrwxrwx  1 root root   13 Sep  7 11:42 app.js -> ../map/app.js
-rw-r--r--  1 root root 1,8K Sep  7 15:32 config.json
lrwxrwxrwx  1 root root   10 Sep  7 11:42 css -> ../map/css
lrwxrwxrwx  1 root root   12 Sep  7 11:42 fonts -> ../map/fonts
lrwxrwxrwx  1 root root   13 Sep  7 11:42 images -> ../map/images
lrwxrwxrwx  1 root root   17 Sep  7 11:42 index.html -> ../map/index.html
lrwxrwxrwx  1 root root   26 Sep  7 11:42 roboto-fontface.css -> ../map/roboto-fontface.css
lrwxrwxrwx  1 root root   31 Sep  7 11:42 roboto-slab-fontface.css -> ../map/roboto-slab-fontface.css
lrwxrwxrwx  1 root root   16 Sep  7 11:42 style.css -> ../map/style.css
lrwxrwxrwx  1 root root   20 Sep  7 11:42 style.css.map -> ../map/style.css.map
lrwxrwxrwx  1 root root   13 Sep  7 11:42 vendor -> ../map/vendor

(Die ersten beiden gehen, die letzte nicht.)

Disable symlink off in der Nginx Config setzen:

/etc/nginx/nginx.conf

[code]http {

disable_symlinks off;

[/code]

Die Zeile gibt es da nicht. Der Standardwert müsste doch sein, dass es aktiviert ist, also Symlinks zugelassen sind, oder?

Nein genau andersrum.

Einfach die Zeile so reinschreiben.

forsche mal bitte in eine komplett andere Richtung!
Der Inhalt der config.json unter /map01/ parsed gar nicht mal als valides JSON … Ist mir gerade unter Firebug aufgefallen… Da existiert nämlich das Tab „JSON“ nicht neben dem „Response“-Tab …

EDITH: Komma zuviel hinter { "site": "ffeld08", "name": "Domäne 08 - Spezialprojekte" },
Mach dat wech und es wird gehen… :eyes:

P.S: und die antiquierte Nginx Version ersetzt ihr aber auch noch vor dem Livegang, oder? :wink:

Danke, das war’s!

War nicht geplant, ist ganz normal Debian 8. Gibt es da Sicherheitslücken, von denen ich wissen sollte? Ich bin eigentlich davon ausgegangen, dass Debian nicht auf dem neuesten aber einem sicheren Stand ist?

Sicherheitslücken meines Wissens nicht - aber Debian-Policy ist leider auch, dass zur „Stabilität“ eines Pakets gehört, dass man sich drauf verlassen kann, dass kaputte Dinge auch kaputt bleiben… gefixed/backported wird dort ausschliesslich Security(-Fixes) …
Und zwischen 1.6.x und aktuell 1.10.x ist schon so einiges an Zeit und Features ins Land gegangen…

curl https://nginx.org/keys/nginx_signing.key | apt-key add -
echo "deb http://nginx.org/packages/debian/ jessie nginx"> /etc/apt/sources.list.d/nginx.list

( alternativ: deb http://nginx.org/packages/mainline/debian/ jessie nginx für die »mainline« statt »stable« Version - die hat z.B. auch schon RSA- mit ECDSA-Key parallel für die TLS-Konfiguration…)

Wenn du genauer hinsiehst, die MeshViewer-Version ist auch etwas älter schon. Da gibt es auch schönere Funktionen inzwischen. Es ging erstmal nur darum, dass das läuft.

Eine neue Version würde bedeuten, dass an der Ansible-Konfiguration auch einiges geändert werden müsste. Das ist auch auf dem Plan, aber derzeit habe ich keine Zeit dafür. Es sollte erstmal nur die Karte grob laufen.

1 Like