Gluon Beta 2014.4 (Rheinufer, nun mit richtigem Version Tag )

Fortsetzung der Diskussion von Gluon 2014.4 als Beta Version verfügbar (Rheinufer), formerly known as „2014.3.1“:

Damit ich einschätzen kann, auf welchem Stand dieser Build ist (der zumindest bei mir zur vollsten Zufriedenheit funktioniert seit einer Woche): Wann war denn der Checkout aus dem Master? (Datum?)

Zumal ich den WA850RE nur ungern wieder ausser Betrieb nehmen möchte (und der ja erst im 2014.4. in den Support gekommen ist.)

Hey :smile:

Der Commit war von 20.Oct. Daher auch die Verwirrung bei den Checks: Die ersten Commits sind identisch im log ;).
Ich baue gerade Beta 2014.4 (also die momentane Version mit richtigem Version Tag). Für 2014.3.1 werde ich einen gesonderten Thread machen wenn Testversionen vorliegen.
Generell wollte ich den Beta Branch dann nur für 2014.4 nutzen. 2014.3.1 testen wir dann vorerst ohne Autoupdater manuell.

Gruß
Cyrus

Edit: Habe den Titel mal auf 2014.4 geändert damit es keine Verwirrung gibt :slight_smile: . Hoffe das ist OK so.

1 Like

So die Version wurde neu gebaut und ist jetzt korrekterweise auch „2014.4“. Alle Nodes die Beta als Branch im Autoupdater konfiguriert haben sollten sich in den nächsten 48Std automatisch updaten.
Es ist exakt die gleiche Version nur mit dem geänderten Version Tag.

Die Images gibts hier: Gluon Beta 2014.4 - Rheinufer

1 Like

Hi Fragstone,

Was funktioniert denn genau nicht?
Das Image ist das gleiche wie zuvor nur mit einem anderen Namen. Ich habe auf meinen Geräten keine Fehler feststellen können.

Gruß
Cyrus

Zumal es laut Alfred durchaus Geräte gibt, auf denen es zu laufen scheint:
http://ffmap.freifunk-rheinland.net/alfred.html

ffac-acmitte-jakobstr28-out1 2014.4-beta-1 Ubiquiti Bullet M beta
ffac-acmitte-jakobstr28-out2 2014.4-beta-1 Ubiquiti Bullet M

Da ward ihr wohl schneller als mir lieb ist. Eigentlich habe ich den Beitrag gelöscht. Denn es war mal wieder ein „DAU“ am Werk … diesmal wohl ich :smile:

Habe die neue FF Rheinufer FW mit einer FF Ruhrgebiets Config probiert :smile:

Aber im Gegensatz zu früher hat der Router überhaupt nichts gesagt.
Jetzt läuft er wieder mit einer funktionierenden (passenden) Firmware.

Gruß
Thomas

1 Like

Nee, ist doch völlig o.k „so“. Aus den Fehlern anderer lerne ich eigentlich sogar lieber :wink:

1 Like

Ich möchte meine Beobachtung noch mal hier posten, damit es nicht den Weg in die Stable findet…

Obwohl in /tmp/resolv.conf.auto der nameserver 2001:470:20::2 steht, wird das log mit folgenden Meldungen vollgeschrieben:

Wed Nov 12 11:32:10 2014 daemon.warn dnsmasq[1282]: no servers found in /tmp/resolv.conf.auto, will retry
Wed Nov 12 11:32:14 2014 daemon.info dnsmasq[1282]: reading /tmp/resolv.conf.auto
Wed Nov 12 11:32:14 2014 daemon.info dnsmasq[1282]: using local addresses only for domain lan
Wed Nov 12 11:32:14 2014 daemon.info dnsmasq[1282]: using nameserver 2001:470:20::2#53
Wed Nov 12 11:32:45 2014 daemon.warn dnsmasq[1282]: no servers found in /tmp/resolv.conf.auto, will retry
Wed Nov 12 11:32:47 2014 daemon.info dnsmasq[1282]: reading /tmp/resolv.conf.auto
Wed Nov 12 11:32:47 2014 daemon.info dnsmasq[1282]: using local addresses only for domain lan
Wed Nov 12 11:32:47 2014 daemon.info dnsmasq[1282]: using nameserver 2001:470:20::2#53

Ich bin mir nicht sicher, ob es allgemein an der Beta liegt, oder an der Beta in Zusammenhang mit einem WA750, auf dem ich die Beta laufen habe.
Auf anderer Hardware setze ich die Beta nicht ein.

Hat jemand ähnliche Beobachtungen gemacht?

Das ist leider derzeit angeblich nicht zu ändern, weil „so in dem zugrundeliegenden Openwrt“.

ok, dann weiß ich bescheid und wechsle mit meinen 2014.3ern nicht zu 2014.4. Ich finde das zumüllen des Logs untragbar.

Ich habe eine neue Experimental-Version gebaut, die hier jetzt seit Mittag auf mehreren Routern unterschiedlicher Hardware läuft, auch im Mesh (vpn/wifi). Denke also dass sie funktioniert.

Download unter:
http://www.nadeshda.org/ff/gluon-rheinufer/

neuer fastd16 mit „umac“ ist drin, wenn die Supernodes es denn freischalten (läuft in ff-ruhrgebiet schon).

Mögliches Issue: Direktinstallation auf diese Version (auch sysupgrade, aber eben ohne Parameterübernahme) könnte ein Problem sein, evtl. etwas mit der fastd-Schlüsselerzeugung.

Siehe auch
http://www.nadeshda.org/ff/niemandsland-kiefern-nadeshda-wolke.html
(die nadeshda.org-gelabelten)

2 Likes

Also genau Deinen Effekt da oben habe ich nicht.
Dafür aber aber

root@nadeshda:~# logread -f
Fri Nov 21 16:48:36 2014 daemon.info dnsmasq[1207]: reading /var/gluon/wan-dnsmasq/resolv.conf
Fri Nov 21 16:48:36 2014 daemon.info dnsmasq[1207]: using nameserver fd00::be05:43ff:fe32:6f5d#53
Fri Nov 21 16:48:36 2014 daemon.info dnsmasq[1207]: using nameserver 192.168.138.1#53
Fri Nov 21 16:48:49 2014 daemon.info dnsmasq[1207]: reading /var/gluon/wan-dnsmasq/resolv.conf
Fri Nov 21 16:48:49 2014 daemon.info dnsmasq[1207]: using nameserver fd00::be05:43ff:fe32:6f5d#53
Fri Nov 21 16:48:49 2014 daemon.info dnsmasq[1207]: using nameserver 192.168.138.1#53
Fri Nov 21 16:49:05 2014 daemon.info dnsmasq[1207]: reading /var/gluon/wan-dnsmasq/resolv.conf
Fri Nov 21 16:49:05 2014 daemon.info dnsmasq[1207]: using nameserver fd00::be05:43ff:fe32:6f5d#53

Also kein Fehler, aber viel Log trotzdem.

Ich habe jetzt so diverse neue Hardware mit dem Master (gestern gezogen) zu laufen:
TP-Link TL-MR3020 (USBpowered WISP-Router)
TP-Link TL-MR3040 (Battery powered 3G/LTE-Router)
TP-Link TL-WR710Nv1 (WallPlug WISP/3G-Router)
TP-Link TL-WA850RE (WallPlug Mimo-Repeater)
TP-Link CPE210 (Outdoor AP 2,4GHz)

Dazu die üblichen WR841N/841ND (V7,v8), Ubiquiti Nanonsation/LocoM2 (Bullet/Nano),
für „ffruhr“ laufen auch ein TL3600 und WR740v4 mit der dortigen Site.conf.
Die Verbesserungen im Wifi bei den AR-Chipsätzen sind meines Gefühls nach auch sichtbar.
Wer die experimentals testen mögen sollte.

Rheinufer: (factory und Sysupgrade)
http://www.nadeshda.org/ff/gluon-rheinufer/2014.4exp4/

Ruhr: (nur sysupgrade)
http://www.nadeshda.org/ff/gluon-ruhr/sysupgrade/

Sieht alles ganz gut aus so weit ich es bislang beurteilen kann.
http://[2a02:f98:0:28:eade:27ff:fece:b782]/cgi-bin/status

nadeshda-org-C2AModel: TP-Link CPE210 v1.0
Firmware release: 2014.4-beta-4_exp20141130-ad

17:25:34 up  3:53,  load average: 0.64, 0.76, 0.86

5: br-client: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue 
    link/ether e8:de:27:ce:b7:82 brd ff:ff:ff:ff:ff:ff
    inet6 2a02:f98:0:28:eade:27ff:fece:b782/64 scope global dynamic 
       valid_lft 86393sec preferred_lft 3593sec
    inet6 fda0:747e:ab29:cafe:eade:27ff:fece:b782/64 scope global dynamic 
       valid_lft 86400sec preferred_lft 3600sec
    inet6 fe80::eade:27ff:fece:b782/64 scope link 
       valid_lft forever preferred_lft forever

             total         used         free       shared      buffers
Mem:         61348        25812        35536            0         2152
-/+ buffers:              23660        37688
Swap:            0            0            0

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2304      2304         0 100% /rom
/dev/mtdblock5            3904       296      3608   8% /overlay
Neighbourswlan0Joined IBSS 32:ca:ff:ee:ba:be (on wlan0)
	SSID: wifimesh-rheinufer
	freq: 2422

Station ea:97:f7:9d:d6:cc (nadeshda.org-plug) (on wlan0)
	inactive time:	10 ms
	rx bytes:	20155624
	rx packets:	164638
	tx bytes:	96023
	tx packets:	942
	tx retries:	202
	tx failed:	0
	signal:  	-48 [-48, -57] dBm
	signal avg:	-46 [-47, -55] dBm
	tx bitrate:	144.4 MBit/s MCS 15 short GI
	rx bitrate:	135.0 MBit/s MCS 7 40MHz
	authorized:	yes
	authenticated:	yes
	preamble:	long
	WMM/WME:	yes
	MFP:		no
	TDLS peer:	no
Station fa:d4:12:a9:f6:2c (nadeshda-org-3020v1) (on wlan0)
	inactive time:	10 ms
	rx bytes:	54758759
	rx packets:	444537
	tx bytes:	232119
	tx packets:	2384
	tx retries:	289
	tx failed:	1
	signal:  	-47 [-54, -49] dBm
	signal avg:	-46 [-53, -48] dBm
	tx bitrate:	108.0 MBit/s MCS 5 40MHz
	rx bitrate:	150.0 MBit/s MCS 7 40MHz short GI
	authorized:	yes
	authenticated:	yes
	preamble:	long
	WMM/WME:	yes
	MFP:		no
	TDLS peer:	no
Station 92:f9:53:7f:b5:8b (nadeshda-org-3040v1) (on wlan0)
	inactive time:	10 ms
	rx bytes:	80108151
	rx packets:	648377
	tx bytes:	341541
	tx packets:	3551
	tx retries:	449
	tx failed:	2
	signal:  	-53 [-58, -55] dBm
	signal avg:	-53 [-59, -54] dBm
	tx bitrate:	135.0 MBit/s MCS 6 40MHz short GI
	rx bitrate:	121.5 MBit/s MCS 6 40MHz
	authorized:	yes
	authenticated:	yes
	preamble:	long
	WMM/WME:	yes
	MFP:		no
	TDLS peer:	no
Station 12:01:ee:45:af:74 (nadeshda-org-710N1) (on wlan0)
	inactive time:	0 ms
	rx bytes:	90433435
	rx packets:	730779
	tx bytes:	669820
	tx packets:	6162
	tx retries:	537
	tx failed:	1
	signal:  	-49 [-49, -56] dBm
	signal avg:	-49 [-50, -56] dBm
	tx bitrate:	135.0 MBit/s MCS 7 40MHz
	rx bitrate:	121.5 MBit/s MCS 6 40MHz
	authorized:	yes
	authenticated:	yes
	preamble:	long
	WMM/WME:	yes
	MFP:		no
	TDLS peer:	no
Station ea:e1:28:ce:b9:06 (nadeshda-org-C2B) (on wlan0)
	inactive time:	0 ms
	rx bytes:	122433612
	rx packets:	986744
	tx bytes:	502514
	tx packets:	4854
	tx retries:	110
	tx failed:	0
	signal:  	-30 [-39, -31] dBm
	signal avg:	-30 [-38, -30] dBm
	tx bitrate:	300.0 MBit/s MCS 15 40MHz short GI
	rx bitrate:	270.0 MBit/s MCS 14 40MHz short GI
	authorized:	yes
	authenticated:	yes
	preamble:	long
	WMM/WME:	yes
	MFP:		no
	TDLS peer:	no

VPN statusfastd running for 13990.622 seconds
There are 4 peers configured, of which 2 are connected:

mesh_vpn_backbone_peer_rheinufer0: connected for 13658.748 seconds
mesh_vpn_backbone_peer_rheinufer1: not connected
mesh_vpn_backbone_peer_rheinufer3: not connected
mesh_vpn_backbone_peer_rheinufer2: connected for 13653.341 seconds

Ist geplant, diese Changes auch in der „mainline“ Rheinufer-Firmware reinzubringen? Denn 50% mehr VPN-Durchsatz sind ja schon durchaus knorke.

Sobald diese Version stabil ist. Sprich wenn von den Gluon Devs die Version als stabil mit Revisionstag herausgegeben wird. Außerdem gilt für alle Versionen die nicht von @nomaster und mir signiert sind, das es dafür keinen Support gibt. Sprich Probleme die damit auftreten oder in Verbindung damit auftreten werden wir nicht lösen da wir sonst zu viel Aufwand hätten uns erst mit der Firmware auseinander zu setzen. Entwicklungshilfe gibt es natürlich.

Naja wird sich ja nur um eine Frage der Zeit handeln. :smile:

Wobei ich nicht verstehe: Die Beta ist doch atm aus master gezogen, heißt das, dass die schneller den fastd 16 kriegt?

Naja, das hängt ja auch davon ab, was man in die Site.conf/site.mk schreibt.
(und dass neue batmans nun nicht unbedingt immer besser wären als alte haben die Wuppertaler schmerzlich erfahren dürfen, so wie ich das verstanden habe.)

Ich habe ein neue Version bereitgestellt, werde diesen Thread hier schließen.
https://forum.freifunk.net/t/rheinufer-gluon-2014-4-beta-2/922