Internet am FF-Router, aber nicht am Endgerät

Hallo zusammen,

nach längerer Abstinenz habe ich mal wieder meinen alten Freifunkrouter (TP Link WR1043ND v2) flott gemacht und in Betrieb genommen. Allerdings bekomme ich keine Internetverbindung an Endgeräte.

Per SSH Verbindung zum Router habe ich bisher folgendes getestet:

ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=117 time=30.931 ms
64 bytes from 8.8.8.8: seq=1 ttl=117 time=31.143 ms

ping google.com

PING google.com (142.250.186.110): 56 data bytes
64 bytes from 142.250.186.110: seq=0 ttl=115 time=33.368 ms
64 bytes from 142.250.186.110: seq=1 ttl=115 time=32.690 ms

traceroute openwrt.org
traceroute to openwrt.org (139.59.209.225), 30 hops max, 38 byte packets
 1  192.168.1.1 (192.168.1.1)  0.495 ms  0.458 ms  0.442 ms
 2  loopback1.0003.acln.01.ber.de.net.telefonica.de (62.52.201.186)  22.783 ms  17.084 ms  55.273 ms
 3  bundle-ether17.0004.dbrx.01.ber.de.net.telefonica.de (62.53.2.114)  17.361 ms  17.746 ms  bundle-ether17.0003.dbrx.01.ber.de.net.telefonica.de (62.53.2.110)  18.019 ms
 4  ae10-0.0002.corx.01.ber.de.net.telefonica.de (62.53.25.239)  27.807 ms  27.592 ms  27.699 ms
 5  ae4-0.0002.corx.02.fra.de.net.telefonica.de (62.53.0.73)  27.359 ms  ae4-0.0001.corx.01.off.de.net.telefonica.de (62.53.0.61)  27.621 ms  ae4-0.0002.corx.02.fra.de.net.telefonica.de (62.53.0.73)  27.495 ms
 6  bundle-ether1.0001.dbrx.01.off.de.net.telefonica.de (62.53.28.153)  28.158 ms  bundle-ether2.0002.dbrx.01.off.de.net.telefonica.de (62.53.0.209)  27.847 ms  bundle-ether1.0003.dbrx.02.fra.de.net.telefonica.de (62.53.14.163)  27.791 ms
 7  bundle-ether1.0005.prrx.02.fra.de.net.telefonica.de (62.53.10.51)  28.515 ms  28.103 ms  28.422 ms
 8  fra2-edge1.digitalocean.com (80.81.195.151)  41.303 ms  39.288 ms  33.085 ms
 9  138.197.250.142 (138.197.250.142)  28.223 ms  *  138.197.250.152 (138.197.250.152)  27.971 ms
10  *  *  *
11  *  *  *
12  wiki-01.infra.openwrt.org (139.59.209.225)  27.583 ms  *  *

Am Endgerät sieht es aber anders aus. Android vermeldet sofort, es bestünde kein Internet und schlägt vor die Verbindung zu wechseln, der PC kann hingegen keine Verbindung zu externen Quellen (sowohl per IP als auch per www.-Adresse) aufbauen und verliert alle Pakete beim Ping.

Hätte jemand von euch einen Tipp was da schieflaufen könnte? Ich habe mir schon die aktuelle Firmware meiner Community (Magdeburg) neu aufgespielt - kein Erfolg. Zum Testen habe ich anschließend die Firmware der Berliner aufgespielt, auch hier das gleiche Problem.

Vielen Dank euch und beste Grüße
Stephan

Moin Stephan,

ist der VPN-Tunnel aktiviert?

Bedenke, wenn du aus der Kommandozeile per V4 von einem Gluon-Gerät was netzwerktechnisches machst, geht das direkt über die lokale Verbindung, nicht über die Freifunk-Gateways raus.

Viele Grüße
Matthias

2 Likes

Hallo Matthias,

wenn du mir sagst wie ich das teste ohne ins Netz zu kommen, überprüfe ich es gern.

Als ich den das letzte mal betrieben hatte (vor vielleicht zwei Jahren) ging das noch von allein (bilde ich mir ein).

Im Zweifel über den Konfigurationsmodus gehen oder mal

 uci show |grep mesh

ausführen.

1 Like

Besten Dank.

Der Befehl sagt gibt folgenden Output

ffwizard.settings.dhcpmesh='10.31.82.16/28'
ffwizard.settings.meship_radio0='10.31.80.234'
ffwizard.settings.meshmode_radio0='80211s'
ffwizard.upgrade.lastUpgrade='005-wireless-mesh'
freifunk.community.mesh_network='10.0.0.0/8'
freifunk.wifi_iface_80211s.mode='mesh'
freifunk.wifi_iface_80211s.mesh_id='Mesh-Freifunk'
freifunk.wifi_iface_80211s.mesh_fwding='0'
luci_statistics.collectd_interface.Interfaces='ffuplink wlan0-mesh-2 br-dhcp'
luci_statistics.collectd_iwinfo.Interfaces='wlan0-mesh-2 wlan0-dhcp-2'
profile_Freifunk.profile.mesh_network='10.0.0.0/8'
profile_berlin.profile.mesh_network='10.0.0.0/8'
profile_berlin.wifi_iface_80211s.mesh_id='Mesh-Freifunk-Berlin'
profile_cottbus.profile.mesh_network='10.35.0.0/16'
profile_demo.profile.mesh_network='10.11.12.0/24'
profile_fuerstenwalde.profile.mesh_network='10.0.0.0/8'
profile_gadow.profile.mesh_network='10.61.0.0/16'
profile_kyritz.profile.ssid='mesh.freifunk.net'
profile_kyritz.profile.mesh_network='104.59.0.0/16'
profile_potsdam.profile.mesh_network='10.22.0.0/16'
profile_weimar.profile.mesh_network='10.63.0.0/16'
wireless.wlan0_mesh_2=wifi-iface
wireless.wlan0_mesh_2.device='radio0'
wireless.wlan0_mesh_2.ifname='wlan0-mesh-2'
wireless.wlan0_mesh_2.network='wireless0'
wireless.wlan0_mesh_2.encryption='none'
wireless.wlan0_mesh_2.mcast_rate='12000'
wireless.wlan0_mesh_2.mesh_fwding='0'
wireless.wlan0_mesh_2.mode='mesh'
wireless.wlan0_mesh_2.mesh_id='Mesh-Freifunk-Berlin'

Zuvor bin ich noch auf [Gelöst] Kein VPN Tunnel - Funk & Router - Freifunk Münsterland gestoßen und habe

set uci tunneldigger.@broker[0].enabled='1' 

gesetzt. Leider ohne Erfolg.

Ganz im Stile von „IT Crowd“:

„Did you turn it off and on again?“

Habe den Router zum gefühlt zwanzigsten Mal mit firstboot resettet und alles neu eingestellt - allerdings zum ersten Mal mit der Berliner Firmware. Tatsächlich, jetzt klappt es. Ich vermute, dass in der Magdeburger Firmware irgendwelche Artefakte nicht richtig resettet wurden und so auch der Berliner Firmware den Dienst versagten.

Jetzt muss ich nur noch die Magdeburger Firmware zum Laufen bringen - oder nach Berlin umziehen. :smiley:

  1. „Firstboot“ cleared alte Einstellungen zuverlässig
  2. Nach meinem Wissen gibt es in Magedeburg eine Migration von batman-adv zu babel-gluon. Wie dort der Stand ist: vermag ich nicht zu sagen, ich könnte aber vermuten, dass Du evtl. eine Firmware für ein bereits abgeschaltetes Netzssegment benutzt hast (also entweder legacy-batmanadv, oder eine nicht mehr aktive babel-testdomain)
  3. Was Du da getestet hast ist das IPv4-WAN-Interface des Routers. Wenn Du wissen möchtest, wie es dem Client-Netz geht, dann geht das mit den Möglichkeiten der routershell nur begrenzt (und vor allem total unterschiedlich, abhängig davon, ob Du jetzt eine batman-adv oder eine babel-firmware nutzt).

Will sagen: Wenn Du nicht zu sagen vermagst, welche Firmware Du genau (quelle/download-link) Du genutzt hast: Schwer zu sagen, ob das überhaupt hätte funktionieren können.
Und wie man das debugt. Tipps zu Babel-Gluon sind hier vermutlich relativ rar.

Hallo adorfer, das sind gute Hinweise, danke.

Ich bin aktuell etwas am Überlegen ob sich die Fehlersuche bezüglich Magdeburg wirklich lohnt, da ich tatsächlich in einigen Wochen umziehen werde. Auf jeden Fall werde ich die Magdeburger Community mal anschreiben.

Die Firmware für TP-Link TL-WR1043N/ND v2 hatte ich über die Magdeburger Community bezogen - http://firmware.md.freifunk.net/stable/0.39/factory/gluon-ffmd-0.39-tp-link-tl-wr1043n-nd-v2.bin

Gruß
Stephan

1 Like

Da bist du auf der richtigen Spur. Bitte nochmal ohne Tippfehler und vollständig:

uci set tunneldigger.@broker[0].enabled='1'
uci commit tunneldigger
/etc/init.d/tunneldigger restart

Viele Grüße
Matthias

Ich bin mir gerade nicht sicher, ob das wirklich zu der im Router befindlichen Firmware passt.
Das Posting lese ich so, als das „ein Wiki-Fund“ war… zu einer völlig anderen Firmware.

1 Like