IPv6 für virtuelle Gateways unter Proxmox bei Hetzner einrichten

Ich hätte doch nen eigenes Thema aufmachen sollen, damit das Problem für sich stehen kann :wink:
Mit dem eigenen /56 hatte ich geschrieben.

Würde das /56 auf dem VSwitch liegen, ja, das wäre für die Verteilung dann kein Problem und würde sicherlich auch so funktionieren. Wobei ich mir nicht sicher bin, ob wir mit dem 1TB inklusiv Traffic ausreichen würden. Wir haben jetzt bei uns ca. 28TB gesamt IPv6 -Traffic in Summe über all unsere Server.

Aufgrund der Antworten auf meinem Start-Beitrag hatten wir nun für jeden Server nen eigenes /56 Netz gebucht. Damit konnte ich auch wunderbar das ursprüngliche Problem lösen. Nun habe ich aber das Problem der unterschiedlichen Präfixe und Routen innerhalb eines Meshes.

Beim Freifunk ist es üblicherweise gewollt (und ich halte das auch für wichtig), das jedes Gerät im Netz eine global geroutete IPv6 bekommt. Und diese ist dann nicht durch Firewall oder NAT auf den Gateways abzuschotten. Einfach damit das Internet nicht noch stärker nur über zentrale Plattformen läuft.

(Auch wenn man das damit wohl kaum verhindert :frowning_face:. Aber beim Freifunk geht es ja auch gerade um Dezentralität.)

Wenn man also diese NAT66 Geschichten veranstaltet sollte man, meiner Meinung, mindestens dafür sorgen, das jedes Gerät trotzdem eine „globale“ IPv6 bekommt über die eingehender Traffic laufen kann.

Also nicht nur ULAs an die Clients verteilen. Und dann ist es auch praktisch wenn man auf den Hetzner Kisten die /56 zur Verfügung hat :wink:.

Schön, dass Du mir das alles erklärt hast, was ich mir oben schon verkniffen habe.
Ich würde Dir in einem neuen Thread dazu auch belegen, dass Du in der Konsequenz Unrecht mit Deiner Aussage hast. Dass nämlich das dogmatische Festhalten an öffentlichen IPv6-Adressen in den bestehenden Batman-Netzen gerade zu diesen zentralistischen Strukturen wie FFRL oder anderen AS-Freifunkprovidern geführt hat.

Ich verstehe wirklich nicht, warum wir hier überhaupt über Nat66 diskutieren.
Wir haben doch festgestellt, dass es hier überhaupt nicht weiterhilft mit der Problemstellung des TS.

Das war dann nach ARM-Servern (erste Inkarnation); denn da gab’s nur 1918 mit einem Setup ähnlich AWS (die Public-v4 wurde $woanders bereitgestellt). Aber gut zu wissen, daß sie’s nun (besser) im Griff haben.

Was dann vielleicht ein neuer Thread werden sollte. Denn Lösungsbedarf gibt es ja, nur (bei Hetzner) keine bezahlbare lokale Lösung.

2 Likes