Lan Ports deaktivieren

Kann man irgendwie die gelben LAN Ports beim WR841 deaktivieren?

Ich will den Nutzer gern vor seinem Putzpersonal schützen, das die Kabel immer einfach irgendwo wieder reinsteckt. Soll nur der blaue gehen, oder alle ports als WAN, wenn das geht

Hier findet man nur, wie man Mesh on LAN aktiviert: Commandline administration · freifunk-gluon/gluon Wiki · GitHub

Die machen gerade nicht mehr mit, weil derern Privatnetz plötzlich aus dem Freifunk erreichbar war

Ich brauch da ein Lösung, wie das nicht mehr passieren kann; zukleben waere die einfachste – aber unprofessionell :wink:

via rc.local oder so könnte man das doch auch update-fest basteln, hat das schon mal jemand gemacht?

1 Like

http://www.ebay.de/itm/301641728862

2 Likes

Wenn du LAN-Mesh aktivierst, kann das private Netz nicht mehr ins Freifunk gelangen.

Grüße
Matthias

aber dann geistern im gesamten privaten netz die mesh pakete rum, das wollen die wohl auch nicht, vor allem, weil manche schlechten switche und co damit nicht klar kommen und abstürzen

Also schnell und schmutzig kannst du eth0 (müssten glaub die gelben Ports sein) einfach in die br-wan mit reinhängen und Batman und das Clientnetz ausmachen. Dann sind alle fünf Ports gleichwertig.

Es bringt ja auch nichts, wenn das Putzpersonal den falschen Port erwischt und nichts mehr geht. Aber das ist glaube nicht nicht autoupdatesicher.

Grüße
Matthias

Wenn nur das Aussehen das Problem ist: Wenn man einfach ein paar transparente RJ45-Stecker nimmt (unvercrimpt natürlich) und die in die Ports reinsteckt sieht das schon aus als wären das Stöpsel, die genau dafür gedacht sind :smile:

EDIT: Funktioniert natürlich nur, wenn nur ein Kabel eingesteckt ist, oder zumindest alle im gelben Port stecken, weil sonst Vertauschungsgefahr herrscht…

1 Like

Ansonsten kannst du auch anschauen ob du mit policy-based Routing weiterkommst.

Ungetestet sowas wie:
ip rule add blackhole iif eth0

Musst du nur noch updatefest kriegen (und vielleicht nen Hinweis draufkleben oder updatefest in die MOTD schreiben damit sich der nächste nicht totdebuggt).

Und vielleicht mal testen ob dann Config-Mode noch funktioniert.

1 Like