Mesh on LAN anscheinend ohne Funktion - Fehlersuche

Bei mehreren Geräten scheint bei mir die Kabelkopplung nicht richtig zu funktionieren. Mesh on LAN bzw. WAN ist natürlich an und hat in der Vergangenheit funktioniert.

Ein Beispiel: TL-WDR4300 bei mir lokal als Offloader ist mit der CPE510 auf dem Dach per Mesh-on-LAN verbunden. Der gesamte Traffic geht aber über das 5GHz-Mesh raus. Gluon 2016.1.x
Hat hier jemand eine Idee?

ifconfig 
bat0      Link encap:Ethernet  HWaddr C4:6E:1F:5E:1C:70  
          inet6 addr: fe80::c66e:1fff:fe5e:1c70/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1766832 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76392 errors:0 dropped:45 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:139010478 (132.5 MiB)  TX bytes:14051286 (13.3 MiB)

br-client Link encap:Ethernet  HWaddr C4:6E:1F:5E:1C:70  
          inet6 addr: fdef:ffc0:7030:0:c66e:1fff:fe5e:1c70/64 Scope:Global
          inet6 addr: fe80::c66e:1fff:fe5e:1c70/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1774538 errors:0 dropped:1 overruns:0 frame:0
          TX packets:114722 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:115088365 (109.7 MiB)  TX bytes:17106947 (16.3 MiB)

br-mesh_lan Link encap:Ethernet  HWaddr DA:7D:B3:D5:0B:5E  
          inet6 addr: fe80::d87d:b3ff:fed5:b5e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3497450 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:386033600 (368.1 MiB)

br-wan    Link encap:Ethernet  HWaddr DA:7D:B3:D5:0B:5B  
          inet6 addr: fe80::d87d:b3ff:fed5:b5b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3587858 errors:0 dropped:3587858 overruns:0 frame:0
          TX packets:116897 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:348316233 (332.1 MiB)  TX bytes:39516037 (37.6 MiB)

client0   Link encap:Ethernet  HWaddr DA:7D:B3:D5:0B:58  
          inet6 addr: fe80::d87d:b3ff:fed5:b58/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7588 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1793565 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:916949 (895.4 KiB)  TX bytes:174035454 (165.9 MiB)

eth0      Link encap:Ethernet  HWaddr C4:6E:1F:5E:1C:70  
          inet6 addr: fe80::c66e:1fff:fe5e:1c70/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3608337 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3635452 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:415347617 (396.1 MiB)  TX bytes:442733289 (422.2 MiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr C4:6E:1F:5E:1C:70  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3587858 errors:0 dropped:0 overruns:0 frame:0
          TX packets:116897 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:348316233 (332.1 MiB)  TX bytes:39516037 (37.6 MiB)

eth0.2    Link encap:Ethernet  HWaddr C4:6E:1F:5E:1C:70  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3497448 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:386028000 (368.1 MiB)

ibss0     Link encap:Ethernet  HWaddr DA:7D:B3:D5:0B:5A  
          inet6 addr: fe80::d87d:b3ff:fed5:b5a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1536  Metric:1
          RX packets:41279342 errors:0 dropped:2 overruns:0 frame:0
          TX packets:37822063 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:33058165779 (30.7 GiB)  TX bytes:33414778590 (31.1 GiB)

ibss0.61  Link encap:Ethernet  HWaddr DA:7D:B3:D5:0B:5A  
          inet6 addr: fe80::d87d:b3ff:fed5:b5a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1532  Metric:1
          RX packets:41279197 errors:0 dropped:3 overruns:0 frame:0
          TX packets:37822088 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:32315123043 (30.0 GiB)  TX bytes:32514439359 (30.2 GiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:170669 errors:0 dropped:0 overruns:0 frame:0
          TX packets:170669 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:23623611 (22.5 MiB)  TX bytes:23623611 (22.5 MiB)

local-node Link encap:Ethernet  HWaddr 16:41:95:40:F7:DC  
          inet addr:10.61.3.3  Bcast:10.61.3.255  Mask:255.255.255.0
          inet6 addr: fe80::1441:95ff:fe40:f7dc/64 Scope:Link
          inet6 addr: fdef:ffc0:3dd7::1/128 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:666045 errors:0 dropped:1 overruns:0 frame:0
          TX packets:44984 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:37684002 (35.9 MiB)  TX bytes:3868832 (3.6 MiB)

ifconfig ist tot. Zeig mal bitte die Ausgabe von

ip a s 

und

brtctl show

sowie

batctl if

Grüße
Matthias

ip a s

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel qlen 1000
    link/ether c4:6e:1f:5e:1c:70 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::c66e:1fff:fe5e:1c70/64 scope link 
       valid_lft forever preferred_lft forever
3: teql0: <NOARP> mtu 1500 qdisc noop qlen 100
    link/void 
35: br-mesh_lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master bat0 
    link/ether da:7d:b3:d5:0b:5e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d87d:b3ff:fed5:b5e/64 scope link 
       valid_lft forever preferred_lft forever
36: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-mesh_lan 
    link/ether c4:6e:1f:5e:1c:70 brd ff:ff:ff:ff:ff:ff
37: br-wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue 
    link/ether da:7d:b3:d5:0b:5b brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d87d:b3ff:fed5:b5b/64 scope link 
       valid_lft forever preferred_lft forever
38: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-wan 
    link/ether c4:6e:1f:5e:1c:70 brd ff:ff:ff:ff:ff:ff
39: br-client: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue 
    link/ether c4:6e:1f:5e:1c:70 brd ff:ff:ff:ff:ff:ff
    inet6 fdef:ffc0:7030:0:c66e:1fff:fe5e:1c70/64 scope global dynamic 
       valid_lft 85947sec preferred_lft 13947sec
    inet6 fe80::c66e:1fff:fe5e:1c70/64 scope link 
       valid_lft forever preferred_lft forever
40: local-node@br-client: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue 
    link/ether 16:41:95:40:f7:dc brd ff:ff:ff:ff:ff:ff
    inet 10.61.3.3/24 brd 10.61.3.255 scope global local-node
       valid_lft forever preferred_lft forever
    inet6 fdef:ffc0:3dd7::1/128 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::1441:95ff:fe40:f7dc/64 scope link 
       valid_lft forever preferred_lft forever
41: ibss0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1536 qdisc mq qlen 1000
    link/ether da:7d:b3:d5:0b:5a brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d87d:b3ff:fed5:b5a/64 scope link 
       valid_lft forever preferred_lft forever
42: bat0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-client 
    link/ether c4:6e:1f:5e:1c:70 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::c66e:1fff:fe5e:1c70/64 scope link 
       valid_lft forever preferred_lft forever
43: client0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-client qlen 1000
    link/ether da:7d:b3:d5:0b:58 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d87d:b3ff:fed5:b58/64 scope link 
       valid_lft forever preferred_lft forever
44: ibss0.61@ibss0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1532 qdisc noqueue master bat0 
    link/ether da:7d:b3:d5:0b:5a brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d87d:b3ff:fed5:b5a/64 scope link 
       valid_lft forever preferred_lft forever

brctl show

bridge name    bridge id        STP enabled    interfaces
br-mesh_lan        7fff.da7db3d50b5e    no        eth0.2
br-wan        7fff.da7db3d50b5b    no        eth0.1
br-client        7fff.c46e1f5e1c70    no        bat0
                            client0

batctl if

ibss0.61: active
br-mesh_lan: active

Danke dir!

Das sieht soweit richtig aus. Kannst du mal einen MeshViewer-Link zu der Installation einstellen? Damit man mal die Topologie versteht?

Grüße
Matthias

Hier ist die CPE510 und hier der per Kabel angeschlossene WDR4300

Man kann leider die Statusseiten nicht abrufen, weil keine öffentliche IPV6. Könntest du davon noch Bilder einstellen?

Hast du mal das WLAN-Mesch einfach an einem der Router abgeschaltet? Dann müsste er auf das Kabel umsteigen.

Hast du auf dem zweiten Router auch kontrolliert, dass dort das LAN-Mesch aktiviert ist?

Ja, wir haben leider noch keine öffentliche IPv6 hinterlegt. Das gluon-Netz fristet bei uns leider bisher ein Schattendasein, da wir hauptsächlich Meshkit (OLSR) und LibreMesh (BMX/batman-adv) einsetzen.
WLAN-Mesh habe ich auch schon deaktiviert, dann geht gar nix mehr rüber. Das LAN-Mesh habe ich natürlich auf beiden kontrolliert und sogar schon mehrmals an- und ausgeschaltet.
Auf der Gegenstelle im Flüchtlingsheim habe ich übrigens das gleiche Problem. Dort geht es von der CPE510 per Kabel auf einen 841er und dann ab auf die unteren Etagen per Mesh. Hier funktioniert das Kabel auch nicht mehr und ich musste meinen letzten WDR3600 als Verbindungsglied opfern.
An anderer Stelle (CPE210 / 841er) funktioniert die Kabelkopplung aber, siehe letztes Bild.
Vorsichtshalber mal hier der Link zu unserer site.conf.



Also auf sommerdind1 hast du WAN-Mesch aktiviert, das wäre der blaue Port, nicht der gelbe. Davon ist abzuraten, wenn du im Wan-Netz noch ein privates WLAN hast, weil das sonst die ganzen Batmanpakete abbekommt.

Und auf der anderen scheint mir LAN-Mesch gar nicht aktiviert zu sein. Bitte geh nochmal auf allen Geräten in den Konfigurationsmodus und überprüfe, ob das alles korrekt gesetzt ist.

Zur Erinnerung:

  • LAN-Mesch (Mesh-on-Lan): Gelbe Ports
  • WAN-Mesch (Mesh-on-Wan): Blauer Port

Beispiel: Du willst einen 841er, der VPN macht, mit der CPE verbinden.
Frage: Wie muss dann die Konfiguration aussehen?

Auf dem 841er muss LAN-Mesch (gelber Port) aktiviert sein und auf der CPE WAN-Mesh, das ist dann der blaue Port, bzw. der primäre, also der der am Netzteil, also dem PoE-Injektor, anliegt. Dann verbindest du den 841er am gelben Port mit dem Lan-Port des PoE-Injektors der CPE am Netzteil.

Grüße
Matthias

1 Like

Ne, bei Sommerwind1 kommt das Signal per WLAN von einem anderen 841er, der das VPN macht. Über den WAN-Port ist lediglich noch eine CPE per Mesh angebunden. Die LAN-Ports müssen frei sein, da diese für Endgeräte genutzt werden wie z.B. SIP-Telefon.

Bei den Geräten, um die es eigentlich geht (s.o.), habe ich mehrmals gegengecheckt, ob Mesh-on-LAN aktiviert ist, sowohl per Config-Mode als auch per SSH. Ich bin mir auch 100% sicher, dass es funktioniert hat. Leider kann ich aber nicht sagen, seit wann nicht mehr. Da die CPE510 (Dach) und der WDR4300 (direkt unterm Dach) so nah beieinander stehen, meshen die sowieso über WLAN und es ist daher auch nicht aufgefallen.

Hast du mal das Kabel getestet? Blinken die LEDs?

Kabel getestet und sogar getauscht, entsprechende LED blinkt. Kann mir aber nur schwer vorstellen, dass das Kabel einen weg hat.

Naja, öffentlich ist gar nicht zwingend, aber auch im ICVPN taucht das Netz leider nicht auf:

root@bgp2:~# ip -6 route show table 42 | grep fdef:ffc0:
fdef:ffc0:3dd7::/48 via fec0::a:cf:0:82 dev icvpn  proto bird  metric 1024 
fdef:ffc0:4fff::/64 via fec0::a:cf:1:80 dev icvpn  proto bird  metric 1024 
fdef:ffc0:4fff:1::/64 via fec0::a:cf:1:80 dev icvpn  proto bird  metric 1024 
fdef:ffc0:4fff:2::/64 via fec0::a:cf:1:80 dev icvpn  proto bird  metric 1024

Habe mir erlaubt den Titel aussagekräftiger zu gestalten.

Wenn die LED blinkt, ist es ein Softwarefehler. Schreib nochmal auf, wo du welches Mesch aktiviert hast und wie die Topologie des Netzes ist, inklusive der privaten Komponenten.

MPW, wie anfangs beschrieben:

bei „batctl if“ stehen die mesh-on-lan Interfaces auf beiden Routern drin, die Switch-Config sah auch okay aus.

Das m.E. merkwürdigste ist, dass die Interface bei Kabelkopplung (mesh-on-wan und mesh-on-lan) irgendwie trotzdem als Bridge konfiguriert sind. Aus unseren „normalen“ Leipziger batman-adv (und auch OLSR-) Netzen kennen wir das so nicht!

Ich würde ja vorschlagen, mal ein 1-2 weitere Geräte in diese Kabelkopplung zu hängen (Hast du noch 841, oder besser 710?) und dann mit eventl. älterer Gluon-Firmware (oder Meshkit und installiertem tcpdump-mini oder einem Laptop) zu überprüfen. mokkin meinte übrigens auch, dass das Interface auf der Status-Seite fehlen würde.

1 Like

Es mesht nun wieder via Kabel. Ich habe LAN und WAN in der Switch-Config getauscht.

Scheinbar lag es an 2 Fehlern:

  • Der erste LAN-Anschluss der CPE510 ist gar nicht mehr LAN sondern WAN. (Hat das jemand mit Absicht für Gluon gemacht? Ich hatte da früher mal komische Anfragen gelesen)

  • Mesh-on-WAN funktioniert nicht mehr

Ich kenne es von Libremesh, dass am WAN-Port auf DHCP-Antworten gelauscht wird und parallel Mesh-Kabelkopplung möglich ist… Aber bei Gluon, ist das wirklich Absicht?

config interface ‚wan‘
option ifname ‚eth0.1‘
option auto ‚1‘
option peerdns ‚0‘
option type ‚bridge‘
option proto ‚dhcp‘
option multicast_querier ‚0‘
option igmp_snooping ‚0‘
option macaddr ‚da:7d:b3:d5:0b:5b‘


config interface ‚mesh_wan‘
option ifname ‚br-wan‘
option auto ‚1‘
option proto ‚gluon_mesh‘
option fixed_mtu ‚1‘

Zumindest entsinne ich mich auch schon, aus Verzweiflung bei CPE210ern schließlich entweder Mesh_wan_auto und Mesh_lan_auto angeschaltet zu haben, obwohl nur ein Kabel angeschlossen war.

Sprich: Zumindest in irgendwelchen 2016.1ern war da mal was durcheinander.

Also lesen musst du halt schon selber, da kann dir keiner bei helfen. :wink: Auf den Geräten mit PoE ist am Injektor immer WAN-Mesch, immer so gewesen.

Upps. Also bei Openwrt, LEDE bzw Freifunk via Meshkit war das schon immer anders (PoE=LAN). Aber bei Gluon kann das durchaus anders sein :smile:

Aber ich bleibe vorerst trotzdem dabei: die Mesh-On-WAN Funktion scheint irgendwie kaputt :-o (siehe s.o. config-file) und das scheint auch zb einen 841 zu betreffen.
Gluon-versionsnummern habe ich leider nicht. Das müßten wir noch raussuchen und das Problem nochmal ordentlich „im Labor“ nachvollziehen, bevor wir ein Ticket aufmachen?

Ich hab so an die 20 Geräte hier in Münsterland, die ich persönlich aufgebaut habe und wo alles so funktioniert, wie es dokumentiert ist.

2 Likes