Meshviewer (NetworkError)

Hallo Leute,

seit 2 Tagen kämpfe ich mit dem Meshviewer.

Beim Installieren kommen keine Fehler,

Wenn ich die Karte öffne kommt nur ein weisser hintergrund und Error: Network Error

Was mache ich da falsch??

danke euch schon mal

Rene

Hi, öffne mal im Chrome die Entwicklertools und dann auf den Reiter „Console“, dort findest du meistens die Ursache.Ich hatte bisher Probleme, weil ich zu blöd für die nginx Konfiguration war (Alias oder hostname falsch).

OK, ich versuchs mal

So, hier die ausgabe der Console…

XMLHttpRequest cannot load http://gw01.freifunk-bamberg.de/data/nodes.json. No ‚Access-Control-Allow-Origin‘ header is present on the requested resource. Origin ‚http://idefix‘ is therefore not allowed access. idefix/:1

Daraus werde ich nicht schlau

Hi,
ich glaube die Fehlerursache ist der DNS Name. Bei der Generierung des Meshviewer hast du in der config.js den DataPath definiert. Dieser Datepath muss auch in der Config von nginx (server_name) so eingerichtet sein.
Grüße
netminion

habe den fehler gefunden, es lag an den header des servers wo die json dateien liegen

einfach auf der Console des Servers

a2enmod headers

und folgende Zeile im Vortualhost:
Header set Access-Control-Allow-Origin „*“

und schon geht es von jedem rechner aus

Aber trotzdem danke

It’s the apache way :wink:
Freut mich dass es jetzt läuft.

1 Like

CORS muss aktiviert sein…

Ich bekam auch den CORS fehler in der Firefox console, obwohl ich a2enmod headers habe und die Zeile

	Header set Access-Control-Allow-Origin "*"

in meiner apache cond für die seite habe.

Das Problem war, dass man dies auch in die apache config für die domain, von der die json geladen werden soll eintragen muss, siehe:enable cross-origin resource sharing

dann darf der meshviewer die json von dort auch laden

siehe: enable cross-origin resource sharing