Netgear repeater ex3700 mit openwrt?


#4

Moin,
mit scp oder unter Windows mit WinSCP kannst du Dateien über eine ssh-Verbindung kopieren. Dazu gibt es diverse erklärungen im Forum und im restlichen Internet. Grundsätzlich musst du deine OpenWRT-Firmeware (sysupgrade) nach /tmp auf dem Repeater kopieren, um diese dann auf dem Gerät zu installieren. Unter Linux etwa so

linux$ scp openwrt-dein-image-sysupgrade.bin root@192.168.1.1:/tmp
root@OpenWrt:/# sysupgrade -v /tmp/[specified firmware].bin

https://openwrt.org/docs/guide-user/installation/generic.sysupgrade#scp

Offtopic der Vollständigkeit halber: Eventuell wäre eine Rubrik Offtopic/OpenWRT im Forum ganz nützlich. Ansonsten ist auch forum.lede-project.org immer eine gute Anlaufstelle für solche Fragen. Wer sich nicht in Englischer Sprache versuchen will, kann bestimmt auch einfach auf Deutsch fragen, ohne dass ihm der Kopf abgerissen wird.


#5

Hallo erstmal danke,
sysupdate hat geklappt mit scp
hab jedoch immer noch kein webinterface
Bitte noch um Hilfe wie ich das Webinterface über /temp installieren kann
da der Repeater ja noch nicht über WPS ins internet kommt.
geht ja nicht über update
Danke
MFG


#6

Welche Softwareversion hast du denn aufgespielt? Nicht alle vorkompilierten OpenWrts haben eine Weboberfläche.


#7

Hallo,
hab die von hier “https://openwrt.org/toh/netgear/ex3700_ex3800
da gabs nur die eine version
für den repeater
k.a.
MFG


#8

Ich halte es für unwahrscheinlich, dass die WPS-Taste funktioniert wenn du das Webinterface installiert hast. Eher musst du das Gerät manuell als Bridge Konfigurieren.

LuCI ist ein metapaket, du musst eine ganze reihe von Paketen installieren, siehe OpenWrt Project: LuCI Essentials

Oder WLan Konfigurieren unter /etc/config/wireless, das Gerät per Lan-Kabel mit dem Internet verbinden und eine ssh-Session über WLan auf machen. Dann kannst du bestimmt opkg mit dem Repository von OpenWRT benutyen.
Vermutlich kannst du WLan mit folgendem Befehl aktivieren oder halt manuell aktivieren/anpassen.

uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi

https://openwrt.org/docs/guide-user/network/wifi/basic
Bei sowas lernt man immer ne Menge.

@MPW Glaube da gibt es nur einen Snapshot, die Doku ist auch mehr als dürfig obwohl es seit ~ einem Jahr Unterstützung in owrt gibt.


#9

so oder so, der Router ist nicht gebrickt.
Entweder Du änderst den Thread-Titel oder machst einen neuen Thread auf.

Oder was ist so schwer verständlich. Auf der von Dir selbst verlinkten Webseite steht es doch.
Oder möchtest Du das nochmal erklärt haben?


#10

Danke,
habe gestern ewig gesucht nach LuCi nix gefunden
wo ich wenigstens ne Minimal installation finden kann
viellecht jemand noch nen tip
MFG


#11

Wie in @adorfer s Beitrag in der unteren Hälfte des Fotos steht, enthält die von dir installierte Version keine Weboberfläche. Da kannst du lange probieren.

Hast du das schon probiert? OpenWrt Project: LuCI installation

Viele Grüße
Matthias


#12

Hallo ja habe ich probiert
aber ich kann die Pakete nicht installieren
kommt fehler "root@OpenWrt:~# opkg install luci-lib-core_0.11.1-1_ar71xx.ipk
Unknown package ‘luci-lib-core’.
Collected errors:

  • pkg_hash_fetch_best_installation_candidate: Packages for luci-lib-core found, but incompatible with the architectures configured"
    wlan geht jetzt der Repeater ist als offenes Wlan zu sehen
    habe dann probiert über eine neue SSH session über opkg update zu machen geht aber auch nicht

der Repeater hängt über Lan an der fritzbox 7490 und ich kann auch über ssh 192.168.1.1 drauf zugreifen
Aber komme damit nicht ins internet
Fritzbox hat die Adresse 192.168.1.5
wie bekomme ich den repeater ins Internet damit ich die Pakete von Luci installieren kann
bzw. wie bekomme ich die Orginal Netgear 3700ex firmware wieder drauf
MFG und schönen Sonntag


#13

Hast du vorher

opkg update

ausgeführt?


#14

ja geht leider nicht
Failed to establish connection
sogar das neueste sysupdate gemacht
OpenWrt SNAPSHOT, r7493-b123921
mfg


#15

Ist der Router denn online?

ping 1.1.1.1

#16

ja aber der repeater nicht
denke mal ich muss dem repeater ne andere ip geben
möchte aber an meiner fritzbox nix ändern
wie gebe ich dem repeater ne andere ip? bzw dns adresse über ssh


#17

Nimm es nicht böse, aber ich hab so das Gefühl, du probierst nur wahllos rum :wink: .

Wie sieht den die Netzwerkkonfiguration auf dem Repeater aus?

ip address show

Der Repeater kann eine statisch oder dynmisch von der FritzBox zugewiesene IP bekommen.

Hängt er schon im WLAN der FritzBox? Ich glaube du möchtest WLAN mit WLAN erweitern und hängst ihn nicht per Kabel an die FritzBox, oder?

Da du nicht sehr kommandozeilen-erfahren scheinst, frage ich mich gerade, über welche Netzverbindung du probiert hast die Pakete für die Weboberfläche zu installieren?

Du solltest dich entscheiden, alles per Kommandozeile zu machen und das mit dem LuCi zu vergessen. Oder du hängst das Dingen erstmal per Kabel an die FritzBox und installierst die Pakete für die Weboberfläche.


#18

Du musst vermutlich den Adressbereich von deinem Repeater anpassen:
https://openwrt.org/docs/guide-quick-start/ts-internetconnectivity

If you still cannot access the internet, then ask on the forum.lede.org for more help.

Die Mediatek-Chips machen meines Wissens mit dem aktuellen Treiber eh kein besonders stabiles WLan, das ist vermutlich auch der Grund für die verwaiste Doku. Repeater machen dir zusätzlich eher die Airtime voll, es sei denn, du hängst ihn per Kabel an deine Fritzbox, dann könntest du auf einem anderen Kanal ein Netz auf machen.

Meine Empfehlung ist OpenWrt Project: Back to original firmware und ein anderes Bastelprojekt suchen. Wenn es nicht klappt, kannst du höchstwahrscheinlich folgende Anleitung benutzen OpenWrt Project: Netgear WNDR3700 and WNDR37AV oder OpenWrt Project: mipsel_24kc nach mt7620 durchforsten und dir selbst eine Lösungsbeschreibung suchen.
Wenn das klappt, wird sich bestimmt der oder die Nächste über eine kurze Beschreibung in der Devicepage https://openwrt.org/toh/netgear/ex3700_ex3800?s[]=ex3700 freuen.

Besten Gruß C*


#19

Danke @coco
ja habe schon die Ip Adresse vom repeater von 192.168.1.1 nach 192.168.1.53 verlegt.
trotzdem habe ich noch kein Internetzugang auf dem repeater.
ich kenne mich auch nicht aus mit den ganzen befehlen.
Ziel war eigentlich nur das Teil ab und zu als Repeater zu benutzen,
weil die Orginal Netgear Software nicht so gut mit der Fritzbox harmoniert hat.
Dachte nicht das es mit openwrt so kompliziert wird.
Nun gut danke erstmal
MFG


#20

Wir wissen ja garnicht was du genau machst, zeig mal

uci show network

#21

hallo,
hier die Ausgabe
network.loopback=interface
network.loopback.ifname=‘lo’
network.loopback.proto=‘static’
network.loopback.ipaddr=‘127.0.0.1’
network.loopback.netmask=‘255.0.0.0’
network.globals=globals
network.globals.ula_prefix=‘fdca:82cc:2f8c::/48’
network.lan=interface
network.lan.type=‘bridge’
network.lan.ifname=‘eth0’
network.lan.proto=‘static’
network.lan.netmask=‘255.255.255.0’
network.lan.ip6assign=‘60’
network.lan.ipaddr=‘192.168.1.53’
network.lan_dev=device
network.lan_dev.name=‘eth0’
network.lan_dev.macaddr=‘2c:30:33:d0:72:8e’

mfg


#22

Du hast ja schon mit irgendeiner Methode die Datei /etc/config/network bearbeitet. Trage in der gleichen Datei mal unter

config interface lan
	option gateway '192.168.1.5'
	option dns '192.168.1.5'

ein. 192.168.1.5 ist die Adresse deiner Fritzbox, das muss natürlich stimmen. Der Abschnitt sollte dann etwa so aussehen

config interface lan
    	option ifname 'eth0'
    	option type 'bridge'
    	option proto 'static'
    	option ipaddr '192.168.1.53'
    	option netmask '255.255.255.0'
    	option gateway '192.168.1.5'
    	option dns '192.168.1.5'

192.168.1.53 darf natürlich nicht gleichzeitug von einem anderen Gerät benutzt werden.
Eventuell kommst du damit erst mal ins Netz.

/etc/config/wireless sollte der Abschnitt config wifi-iface etwa so aussehen (in der Grundeinstellung)

config wifi-iface
    	option device wifi0 #wifi0 oder anderer Interface-Name
    	option network lan
    	option mode ap
    	option ssid OpenWrt
    	option encryption none

Damit bekommen Endgeräte über deinen Netgear…eine Adresse von deiner Fritzbox, wenn diese per Lan-Kabel angebunden ist.


#23

Hallo Juhu hat geklappt
konnte jetzt endlich das luci Paket runterladen
Vielen Dan für die Hilfe
MFG