[solved]TP 841 Name or service not known

Hallo an das Team!

Erstmal vielen Dank für das Projekt! Ich finde es als den richtigen Ansatz in der heutigen Zeit wo große Unternehmen mit weniger Leistung mehr verlangen!

Jetzt zu meine Frage:
Ich habe um mein Grundstück drei TP 841 v9.2/v9.1 am laufen. Zwei davon sind innerhalb des Hauses im WAN direkt mit dem Internet verbunden ein weiterer ist außerhalb des Hausen über WLAN-Mesh mit dem vorhandenen FF-Netz verbunden und genau um diesen dreht es sich hier. Dieser Router liefert permanent folgende Fehlermeldung:

Tue Apr 7 22:27:23 2015 daemon.info fastd[1199]: resolving host ffrg5.freifunk-ruhrgebiet.de' for peer <mesh_vpn_backbone_peer_ruhrgebiet5>... Tue Apr 7 22:27:23 2015 daemon.info fastd[1199]: resolving host ffrg5.freifunk-ruhrgebiet.de’ failed: Name or service not known
Tue Apr 7 22:27:24 2015 daemon.info fastd[1199]: resolving host ffrg10.freifunk-ruhrgebiet.de' for peer <mesh_vpn_backbone_peer_ruhrgebiet10>... Tue Apr 7 22:27:24 2015 daemon.info fastd[1199]: resolving host ffrg10.freifunk-ruhrgebiet.de’ failed: Name or service not known

Es sieht für mich so aus, als würde Router versuchen ein VPN zum Backbone aufzubauen was aber nicht gelingt.

Auf der Routenübersicht hat dieser auch kein VPN zu einem Backbone. Surfen über diesen funktioniert hingegen was ja auch logisch ist.

Sind diese Fehlermeldungen normal wenn der Router nur über das WLAN-Mesh verbunden ist?

Gruß und Dank

Saho

Du solltest/mußt das VPN abschalten, wenn der Router keine physikalische Verbindung in Internet hat.
Da die Verbindung zu den Supernodes über das WAN und nicht über das mesh läuft kommen ansonsten solche Fehlermeldungen.

Ich würde das VPN auch wirklich nur an 1 Router/Interbnet-Zugang einschalten.

Vielen Dank für die schnelle Antwort!

Kannst du mir den Konsolenbefehl nennen wie ich VPN auf dem betreffenden Router ausschalte.

Gibt es eigentlich eine „ordentlich“ Übersicht über die einzustellenden Parameter?

Den zweiten würde ich gerne weiter mit VPN laufen lassen damit das Mesh auch noch läuft wenn der Main-Router mal nicht on ist.

Gruß

Saho

Die wichtigsten Kommandos findest du hier:

cool, vielen Dank!

Also sollte

uci set gluon-simple-tc.mesh_vpn.enabled=0
uci commit gluon-simple-tc

VPN auf dem Router ausschalten?

eher so:

uci set fastd.mesh_vpn.enabled=0
uci commit fastd

Viel Erfolg!

Leider ohne Erfolg

ich habe es auf der Konsole mittels

uci set gluon-simple-tc.mesh_vpn.enabled=0
uci commit gluon-simple-tc
reboot

versucht.

Leider versucht der Router nach wie vor eine VPN aufzubauen

Tue Apr 7 23:16:57 2015 daemon.info fastd[1165]: resolving host ffrg6.freifunk-ruhrgebiet.de' for peer <mesh_vpn_backbone_peer_ruhrgebiet6>... Tue Apr 7 23:16:57 2015 daemon.info fastd[1165]: resolving host ffrg6.freifunk-ruhrgebiet.de’ failed: Name or service not known
Tue Apr 7 23:16:58 2015 daemon.info fastd[1165]: resolving host ffrg7.freifunk-ruhrgebiet.de' for peer <mesh_vpn_backbone_peer_ruhrgebiet7>... Tue Apr 7 23:16:58 2015 daemon.info fastd[1165]: resolving host ffrg7.freifunk-ruhrgebiet.de’ failed: Name or service not known
Tue Apr 7 23:16:58 2015 daemon.info fastd[1165]: resolving host ffrg2.freifunk-ruhrgebiet.de' for peer <mesh_vpn_backbone_peer_ruhrgebiet2>... Tue Apr 7 23:16:58 2015 daemon.info fastd[1165]: resolving host ffrg2.freifunk-ruhrgebiet.de’ failed: Name or service not known

Ich bitte um Nachsicht!

Gruß

Saho

s.o.
Du hast den falschen Eintrag verändert.

uci set fastd.mesh_vpn.enabled=0
uci commit fastd

Damit geht das.

1 Like

das war es!

Vielen Dank und angenehmen Abend noch!

1 Like

Was mich erstaunt ist, dass bei Euch ein uci commit fastd den laufenden fastd beendet.
Zumindest meine ich beobachtet zu haben, dass man damit wohl die Config neu geladen bekommt, nicht aber das Ding beendet.

Er hat einfach rebootet…s.o.

Klar geht das smarter, aber ist doch ok :wink:

Bevor ihr das Thema geistig verlässt - in vielen Anleitungen steht „VPN immer anlassen“. Ist das falsch/kaputt?

Ich kann mir nicht vorstellen, welchen Sinn das haben sollte, ausser unnötig RAM zu verbrauchen.

Weil Geräte später mal umbeklemmt werden und das Umprogrammierern für viele NutzerInnen eine echte Aufgabe zu sein scheint. (vgl vielen Threads „komme nicht in den Config-Mode“)

„Er“ = der Router nach Eingabe von uci commit fastd?
Oder „er“= der User?

Der User natürlich!
,

Und wie es bei Deinen Routern derzeit? beendet ein

uci set fastd.mesh_vpn.enabled=0
uci commit fastd

den laufenden fastd im Sinne von „task weg, Ram wieder frei“?

korrekt, ich habe den Router neu gestartet.

Ist das nicht richtig? Sollte man besser like Linux via init die Runlevel wechseln? Oder welcher Prozess soll wie neu gestartet werden?

/etc/init.d/fastd {start|stop|restart}

wäre der einfachste Weg ohne den kompl. Router zu rebooten.

klar, logisch :grin:

Danke!

1 Like