TP-Link CPE210 unter Gluon instabil

Das Problem wandert mit Geräten.
Wenn man also eine andere CPE210 hinhängt, dann läuft die durch.
Und die ursprüngliche CPE210 zeigt den Effekt dann am neuen Standplatz. (trotz anderer Kabel und anderem Netzteil).
Ist also wohl wirklich etwas individuelles.
Trotzdem kein Grund, das deswegen in Garantieabwicklung zu geben oder wegzuwerfen.

Hallo zusammen,
hoffe ich bin hier richtig, ich habe das gleiche Problem, seit der Firmware 2016-1.x.x habe ich gleiche Problematik. Vorher liefen die beiden CPE´s problemlos, auch die Signalpegel-anzeige an der Seite war aktiv (4 LED´s). Es kann mal nur eine Stunde dauern, oder auch mal 9 Tage - ohne neustart. (Die LED´s sind zwar nicht mehr notwendig wegen der neuen Statusseite, zur groben Ausrichtung aber recht hilfreich.

Auf der Statusseite ist das Signal noch zu sehen, allerdings werden keine Bytes mehr transportiert. Wurde beim wechsel der Firmware evtl. ein neuer Treiber für den WLAN-Chip benutzt?
Zum glück gibt es von der anderen Seite per Kabel die Möglichkeit auf den Router zuzugreifen über eine andere Brücke darauf zuzugreifen um den Router per SSH neu zu starten. Am mesh kann es nicht liegen, sonst wäre dies auch per LAN nicht mehr möglich.
Gibt es bisher nur den Workaround den CPE per Script neu zu starten? Bzw. per Modul.?

Dazu gibt es von mir bereits ein Post im Freifunk Münsterland: TP-Link CPE-210 geht offline - Funk & Router - Freifunk Münsterland

Danke im Voraus.
Gruß Boris

den Thread I’m Münsterland-Forum hatte ich letzte Woche gesehen, habe da aber keinen Account (bin ja nicht im Münsterland)
Daher keine Antwort dort.

Hier hat sich das Wificheck-Package bewährt bei 5-6 CPE210ern, die betroffen sind.

(Ja, das Ding bewirkt mehr als man vermuten möchte.)

@adorfer: Du bist herzlich eingeladen dir einen Account zu erstellen. Allerdings halte ich es für deutlich sinnvoller so technische Probleme hier zu diskutieren. Wir haben niemanden, der da so richtig Plan davon hat.

Ich habe auch das Gefühl, dass die CPEs mit 2015.1.2 besser liefen.

Baust du dann spezielle Images für die CPE oder steckst du das überall mit rein?

Grüße
Matthias

Ich stecke das Package überall mit hin
ein, da es nicht schadet.
in seltenen Fällen gibt es auch 841er mit dem Effekt. Die würde ich dann zwar unter „eigentlich defekt“ einordnen. Aber wenn’s hilft, warum nicht.

1 Like

BTW: Ich müsste etwas ähnliches noch mal für’s Lan bauen.
oder das Script erweitern.
Denn wir haben jetzt auch mehrere 841er gefunden, die sporadisch ihr Lan verlieren.
Ohne dass es erkennbar wäre von wegen „down“ oder „no link“. Selbst die Link-LED an Gegenstelle und dem 841er selbst bleibt an. Es gehen nur schlicht keinerlei Daten mehr durch.
Selbst ifconfig down/up hilft nicht(!) weiter.
Mal schauen, wie ich das Minimalinvasiv hinbekomme.

Mal per tftp gefläscht? Die meisten Router mit solchen Zicken konnten wir darüber zur Raison bringen, weil wirklich einmal alles überfläscht.

Oder halt tauschen und an einem Standort aufstellen, wo der LAN-Port nicht gebraucht wird.

Leider alles keine Option, wenn die Dinger einmal auf einem Dach verdübelt sind.

Also bei uns fror das IBSS Mesh bei 841ern (bei v8 und v9 an unterschiedlichen Standorten) in Kombination mit Nanostation (M2 Loco oder M2) ebenfalls regelmäßig ein. Mit dem Script auf den 841ern tritt das nun nicht mehr auf.

In der Anlage mal ein Log, was da genau passiert.
Nach dem ersten Start des Scripts gibts sofort ne Kernel Meldung und danach läuft das Wifi ohne Neustart des Routers wieder.

@adorfer Hast Du eine Idee was hier passiert ist und wodurch sich der Router wieder berappelt hat?
Die Kernel Meldung ist ja noch vor der Log Ausgabe des Scripts gekommen.

Ich überlege das als Bug zu melden, da es so reproduzierbar ist und die Hänger ohne das Script regelmäßig auftreten.

2 Likes

Hallo,

Ich bin noch recht neu hier und habe vor ein paar Tagen meinen cpe210 in Hannover in Betrieb genommen. Soweit so gut.

Jetzt wird hoffentlich bald der nächste Router per Mesh connecteN

Wie bekomme ich denn mit das der Probleme macht? Gibt es da einen watchdog?

Das wäre echt peinlich, da ich eine externe Firma gefragt habe ob die einen bei sich aufstellen kann und dieser keinen eingenen Anschluss hat.

/ken

Sollte der wpa-supplicant-mini tatsächlich gegen die hier beschriebenen Effekte helfen?

nein, aber ich merke das das bei mir hier - arg zusammen fällt mit dem v14v14 helper script … also dem anlegen von extra IF und so
hab leider die nächsten 5 tage kaum zeit dafür … aber hier ist bei manchen wegen dem cp210 land unter

Ich nutze seit mehreren Wochen eine Zeitschaltuhr. Diese dreht nachts gegen 3 Uhr für 5 Minuten der CPE den Saft ab. Hat nebenbei den Vorteil, dass der Router spätestens am nächsten Tag wieder läuft, auch wenn Unitymedia und Konsorten mal eben nach Gusto eine neue IP zuweisen und die CPE dann ebenfalls aussteigt. Zumindest bei Abwesendheit vorteilhaft.

Langsam wird’s unübersichtlich.
Aber veilleicht mag ja wer testen:

2 Likes

Gluon zieht jetzt Teile von OpenWRT und Teile von LEDE? Das wird dann ja spannend :wink:

Ich kann Instabilitäten der CPE210v1 ebenfalls bestatigen. Diese treten jedoch nur unter bestimmten Umständen auf.

Lage:

  • CPE210 versorgt via POE passthrough durch eine andere CPE
  • Gluon 2016.1.4 (Release)
  • Mesh via 11s

Ergebnis:

  • spontane Restarts alle paar Stunden.

Lösung:

  • Wechsel zurück auf Mesh via IBSS.
  • CPE läuft durch.

@adorfer Und hier der Commit für das was du schon immer wusstest bzw. vermutet hast: git.openwrt.org Git - openwrt/openwrt.git/commit

@wusel Gluon wird komplett auf LEDE umsteigen. Nicht zuletzt weil NeoRaider auch einer der LEDE Hauptentwickler ist.

Das erklärt aber doch allenfalls die Taubheit des Gerätes unter OpenWRT, nicht aber die Instabilität, oder?

Die überarbeitete Version des Scripts ist zu finden als

(Das prüft nun auch nach Lan-Mesh und findet wegbrechende Lanverbindungen so „unnormal“, dass in so einem Fall nach wiederholt negativem Check ein Reboot erfolgt, in der hoffnung, dass die Phy-Aushandlung am Switch das Problem behebt.)

2 Likes

Ziemlich praktisch, aber irgendwie wäre mir doch wohler, mal die Ursache zu finden.

3 Likes