TP-Link TL-WR1043ND "Spezialconfig"

Das ist eine Idee, die es schon recht lange gibt. Auch wurde mal darüber gesprochen, ob man dafür ein grafisches Konfigurationspaket bauen könnte.

Das würde vermutlich sofort angenommen. Es müsste nur jemand bauen. :).

Danke für den Beitrag, ich baue da auch gerade an was, einen 1043er als VLAN-Switch zu verwenden. So, wie du es gemacht hast, hatte ich es auch verstanden. Das ‚T‘ steht für tagged.

Grüße
Matthias

2 Likes

Naja, ist ja schon nen Sonderfall und vielleicht ist es besser, dass man das nicht grafisch einstellen kann, damit man sich damit auch etwas auseinandersetzt und nicht einfach nur klicken muss :wink:

Für einen 1043 Version 3.0 sieht das Ganze aber scheinbar schon wieder etwas anders aus, wenn ich das richtig sehe. Da müsste ich mir nochmal ein Gerät zum testen holen.

1 Like

Deine Anleitung funktioniert bei mir, vielen Dank!

Ein /etc/init.d/network restart hat mir das Gerät leider abgeschossen. Nach einem Neustart ging es wieder. Wenn man das per Fernwartung macht also lieber drei mal gucken, dass die Syntax passt und dann reboot machen.

Ich nehme alles zurück, wenn man auf die LAN-Ports Clientnetz untagged und Meshnetz auf VLAN3 schaltet, hängt sich der 1043er alle paar Stunden weg und ist auch über WAN nicht mehr erreichbar, vermutlich, weil der Switch irgendwie abgeschmiert ist.

Wir probieren jetzt mit einem zweiten Kabel auf einem Port LAN und auf einem anderen Mesh. Mal sehen, ob das stabil läuft.

@MPW gut zu wissen, muss bei „meinem“ 100xWLAN-Standort ja auch eine VLAN-Config mit dem 1043er einrichten. Kannst du noch einen Bugreport aufmachen? Damit andere Bescheid wissen und das evtl. gefixt werden kann.

Ich hatte mich in Oldenburg noch mit Elektra über die Switche in diesen Billigroutern unterhalten, die sind wohl ziemlich schlecht dokumentiert. Und das ist ja nichtmals eine offiziell unterstütze Funktion. Ich weiß nicht, wo ich da einen Bug aufmachen soll. Meinst du im Gluon oder bei Lede?

Erstmal müsste man an einen eine serielle Konsole anstecken und gucken. Oder per WLAN könnte auch gehen, da kam ich in diesem Fall nicht dran.

Habe mal nachgefragt, Bugreport ist sinnvoll. Bei LEDE dann :slight_smile:

Okay, danke.

hi

wir liefern unsere Firmware standartmäßig so aus das:
WAN → WAN (ethx.2)
2 LAN Ports neben den WAN → Batman/mesh (ethx.3)
2 LAN Ports die weiter weg von WAN sind → Client (ethx.1)

dabei haben wir keine Probleme mit abstürze, das klappt auch auf den 841er und anderen Kisten problemlos.

Für RF Strecken hab ich auf einen 1043er (v2 oder v3 grad nicht ganz sicher) folgende Sonderconfig (hat sich zig mal geändert, deshalb auch weit weg von unseren Standart, hat sich halt so ergeben nach und nach):

CLIENT_PORTS=„1 2 4 6t“ # eth0.1
WAN_PORTS=„5 6t“ # eth0.2 aktuell der einzig freie Port, nicht in Verwendung
BATMAN_PORTS=„3 4t 6t“ #eth0.3
plus ein weiteres VLAN um Babel von einer auf ne andere RF Strecke umzusetzen (eigentlich ist 6t unnötig aber egal):
config interface ‚vlan4‘
option ifname ‚eth0.4‘

config switch_vlan ‚eth0_4‘
option device ‚ag71xx-mdio.0‘
option vlan ‚4‘
option ports ‚1t 4t 6t‘
(6t ist zur CPU)

Plan sieht noch vor, 4t mit ins eth0.2 zu stecken, damit das priv. Netz über die RF Strecke hier wieder auf den blauen Port untagged mit rausfällt, wird demnächst konfiguriert und klappt bestimmt auch :wink:

läuft noch unter dem letzten OpenWRT Release, würde aber wetten das klappt unter LEDE genauso. Kein Gluon sondern eigene Firmware.

auch dieser läuft absolut stabil ohne Probleme. Nur 841er mögen es nicht, auf einen Port tagged und untagged gleichzeitig, sie taggen dann einfach alles obwohl die config was anderes sagt (ihhhh). Hab auch mal was munkeln hören das VLAN IDs >16 Probleme machen sollen, hab ich bisher aber nie gebraucht und zumindest ein Kollege hat auf nen wdr4900 VLAN ID 101 am laufen, also entweder betrifft das nur einen Teil der Router oder ist nur ein munkeln :wink:

Also entweder ist es ein Gluonspezifsches Problem oder… Wobei ich mir nicht vorstellen kann, was Gluon da kaputt machen sollte. Am Switch der Router scheint es auf jeden Fall nicht zu liegen.

Achja bei den ganzen Sonderconfig Zeug muss man höllisch aufpassen, das man keine 2 gleichen MAC Adressen ins gleiche Layer 2/Batman Netz steckt!

mfg

Christian

@ChrisD, danke für deine Rückmeldung. Es kann natürlich auch immer sein, dass das eine Gerät eine Macke hat.

Ich werde das nochmal testen. Meines ist ein V4, aber das sollte nicht viel ändern.

Hallo,

ich muss das nochmal aufgreifen. Wir haben jetzt an einem zweiten Standort exakt dasselbe Problem.

Gemeinsamkeiten:

  • Beides V4
  • dahinter hängt jeweils ein Ubiquity-Switch

Theorien:

  • Entweder gibt es einen Bug im V4, @ChrisD, hast du V4er an denen du das mit geteilten Ports laufen hast
  • Oder die Ubiquity-Switch überforderen die Switche der 1043er. Da gehen ja dann ziemlich viele Macadressen drüber. Das sind alles so Installationen, wo teilweise 200 Clients an APs mit Nichtfreifunksoftware dran hängen.

Ich habe folgende Konfiguration probiert, die zum Absturz nach zwei bis zehn Stunden. Eventuell kann da mal jemand drüber sehen, vielleicht habe ich auch einen Fehler gemacht:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdeb:9e2a:669e::/48'

config interface 'wan6'
	option proto 'dhcpv6'
	option sourcefilter '0'
	option ifname 'br-wan'
	option ip6table '1'
	option peerdns '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 1 2'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '0t 3 4'

config interface 'wan'
	option ifname 'eth0.2'
	option multicast_querier '0'
	option peerdns '0'
	option auto '1'
	option type 'bridge'
	option proto 'dhcp'
	option macaddr 'ca:20:9c:5d:61:90'

config rule6 'wan6_lookup'
	option mark '0x01/0x01'
	option lookup '1'

config route6 'wan6_unreachable'
	option type 'unreachable'
	option table '1'
	option target '::/0'
	option metric '65535'
	option gateway '::'
	option interface 'loopback'

config interface 'ibss_radio0'
	option proto 'gluon_mesh'

config interface 'mesh_wan'
	option ifname 'br-wan'
	option auto '0'
	option transitive '1'
	option fixed_mtu '1'
	option proto 'gluon_mesh'

config interface 'mesh_lan'
	option igmp_snooping '0'
	option ifname 'eth0.3'
	option transitive '1'
	option fixed_mtu '1'
	option proto 'gluon_mesh'
	option type 'bridge'
	option macaddr 'ca:20:9c:5d:61:94'
	option auto '1'

config interface 'client'
	option type 'bridge'
	option macaddr '84:16:f9:c8:94:9e'
	option proto 'dhcpv6'
	option reqprefix 'no'
	option robustness '3'
	option query_interval '2000'
	option query_response_interval '500'
	option peerdns '1'
	option sourcefilter '0'
	list ifname 'bat0'
	list ifname 'eth0.1'

config interface 'bat0'
	option multicast_router '2'
	option ifname 'bat0'
	option macaddr '84:16:f9:c8:94:9e'
	option learning '1'
	option proto 'none'

config interface 'mesh_vpn'
	option ifname 'mesh-vpn'
	option mtu '1364'
	option proto 'gluon_mesh'
	option fixed_mtu '1'
	option transitive '1'

config device 'local_node_dev'
	option macaddr 'de:ad:be:ef:08:01'
	option ifname 'br-client'
	option name 'local-node'
	option type 'macvlan'

config interface 'local_node'
	option ifname 'local-node'
	option ipaddr '10.2.0.1'
	option ip6addr '2a03:2260:115:200::1/128'
	option netmask '255.255.0.0'
	option proto 'static'

config route6 'local_node_route6'
	option target '2a03:2260:115:200::/64'
	option gateway '::'
	option interface 'client'

Geändert habe ich nur diesen Block hier:

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 1 2'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '0t 3 4'

Viele Grüße
Matthias

hi

ich persönlich hab aktuell keinen v4 am laufen. Da dies aber bei uns absoluter Standart ist und hier (gerade mal nachgeguckt) 119 1043v4 Router laufen und sich bisher niemand beschwehrt hat über sowas (das machen sogar 841er problemlos), gehe ich mal davon aus das es hier geht.

Das einzige was evtl. sein könnte, das einfach niemand am Client und Batmanport etwas gleichzeitig angestöpselt hat, die Situation ist ja auch nicht soooo häufig. Stürzen sie auch ab, wenn die config zwar aktiviert ist aber nichts angesteckt ist?

mfg

Christian

Das müsste ich nochmal zu Hause testen.

So, gerade war der nächste Absturz. Ist unserer Meinung nach definitiv mit der Auslastung verbunden. Als wieder alles lief und sich hier so knapp 200 Clients verbunden hatten, ist das Ding ziemlich zeitnah in die Knie gegangen. Wie man am Namen sieht, geht es um den Hauptbahnhof Münster, in der Abendzeit sind da natürlich viele Leute unterwegs :wink: .

Im logread steht leider gar nichts, nur das Mesh-VPN reißt irgendwann ab, weil halt alle Ports tot sind. (Geprüft über WLAN vor Ort.)

Ich hab mal auch die Switch-Config gedumpt, vielleicht erkennt da jemand was:

root@HBF-Gluon-SPD:~# swconfig dev switch0 show
Global attributes:
	enable_vlan: 1
	enable_mirror_rx: 0
	enable_mirror_tx: 0
	mirror_monitor_port: 0
	mirror_source_port: 0
	arl_table: address resolution table
Too many entries found, displaying the first 100 only!
Port 0: MAC f0:79:60:82:7c:0a
Port 0: MAC 78:4f:43:19:d6:d4
Port 0: MAC 30:63:6b:e4:bc:b5
Port 0: MAC 80:ea:96:68:a6:ee
Port 0: MAC 18:89:5b:98:d0:be
Port 0: MAC 60:e3:27:b2:d4:a4
Port 0: MAC 00:19:99:5f:b3:64
Port 0: MAC 30:07:4d:a7:ce:e2
Port 0: MAC e8:94:f6:6d:0c:f0
Port 0: MAC ec:9b:f3:f9:b2:be
Port 0: MAC 74:1b:b2:a5:0f:48
Port 0: MAC 64:70:02:52:68:68
Port 0: MAC 58:7f:57:8f:32:65
Port 0: MAC 78:a3:e4:ee:9d:82
Port 0: MAC 14:a5:1a:1f:17:c2
Port 0: MAC 60:92:17:29:d7:30
Port 0: MAC dc:a9:04:2d:47:be
Port 0: MAC 50:c7:bf:7b:39:24
Port 0: MAC 98:de:d0:aa:86:16
Port 0: MAC 1c:5c:f2:67:fc:ae
Port 0: MAC de:b5:fe:b8:b2:84
Port 0: MAC 80:2a:a8:2d:c6:68
Port 0: MAC 3c:fa:43:71:1f:d8
Port 0: MAC 84:7a:88:32:8f:96
Port 0: MAC 8c:1a:bf:82:a0:4a
Port 0: MAC 2c:f0:a2:2a:6f:7d
Port 0: MAC 18:65:90:80:30:7a
Port 0: MAC 34:69:87:2c:65:6f
Port 0: MAC d4:a1:48:03:8b:f1
Port 0: MAC 4c:66:41:22:37:9a
Port 0: MAC 94:b1:0a:31:06:01
Port 0: MAC f4:09:d8:66:01:73
Port 0: MAC d8:5b:2a:fa:39:af
Port 0: MAC 18:65:90:1e:b3:38
Port 0: MAC e8:50:8b:8f:c1:f1
Port 0: MAC 00:b3:62:00:00:9c
Port 0: MAC cc:20:e8:64:d8:93
Port 0: MAC 34:69:87:cd:a0:ff
Port 0: MAC e8:94:f6:6d:0c:c6
Port 0: MAC 8c:79:67:20:84:14
Port 0: MAC 4c:66:41:cf:0d:d2
Port 0: MAC 5c:a8:6a:6d:2b:c3
Port 0: MAC f8:1a:67:51:64:92
Port 0: MAC e4:9a:79:10:6d:11
Port 0: MAC c0:cc:f8:e8:88:c0
Port 0: MAC e8:94:f6:6d:10:ce
Port 0: MAC 30:b5:c2:d9:9a:3e
Port 0: MAC 90:f6:52:f8:f2:02
Port 0: MAC 0c:84:dc:9c:c6:7f
Port 0: MAC 20:6e:9c:dd:4d:07
Port 0: MAC 70:14:a6:5e:04:5f
Port 0: MAC 50:82:d5:cc:04:17
Port 0: MAC 84:c7:ea:36:47:68
Port 0: MAC bc:6c:21:8f:49:1b
Port 0: MAC 00:5a:13:0b:7d:8e
Port 0: MAC e8:94:f6:42:8f:c0
Port 0: MAC 14:1f:78:7b:19:eb
Port 0: MAC 88:83:22:fa:61:64
Port 0: MAC e8:94:f6:6d:0c:da
Port 0: MAC e8:94:f6:63:0d:02
Port 0: MAC 60:e3:27:76:9d:e2
Port 0: MAC c4:6e:1f:ae:23:ee
Port 0: MAC 3c:05:18:0f:03:1d
Port 0: MAC c0:bd:d1:e7:db:d4
Port 0: MAC 00:93:44:21:6e:c9
Port 0: MAC 78:c3:e9:05:63:b2
Port 0: MAC 70:70:0d:6b:e1:27
Port 0: MAC 18:a6:f7:8b:9b:42
Port 0: MAC f8:d0:ac:e6:d5:43
Port 0: MAC a4:2b:b0:ca:78:10
Port 0: MAC a0:f3:c1:5b:54:6e
Port 0: MAC f4:f2:6d:40:47:9a
Port 0: MAC 30:b5:c2:b0:55:02
Port 0: MAC c0:1a:da:46:67:52
Port 0: MAC c8:85:50:90:bf:de
Port 0: MAC 8c:f5:a3:e4:3c:32
Port 0: MAC b8:e8:56:ab:6e:31
Port 0: MAC 84:16:f9:c8:94:9e
Port 0: MAC d8:5b:2a:4c:ed:89
Port 0: MAC bc:76:5e:d4:ba:aa
Port 0: MAC 24:5b:a7:dc:c7:34
Port 0: MAC d8:bb:2c:e0:ae:15
Port 0: MAC cc:08:8d:21:42:9e
Port 0: MAC 38:ca:da:d7:9c:50
Port 0: MAC f0:d1:a9:a7:3e:89
Port 0: MAC 1c:99:4c:fe:a0:db
Port 2: MAC bc:54:36:77:ac:4b
Port 2: MAC 84:7a:88:69:9b:a9
Port 2: MAC 2c:59:8a:5a:be:76
Port 2: MAC c0:bd:d1:af:2d:ba
Port 2: MAC d4:61:2e:d5:b5:d3
Port 2: MAC ec:10:7b:71:b4:dc
Port 2: MAC 48:43:7c:c6:2f:23
Port 2: MAC 68:db:ca:0b:8d:85
Port 2: MAC 1c:5c:f2:6c:93:54
Port 2: MAC 8c:1a:bf:24:3f:ff
Port 2: MAC 3c:05:18:03:fc:9f
Port 2: MAC 0c:d7:46:67:ed:a1
Port 2: MAC 28:3f:69:32:e3:73
Port 4: MAC ce:95:62:87:f4:50

Port 0:
	mib: Port 0 MIB counters
RxBroad     : 207485
RxPause     : 0
RxMulti     : 125217
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 39084
Rx128Byte   : 474667
Rx256Byte   : 666811
Rx512Byte   : 74639
Rx1024Byte  : 75377
Rx1518Byte  : 524348
RxMaxByte   : 279
RxTooLong   : 0
RxGoodByte  : 929663459
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 2145
TxBroad     : 112329
TxPause     : 12
TxMulti     : 26613
TxUnderRun  : 0
Tx64Byte    : 40
Tx128Byte   : 579932
Tx256Byte   : 516372
Tx512Byte   : 88917
Tx1024Byte  : 37671
Tx1518Byte  : 631974
TxMaxByte   : 293
TxOverSize  : 0
TxByte      : 1065566175
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	enable_eee: ???
	pvid: 0
	link: port:0 link:up speed:1000baseT full-duplex txflow rxflow 
Port 1:
	mib: Port 1 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	enable_eee: 0
	pvid: 1
	link: port:1 link:down
Port 2:
	mib: Port 2 MIB counters
RxBroad     : 69818
RxPause     : 0
RxMulti     : 23795
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 26618
Rx128Byte   : 423423
Rx256Byte   : 35802
Rx512Byte   : 18068
Rx1024Byte  : 6607
Rx1518Byte  : 72982
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 150878936
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 65093
TxBroad     : 22972
TxPause     : 0
TxMulti     : 124456
TxUnderRun  : 0
Tx64Byte    : 36393
Tx128Byte   : 245579
Tx256Byte   : 37115
Tx512Byte   : 15914
Tx1024Byte  : 19425
Tx1518Byte  : 403693
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 572083595
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	enable_eee: 0
	pvid: 1
	link: port:2 link:up speed:1000baseT full-duplex auto
Port 3:
	mib: Port 3 MIB counters
RxBroad     : 32221
RxPause     : 0
RxMulti     : 14
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 3858
Rx128Byte   : 22848
Rx256Byte   : 13206
Rx512Byte   : 3492
Rx1024Byte  : 979
Rx1518Byte  : 499
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 7388622
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 256807
TxPause     : 0
TxMulti     : 2531
TxUnderRun  : 0
Tx64Byte    : 10377
Tx128Byte   : 216783
Tx256Byte   : 34807
Tx512Byte   : 9446
Tx1024Byte  : 1114
Tx1518Byte  : 727
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 35175413
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	enable_eee: 0
	pvid: 3
	link: port:3 link:up speed:100baseT full-duplex txflow rxflow auto
Port 4:
	mib: Port 4 MIB counters
RxBroad     : 72505
RxPause     : 0
RxMulti     : 2493
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 9016
Rx128Byte   : 122249
Rx256Byte   : 30897
Rx512Byte   : 17342
Rx1024Byte  : 2347
Rx1518Byte  : 6674
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 35275105
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 6
TxBroad     : 216556
TxPause     : 0
TxMulti     : 52
TxUnderRun  : 0
Tx64Byte    : 14879
Tx128Byte   : 233619
Tx256Byte   : 45690
Tx512Byte   : 14605
Tx1024Byte  : 4979
Tx1518Byte  : 45754
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 103095390
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	enable_eee: 0
	pvid: 3
	link: port:4 link:up speed:1000baseT full-duplex auto
Port 5:
	mib: Port 5 MIB counters
RxBroad     : 68
RxPause     : 0
RxMulti     : 1052
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 1887
Rx128Byte   : 44532
Rx256Byte   : 434034
Rx512Byte   : 50778
Rx1024Byte  : 28142
Rx1518Byte  : 552291
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 874931498
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 39
TxPause     : 0
TxMulti     : 24
TxUnderRun  : 0
Tx64Byte    : 897
Tx128Byte   : 9482
Tx256Byte   : 583951
Tx512Byte   : 42981
Tx1024Byte  : 50614
Tx1518Byte  : 74581
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 250204794
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	enable_eee: 0
	pvid: 2
	link: port:5 link:up speed:100baseT full-duplex txflow rxflow auto
Port 6:
	mib: Port 6 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	enable_eee: ???
	pvid: 0
	link: port:6 link:down
VLAN 1:
	vid: 1
	ports: 0t 1 2 
VLAN 2:
	vid: 2
	ports: 0t 5 
VLAN 3:
	vid: 3
	ports: 0t 3 4 

Also ich bin mir relativ sicher, dass das bei euch auch passieren wird, wenn man da 200 Clients dranhängt.

Wir entschärfen das jetzt provisorisch mit einem zweiten 1043er, der eine macht nur Mesh auf den LAN-Ports für die APs mit Gluon. Außerdem kommt ein 2. 1043er dran, der dann Mesh in Clientnetz umwandelt, für die Nicht-GLUON-APs.

Grüße
Matthias

Wie müsste denn die Config für den 1043er aussehen, wenn man jedem Port ein eigenes Batman-Interface geben wollte, also eine eigene br, der dann wiederum einzeln ins batctl eingehängt wird?

Mit dem Blick ins Openwrt-Wiki wird’s klarer:

grafik

Oder ist das jetzt „doppelt gemoppelt“.

löschen:

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

neu:

config switch_vlan
        option device 'switch0'
        option vlan '11'
        option ports '0t 1'

config switch_vlan
        option device 'switch0'
        option vlan '12'
        option ports '0t 2'

config switch_vlan
        option device 'switch0'
        option vlan '13'
        option ports '0t 3'

config switch_vlan
        option device 'switch0'
        option vlan '14'
        option ports '0t 4'

config interface 'mesh_lan11'
        option igmp_snooping '0'
        option ifname 'eth0.11'
        option vlan '11'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option type 'bridge'
        option auto '1'
        option macaddr 'c4:6e:1f:d6:70:11'
    
        
config interface 'mesh_lan12'
        option igmp_snooping '0'
        option ifname 'eth0.12'
        option vlan '12'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option type 'bridge'
        option auto '1'
        option macaddr 'c4:6e:1f:d6:70:12'

config interface 'mesh_lan13'
        option igmp_snooping '0'
        option ifname 'eth0.13'
        option vlan '13'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option type 'bridge'
        option auto '1'
        option macaddr 'c4:6e:1f:d6:70:13'

config interface 'mesh_lan14'
        option igmp_snooping '0'
        option ifname 'eth0.14'
        option vlan '14'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option type 'bridge'
        option auto '1'
        option macaddr 'c4:6e:1f:d6:70:14'

Also ein anderer Ansatz wäre wie auf den Gateways die Brücken, die die L2TP-Interfaces beherbergen:

post-up ebtables -A FORWARD --logical-in $IFACE -j DROP

Dadurch werden die Interfaces in einer Brücke (in diesem Fall die L2TP-Interfaces) nicht untereinander geswitcht, sondern alle nur zum Batman hin. Wenn man das dem Hardwareswitch irgendwie beibringen kann, kann man sich das ganze andere Geraffel sparen.

Ansonsten sieht dein Ansatz aber gut aus.

A post was split to a new topic: Aufbau eines Freifunknetzes in Westerburg

Hallo Patrik,

wo wohnst du bitte im WW ?
Ich plane als frisch zertifizierter Digital Botschafter des Landes RLP Freifunk in alle Senioren Einrichtungen u.a. zu bringen.
Bist du dabei ?

Bitte dich aber bis zum Herbst zu gedulden habe noch andere Termine inkl. Urlaub.
Als weitere Steigerung für die Zukunft könnte ich mir auch das Netzwerk LoraWan vorstellen.

Weitere Mitstreiter aus der Umgebung Westerburg sind willkommen, denn auf die Professionellen Anbieter ist kaum Verlass !
Bitte kurze Nachricht an:

Wolfgang
digibo.wowo@gmail.com

Hallo Wolfgang,

ich bin in Sachen Freifunk inzwischen gar nicht mehr aktiv und kann somit leider nicht unterstützen.

Viele Grüße,
Patrik

Ok schade und danke.

lg
wowo