Ubiquiti Edge-Router X-SFP kaputt geflasht


#1

Hallo zusammen,

Ich habe einen ER-X-SFP, auf dem ich nach dem flashen nicht mehr drauf komme.

Ich habe zuerst diese Anleitung genommen (gilt zwar nur für den ER-X, hat aber trotzdem fuktioniert):

https://www.freifunk-winterberg.net/die-nutzung-von-ubiquiti-edgerouter-x-als-freifunk-offloader/

Danach habe ich mit -force folgende Firmware installiert:

https://util.berlin.freifunk.net/hardware?name=ubnt-erx-sfp

Nun komme ich nach dem booten über keinen LAN-Port mehr auf den Router.

Da der Router einen Seriellen-Anschluss hat habe ich versuch darüber Zugang zu erhalten. Egal mit welcher Baudrate, ich bekomme nur Sonderzeichen. Ich habe als Com-Port die Docking-Station eines Thinkpad T400 und einen CH340-Adapter (sowohl unter Win als auch unter Linux) verwendet, leider bekomme ich nichts anderes als Sonderzeichen übermittelt.

Gibt es noch eine Möglichkeit noch auf das Gerät zu kommen oder kann ich den Router abschreiben?

Gruß,
Bytegetter


#2

@kaki :slight_smile:


#3

Dann schau mal CP210x/CP2102 besser als CH340/CH340G an.


#4

Mit dem SFP-Gerät habe ich noch nix gemacht, wir haben nur mehrere von den ER-X laufen, das hat bisher problemlos funktioniert. Ist das ER-X-Image auch für den SFP unterstützt?


#5

https://wiki.openwrt.org/toh/ubiquiti/ubiquiti_edgerouter_x_er-x_ka#serial

Informationen zur Seriellen im Wiki beachtet?

Ich denke der Router ist noch zu retten. Du musst nur die Sonderzeichen entziffern indem du die richtigen Einstellungen für die Serielle findest.


#6

Moin,

Ich habe mir den anderen Adapter aus dem Link bestellt, mal schauen, ob ich damit mehr erfolg habe.

Das Image zur Erstinstallation hat zumindest funktioniert, er hat damit gebootet und ich kam auf die Console.


#7

Dann solltest du das eigentliche Image per sysupgrade Befehl flashen können.


#8

Das Image https://www.freifunk-winterberg.net/wp-content/uploads/2017/07/lede-ramips-mt7621-ubnt-erx-initramfs-factory.tar ist ja nicht das passende (auch wenn es funktioniert). Gibt es evtl. ein Factory-Image für den x-sfp?


#9

Wenn das initramfs-factory Image läuft einfach das Sysupgrade-Image flashen. Console öffnen, Datei kopieren (scp) und “sysupgrade” ausführen.

Vielleicht ist folgendes Image richtig:

http://images.freifunk-winterberg.net/winterberg_kernstadt/sysupgrade/gluon-ffwtbg_kernstadt-0.8.14.1-ubnt-erx-sysupgrade.tar


#10

Genau, man muss von stock einmalig über das initramfs-factory-Image gehen. Die 0.8.14.1 habe ich vor einigen Tagen erst gebaut, Basis ist Gluon v2017.1.4
Ich habe bisher immer nur mit der Non-SFP-Variante gearbeitet, weil wir bisher keinen Bedarf an SFP haben :slight_smile:
Gruß, Jan


#11

Kann man Gluon auch direkt als initramfs-image bauen und sich so den “Umweg” sparen?


#12

Das SFP-image hat den Vorteil, dass die PoE-Optionen fertig integriert sind.

system.poe_power_port0=gpio_switch
system.poe_power_port0.name='PoE Power Port0'
system.poe_power_port0.gpio_pin='496'
system.poe_power_port0.value='0'
[...]

#13

Kurze Frage zu dem EdgeRouter: Wenn ich dort Freifunk aufspiele, funktionieren dann noch die SFP/GBIC Module wie zuvor? oder gibt es Einschränkungen wie keine HotPlug-Fähigkeit mehr etc.? oder muss die Unterstützung von LEDE aus implementiert werden?

Vielen Dank!


#14

Da die Freifunk-Firmware auf LEDE/OpenWRT basiert, kann dir diese Frage tendenziell am besten das LEDE-Forum beantworten.

Grundsätzlich sollte es kein Problem sein (behaupte ich bis zum Beweis des Gegenteils). Gegenbeweis steht hier: ER-X-SFP - SFP (eth5) port has link-state (LED = lit), but swconfig says link: port:5 link:down - For Developers - LEDE Project Forum

Also doch das LEDE-Forum fragen oder einfach ausprobieren, inzwischen gibt es ja eine Prozedur, die Stock-FW wieder aufzuspielen: Lösung: Gluon auf UBNT EdgeRouter X oder X-SFP (inkl. zurück zur UBNT-Stockfirmware)


#15

Vielen Dank für deine Antwort!

Ich hab jetzt mal unsere FW auf einem ER X SFP installiert und in der Netzwork Conf finde ich lieder kein eth 5 für den SFP Port :confused:

Aber bei

option ports '1 2 3 4 6t'

fehlt die 5. Könnte das eth5 sein? 6 ist die CPU.

Mit welchem Befehl kann ich schauen ob ein Port UP ist? und evlt auch mit welcher Geschwindigkeit?

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fda0:cae0:a6e4::/48'

config device 'lan_dev'
    option name 'eth0.1'
    option macaddr '78:8a:20:0d:18:3a'

config device 'wan_dev'
    option name 'eth0.2'
    option macaddr '78:8a:20:0d:18:3b'

config interface 'wan6'
    option proto 'dhcpv6'
    option ifname 'br-wan'
    option ip6table '1'
    option sourcefilter '0'
    option peerdns '0'
    option reqprefix 'no'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0 6t'

config interface 'wan'
    option igmp_snooping '1'
    option ifname 'eth0.2'
    option multicast_querier '0'
    option peerdns '0'
    option auto '1'
    option type 'bridge'
    option proto 'dhcp'
    option macaddr '4a:ee:d0:a5:5b:70'

config rule6 'wan6_lookup'
    option mark '0x01/0x01'
    option lookup '1'

config route6 'wan6_unreachable'
    option type 'unreachable'
    option table '1'
    option target '::/0'
    option metric '65535'
    option gateway '::'
    option interface 'loopback'

config interface 'mesh_wan'
    option ifname 'br-wan'
    option transitive '1'
    option fixed_mtu '1'
    option proto 'gluon_mesh'
    option auto '1'

config interface 'mesh_lan'
    option igmp_snooping '0'
    option ifname 'eth0.1'
    option transitive '1'
    option fixed_mtu '1'
    option proto 'gluon_mesh'
    option type 'bridge'
    option auto '0'
    option macaddr '4a:ee:d0:a5:5b:74'

config interface 'client'
    option igmp_snooping '1'
    option type 'bridge'
    option auto '1'
    option multicast_querier '1'
    option macaddr '78:8a:20:0d:18:3a'
    option ipv6 '1'
    option keep_ra_dnslifetime '1'
    option sourcefilter '0'
    option peerdns '0'
    option robustness '9'
    option reqprefix 'no'
    option query_interval '2000'
    option query_response_interval '500'
    option proto 'dhcpv6'
    list ifname 'eth0.1'
    list ifname 'local-port'
    list ifname 'bat0'

config device 'local_node_dev'
    option type 'veth'
    option name 'local-node'
    option peer_name 'local-port'
    option macaddr '16:41:95:40:f7:dc'
    option peer_macaddr '78:8a:20:0d:18:3a'

config interface 'local_node'
    option ifname 'local-node'
    option ip6addr 'fd74:fdaa:9dc4::127/128'
    option ip6deprecated '1'
    option proto 'static'

config interface 'gluon_bat0'
    option proto 'gluon_bat0'

config interface 'bat0'
    option multicast_router '2'
    option ifname 'bat0'
    option auto '1'
    option macaddr '78:8a:20:0d:18:3a'
    option learning '1'
    option proto 'none'

config route6 'local_node_route6'
    option target 'fd74:fdaa:9dc4::/64'
    option gateway '::'
    option interface 'client'

config interface 'mesh_vpn'
    option ifname 'mesh-vpn'
    option transitive '1'
    option mtu '1312'
    option macaddr '4a:ee:d0:a5:5b:77'
    option fixed_mtu '1'
    option proto 'gluon_mesh'

config interface 'fallback'
    option sourcefilter '0'
    option proto 'dhcp'
    option peerdns '1'

config interface 'fallback6'
    option sourcefilter '0'
    option ifname '@fallback'
    option peerdns '1'
    option proto 'dhcpv6'

#16

root:~# swconfig list
Found: switch0 - eth0

root:~# swconfig dev switch0 show

Global attributes:
    enable_vlan: 1
Port 0:
    pvid: 1
    link: port:0 link:up speed:1000baseT full-duplex txflow rxflow
Port 1:
    pvid: 1
    link: port:1 link:down
Port 2:
    pvid: 1
    link: port:2 link:up speed:100baseT full-duplex auto
Port 3:
    pvid: 1
    link: port:3 link:up speed:100baseT full-duplex auto
Port 4:
    pvid: 1
    link: port:4 link:up speed:100baseT full-duplex auto
VLAN 1:
    vid: 1
    ports: 0 1 2 3 4

#17

moin,
hab gerade nen er-x-sfp auf dem tisch gehabt. wollt nicht booten. stand was von loading image, crc fail auf der seriellen schnittstelle.
kleine anleitung zum debricken via tftp mit serieller console bei den dingern:

1: er-x erwartet den rechner mit tftp server auf 172.16.3.210 ( er-x hat 172.16.3.211 im bootloader )
2: wir verbinden uns über port 0
3: der er-x erwartet auf dem server ne datei names vme50 zu finden. ( laden wir uns also nen passendes openwrt initramfs-kernel.bin von der openwrt seite und werfen es in das root verzeichnis des tftp-servers unter dem dateinamen vme50 )
4:

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.
default: 3

You choosed 2

hier laden wir das firmware file und schreiben es direkt ins flash. danach rebootet der er-x und alles ist wieder gut!!!

hier der komplette log, allerdings mit option 1 ( load system code to SDRAM via TFTP ) kann man machen um zu checken ob das image läuft bevor man es ins flash schreibt…


===================================================================
                MT7621   stage1 code 10:33:11 (ASIC)
                CPU=50000000 HZ BUS=16666666 HZ
==================================================================
Change MPLL source from XTAL to CR...
do MEMPLL setting..
MEMPLL Config : 0x11100000
3PLL mode + External loopback
=== XTAL-40Mhz === DDR-1200Mhz ===
PLL3 FB_DL: 0xf, 1/0 = 529/495 3D000000
PLL2 FB_DL: 0x14, 1/0 = 603/421 51000000
PLL4 FB_DL: 0x14, 1/0 = 639/385 51000000
do DDR setting..[00320381]
Apply DDR3 Setting...(use customer AC)
          0    8   16   24   32   40   48   56   64   72   80   88   96  104  112  120
      --------------------------------------------------------------------------------
0000:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0001:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0002:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0003:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0004:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0005:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0006:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0007:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0008:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0009:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000A:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000B:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000C:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000D:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    1    1
000E:|    0    0    0    0    0    0    0    0    0    1    1    1    1    1    1    1
000F:|    0    0    0    0    1    1    1    1    1    1    1    1    1    1    0    0
0010:|    1    1    1    1    1    1    1    1    1    0    0    0    0    0    0    0
0011:|    1    1    1    1    0    0    0    0    0    0    0    0    0    0    0    0
0012:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0013:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0014:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0015:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0016:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0017:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0018:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0019:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001A:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001B:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001C:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001D:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001E:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001F:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
rank 0 coarse = 15
rank 0 fine = 72
B:|    0    0    0    0    0    0    0    0    1    1    1    0    0    0    0    0
opt_dle value:9
DRAMC_R0DELDLY[018]=00001A1B
==================================================================
                RX      DQS perbit delay software calibration
==================================================================
1.0-15 bit dq delay value
==================================================================
bit|     0  1  2  3  4  5  6  7  8  9
--------------------------------------
0 |    11 8 10 11 11 6 11 7 5 9
10 |    9 13 7 11 9 10
--------------------------------------

==================================================================
2.dqs window
x=pass dqs delay value (min~max)center
y=0-7bit DQ of every group
input delay:DQS0 =27 DQS1 = 26
==================================================================
bit     DQS0     bit      DQS1
0  (1~51)26  8  (1~48)24
1  (1~52)26  9  (1~49)25
2  (1~53)27  10  (1~52)26
3  (1~51)26  11  (1~48)24
4  (1~53)27  12  (1~48)24
5  (1~53)27  13  (1~50)25
6  (1~54)27  14  (1~49)25
7  (1~54)27  15  (1~52)26
==================================================================
3.dq delay value last
==================================================================
bit|    0  1  2  3  4  5  6  7  8   9
--------------------------------------
0 |    12 9 10 12 11 6 11 7 7 10
10 |    9 15 9 12 10 10
==================================================================
==================================================================
     TX  perbyte calibration
==================================================================
DQS loop = 15, cmp_err_1 = ffff0000
dqs_perbyte_dly.last_dqsdly_pass[0]=15,  finish count=1
dqs_perbyte_dly.last_dqsdly_pass[1]=15,  finish count=2
DQ loop=15, cmp_err_1 = ffff00a2
dqs_perbyte_dly.last_dqdly_pass[1]=15,  finish count=1
DQ loop=14, cmp_err_1 = ffff0080
DQ loop=13, cmp_err_1 = ffff0000
dqs_perbyte_dly.last_dqdly_pass[0]=13,  finish count=2
byte:0, (DQS,DQ)=(9,8)
byte:1, (DQS,DQ)=(8,8)
20,data:89
[EMI] DRAMC calibration passed

===================================================================
                MT7621   stage1 code done
                CPU=50000000 HZ BUS=16666666 HZ
===================================================================


U-Boot 1.1.3 (Aug 30 2017 - 02:28:33)

Board: Ralink APSoC DRAM:  256 MB
relocate_code Pointer at: 8ffb0000

Config XHCI 40M PLL
******************************
Software System Reset Occurred
******************************
Allocate 16 byte aligned buffer: 8ffe1940
Enable NFI Clock
# MTK NAND # : Use HW ECC
NAND ID [C2 DA 90 95 06]
Device found in MTK table, ID: c2da, EXT_ID: 909506
Support this Device in MTK table! c2da
select_chip
[NAND]select ecc bit:4, sparesize :64 spare_per_sector=16
Signature matched and data read!
load_fact_bbt success 2047
load fact bbt success
[mtk_nand] probe successfully!
mtd->writesize=2048 mtd->oobsize=64,    mtd->erasesize=131072  devinfo.iowidth=8
..
UBNT e51 13-02122-13 FCECDA7B62BC
UBNT BD type=e51, mac=FCECDA7B62BC, s/n=FCECDA7B62BC, mrev=13, k_idx=1
============================================
Ralink UBoot Version: 4.3.S.0
--------------------------------------------
ASIC MT7621A DualCore (MAC to MT7530 Mode)
DRAM_CONF_FROM: Auto-Detection
DRAM_TYPE: DDR3
DRAM bus: 16 bit
Xtal Mode=3 OCP Ratio=1/3
Flash component: NAND Flash
Date:Aug 30 2017  Time:02:28:33
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:256, ways:4, linesz:32 ,total:32768

 ##### The CPU freq = 880 MHZ ####
 estimate memory size =256 Mbytes
#Reset_MT7530
Enable port 0

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.
default: 3

You choosed 1
                                                                                                                                                                                       0


1: System Load Linux to SDRAM via TFTP.
 Please Input new ones /or Ctrl-C to discard
        Input device IP (172.16.3.211) ==:
        Input server IP (172.16.3.210) ==:
        Input Linux Kernel filename (vme50) ==:vme50

 netboot_common, argc= 3

 NetTxPacket = 0x8FFE5B80

 KSEG1ADDR(NetTxPacket) = 0xAFFE5B80

 NetLoop,call eth_halt !

 NetLoop,call eth_init !
Trying Eth0 (10/100-M)

 Waitting for RX_DMA_BUSY status Start... done


 ETH_STATE_ACTIVE!!
TFTP from server 172.16.3.210; our IP address is 172.16.3.211
Filename 'vme50'.

 TIMEOUT_COUNT=10,Load address: 0x80a00000
Loading: checksum bad
checksum bad
checksum bad
checksum bad
checksum bad
checksum bad
checksum bad
checksum bad
checksum bad
Got ARP REPLY, set server/gtwy eth addr (3c:97:0e:cb:78:7b)
Got it
#################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #####################
done
Bytes transferred = 3432387 (345fc3 hex)
NetBootFileXferSize= 00345fc3
Automatic boot of image at addr 0x80A00000 ...
## Booting image at 80a00000 ...
   Image Name:   MIPS OpenWrt Linux-4.14.54
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    3432323 Bytes =  3.3 MB
   Load Address: 80001000
   Entry Point:  80001000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80001000) ...
## Giving linux memsize in MB, 256

Starting kernel ...

[    0.000000] Linux version 4.14.54 (buildbot@builds-03.infra.lede-project.org) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7102-3f3a2c9)) #0 SMP Sat Jul 14 13:48:14 2018
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is UBNT-ERX-SFP
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 10000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000]   HighMem  empty
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] random: get_random_bytes called from 0x80549740 with crng_init=0
[    0.000000] percpu: Embedded 14 pages/cpu @8120f000 s26256 r8192 d22896 u57344
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 65024
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Writing ErrCtl register=00048020
[    0.000000] Readback ErrCtl register=00048020
[    0.000000] Memory: 252068K/262144K available (4593K kernel code, 242K rwdata, 564K rodata, 1820K init, 270K bss, 10076K reserved, 0K cma-reserved, 0K highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000] NR_IRQS: 256
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4343773742 ns
[    0.000009] sched_clock: 32 bits at 440MHz, resolution 2ns, wraps every 4880645118ns
[    0.015495] Calibrating delay loop... 586.13 BogoMIPS (lpj=2930688)
[    0.087815] pid_max: default: 32768 minimum: 301
[    0.097132] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.110150] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.125783] Hierarchical SRCU implementation.
[    0.135135] smp: Bringing up secondary CPUs ...
[    0.144769] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.144778] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.144789] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.144922] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.204619] Synchronize counters for CPU 1: done.
[    0.268656] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.268664] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.268672] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.268744] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.325397] Synchronize counters for CPU 2: done.
[    0.385655] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.385663] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.385670] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.385744] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.444964] Synchronize counters for CPU 3: done.
[    0.504563] smp: Brought up 1 node, 4 CPUs
[    0.515905] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.535371] futex hash table entries: 1024 (order: 3, 32768 bytes)
[    0.547804] pinctrl core: initialized pinctrl subsystem
[    0.558688] NET: Registered protocol family 16
[    0.571838] Can't analyze schedule() prologue at 80477e04
[    0.590957] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.602244] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.613465] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.626985] clocksource: Switched to clocksource GIC
[    0.638172] NET: Registered protocol family 2
[    0.647643] TCP established hash table entries: 2048 (order: 1, 8192 bytes)
[    0.661407] TCP bind hash table entries: 2048 (order: 2, 16384 bytes)
[    0.674189] TCP: Hash tables configured (established 2048 bind 2048)
[    0.686904] UDP hash table entries: 256 (order: 1, 8192 bytes)
[    0.698410] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
[    0.711085] NET: Registered protocol family 1
[    2.326978] 4 CPUs re-calibrate udelay(lpj = 2924544)
[    2.338163] Crashlog allocated RAM at address 0x3f00000
[    2.348652] workingset: timestamp_bits=30 max_order=16 bucket_order=0
[    2.368415] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    2.379907] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    2.401408] random: fast init done
[    2.403134] io scheduler noop registered
[    2.403141] io scheduler deadline registered (default)
[    2.427124] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    2.442929] console [ttyS0] disabled
[    2.449978] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 18, base_baud = 3125000) is a 16550A
[    2.467910] console [ttyS0] enabled
[    2.467910] console [ttyS0] enabled
[    2.481697] bootconsole [early0] disabled
[    2.481697] bootconsole [early0] disabled
[    2.498352] cacheinfo: Failed to find cpu0 device node
[    2.508691] cacheinfo: Unable to detect cache hierarchy for CPU 0
[    2.521578] MediaTek Nand driver init, version v2.1 Fix AHB virt2phys error
[    2.535594] Enable NFI Clock
[    2.541359] # MTK NAND # : Use HW ECC
[    2.548663] Device not found, ID: c2da
[    2.556104] Not Support this Device!
[    2.563555] chip_mode=00000001
[    2.569630] Support this Device in MTK table! c2da
[    2.579514] [NAND]select ecc bit:4, sparesize :64 spare_per_sector=16
[    2.592378] nand: device found, Manufacturer ID: 0xc2, Chip ID: 0xda
[    2.605017] nand: Macronix NAND 256MiB 3,3V 8-bit
[    2.614376] nand: 256 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    2.629456] Scanning device for bad blocks
[    2.646597] Bad eraseblock 36 at 0x000000480000
[    2.952586] Bad eraseblock 1243 at 0x000009b60000
[    3.086366] Bad eraseblock 1749 at 0x00000daa0000
[    3.135967] Bad eraseblock 1913 at 0x00000ef20000
[    3.177735] Bad eraseblock 2045 at 0x00000ffa0000
[    3.187648] 6 fixed-partitions partitions found on MTD device MT7621-NAND
[    3.201156] Creating 6 MTD partitions on "MT7621-NAND":
[    3.211561] 0x000000000000-0x000000080000 : "u-boot"
[    3.222469] 0x000000080000-0x0000000e0000 : "u-boot-env"
[    3.234011] 0x0000000e0000-0x000000140000 : "factory"
[    3.245056] 0x000000140000-0x000000440000 : "kernel1"
[    3.256083] 0x000000440000-0x000000740000 : "kernel2"
[    3.267212] 0x000000740000-0x00000ff00000 : "ubi"
[    3.279473] [mtk_nand] probe successfully!
[    3.288344] Signature matched and data read!
[    3.296826] load_fact_bbt success 2047
[    3.304994] libphy: Fixed MDIO Bus: probed
[    3.379526] libphy: mdio: probed
[    4.795650] mtk_soc_eth 1e100000.ethernet: loaded mt7530 driver
[    4.808198] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 19
[    4.827207] NET: Registered protocol family 10
[    4.837664] Segment Routing with IPv6
[    4.845041] NET: Registered protocol family 17
[    4.853986] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    4.879780] 8021q: 802.1Q VLAN Support v1.8
[    4.890950] UBI: auto-attach mtd5
[    4.897635] ubi0: attaching mtd5
[    6.721556] mtk_soc_eth 1e100000.ethernet eth0: port 0 link up
[    7.270052] ubi0: scanning is finished
[    7.294950] ubi0: attached mtd5 (name "ubi", size 247 MiB)
[    7.305937] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    7.319629] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    7.333140] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    7.346998] ubi0: good PEBs: 1979, bad PEBs: 3, corrupted PEBs: 0
[    7.359125] ubi0: user volume: 1, internal volumes: 1, max. volumes count: 128
[    7.373502] ubi0: max/mean erase counter: 1/0, WL threshold: 4096, image sequence number: 532914371
[    7.391508] ubi0: available PEBs: 0, total reserved PEBs: 1979, PEBs reserved for bad PEB handling: 37
[    7.410063] ubi0: background thread "ubi_bgt0d" started, PID 359
[    7.410092] hctosys: unable to open rtc device (rtc0)
[    7.439109] Freeing unused kernel memory: 1820K
[    7.448184] This architecture does not have kernel memory protection.
[    7.472120] init: Console is alive
[    7.479225] init: - watchdog -
[    7.495679] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    7.512180] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    7.537290] init: - preinit -
[    7.661720] mtk_soc_eth 1e100000.ethernet: PPE started
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   10.794691] mtk_soc_eth 1e100000.ethernet: 0x100 = 0x6060000c, 0x10c = 0x80818
[   10.815808] procd: - early -
[   10.821679] procd: - watchdog -
[   11.447131] procd: - watchdog -
[   11.453679] procd: - ubus -
[   11.464083] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.517639] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.530673] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.544152] procd: - init -
Please press Enter to activate this console.
[   11.672168] kmodloader: loading kernel modules from /etc/modules.d/*
[   11.687548] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   12.022078] ip_tables: (C) 2000-2006 Netfilter Core Team
[   12.361066] nf_conntrack version 0.5.0 (4096 buckets, 16384 max)
[   12.565490] xt_time: kernel timezone is -0000
[   12.770172] PPP generic driver version 2.4.2
[   12.779843] NET: Registered protocol family 24
[   12.790767] kmodloader: done loading kernel modules from /etc/modules.d/*
[   13.879555] urandom_read: 5 callbacks suppressed
[   13.879565] random: jshn: uninitialized urandom read (4 bytes read)
[   13.947509] random: jshn: uninitialized urandom read (4 bytes read)
[   19.126446] mtk_soc_eth 1e100000.ethernet: PPE started
[   19.144917] br-lan: port 1(eth0.1) entered blocking state
[   19.155814] br-lan: port 1(eth0.1) entered disabled state
[   19.167317] device eth0.1 entered promiscuous mode
[   19.176907] device eth0 entered promiscuous mode
[   19.189845] br-lan: port 1(eth0.1) entered blocking state
[   19.200655] br-lan: port 1(eth0.1) entered forwarding state
[   19.212214] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   20.117429] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   20.534143] export_store: invalid GPIO 496
[   21.549148] export_store: invalid GPIO 497
[   22.569049] export_store: invalid GPIO 498
[   23.589123] export_store: invalid GPIO 499
[   24.203587] random: crng init done
[   24.609034] export_store: invalid GPIO 500



BusyBox v1.28.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.0-rc2, r7141-e4d0ee5af5
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------

@Bytegetter: ich hab nen ICprog OpenOCD JTAG Adapter, In-Circuit Online Shop adapter. ( ftdi-based ) kost zwar nen paar € mehr, hat aber auch openjtag via usb …

bei fragen:
0 pm support. support gehört in die allgemeinheit …