Überflüssiges "OpenWRT" Radio mit Master - Fehler in Site?

Mir ist aufgefallen, dass unsere experimentellen Emscherland-Images zwar nutzbar sind, aber nochmal ein überflüssiges Radio mit SSID „OpenWRT“ ausstrahlen.

Hier ist der betreffende Block aus unserer site.conf.

   wifi24 = {
            channel = 1,
            htmode = 'HT20',
            ap = {
            ssid = 'Freifunk',
            },
            mesh = {
            id = 'mesh.ffel',
            mcast_rate = 6000,
            },
            ibss = {
            ssid = 'mesh.ffel',
            bssid = '02:ff:13:37:ff:07',
            mcast_rate = 6000,
            },
    },

    wifi5 = {
            channel = 40,
            htmode = 'HT40+',
            ap = {
            ssid = 'Freifunk',
            },
            mesh = {
            id = 'mesh.ffel',
            mcast_rate = 6000,
            },
            ibss = {
            ssid = 'mesh.ffel',
            bssid = '02:ff:13:37:ff:07',
            mcast_rate = 6000,
            },
    },

Seht ihr hier irgendwo einen Fehler?

Der Mist ist natürlich auch in der UCI Wireless-Config zu sehen.

wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11g'
wireless.radio0.path='platform/ar934x_wmac'
wireless.radio0.htmode='HT20'
wireless.radio0.channel='1'
wireless.radio0.country='DE'
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device='radio0'
wireless.@wifi-iface[0].network='lan'
wireless.@wifi-iface[0].mode='ap'
wireless.@wifi-iface[0].ssid='OpenWrt'
wireless.@wifi-iface[0].encryption='none'
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname='client0'
wireless.client_radio0.network='client'
wireless.client_radio0.disabled='0'
wireless.client_radio0.device='radio0'
wireless.client_radio0.mode='ap'
wireless.client_radio0.macaddr='66:72:03:be:0b:26'
wireless.client_radio0.ssid='Freifunk'
wireless.ibss_radio0=wifi-iface
wireless.ibss_radio0.ifname='ibss0'
wireless.ibss_radio0.network='ibss_radio0'
wireless.ibss_radio0.device='radio0'
wireless.ibss_radio0.bssid='02:ff:13:37:ff:07'
wireless.ibss_radio0.disabled='0'
wireless.ibss_radio0.mcast_rate='6000'
wireless.ibss_radio0.mode='adhoc'
wireless.ibss_radio0.macaddr='66:73:03:be:0b:26'
wireless.ibss_radio0.ssid='mesh.ffel'
wireless.mesh_radio0=wifi-iface
wireless.mesh_radio0.ifname='mesh0'
wireless.mesh_radio0.network='mesh_radio0'
wireless.mesh_radio0.device='radio0'
wireless.mesh_radio0.mesh_fwding='0'
wireless.mesh_radio0.mesh_id='mesh.ffel'
wireless.mesh_radio0.mcast_rate='6000'
wireless.mesh_radio0.mode='mesh'
wireless.mesh_radio0.disabled='0'
wireless.mesh_radio0.macaddr='66:75:03:be:0b:26'

Ideen? Vorschläge?

Dazu gibt bereits länger einen Patch.

Bitte pulle das git nochmal komplett. Dann ein make update.

Dann ist das weg.

Bitte wenn nicht bewusst so hingeschrieben in der site.conf entweder mesh oder ibss wählen.

Ibss ist Standard. Mesh ist schon für 801.22s

Okay - probiere ich aus. Baue nochmal ein komplett neues Verzeichnis from scratch und gebe kein mesh an.

Dann ist eventuell der Bug wieder da, der eigentlich mit dem Commit hätte gefixt worden sein sollen.

Also ich habe jetzt nochmal ganz von vorne git clone https://github.com/freifunk-gluon/gluon.git gluon experimental gemacht und nach experimental/site die bestehende Site rüberkopiert. Dann den Block mesh rausgelöscht und durchgebacken. Gleiches Ergebnis, wieder das überflüssige OpenWRT.

Mache ich irgendwas falsch? Muss ich was irgendwie anders patchen?

Hab erst gestern aus dem aktuellen Master ebenfalls eine Exp. gebacken. Bei uns taucht keine OpenWrt SSID in der Config auf.

root@MA-WDR4300:~# uci show wireless | grep OpenWrt
root@MA-WDR4300:~#

Unsere aktuelle Site für die aktuelle Experimental und für die kommenden 2015.2.
https://github.com/FreifunkUE/site/blob/master/site.conf

Ah, man muss offensichtlich die Einstellungen einmal komplett überschreiben, wenn man den Fehler irgendwann hatte. Jetzt ist es wieder in Ordnung, ohne Änderungen an der Site.

wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11g'
wireless.radio0.path='platform/ar934x_wmac'
wireless.radio0.htmode='HT20'
wireless.radio0.channel='1'
wireless.radio0.country='DE'
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname='client0'
wireless.client_radio0.network='client'
wireless.client_radio0.disabled='0'
wireless.client_radio0.device='radio0'
wireless.client_radio0.mode='ap'
wireless.client_radio0.macaddr='66:72:03:be:0b:26'
wireless.client_radio0.ssid='Freifunk'
wireless.ibss_radio0=wifi-iface
wireless.ibss_radio0.ifname='ibss0'
wireless.ibss_radio0.network='ibss_radio0'
wireless.ibss_radio0.device='radio0'
wireless.ibss_radio0.bssid='02:ff:13:37:ff:07'
wireless.ibss_radio0.disabled='0'
wireless.ibss_radio0.mcast_rate='6000'
wireless.ibss_radio0.mode='adhoc'
wireless.ibss_radio0.macaddr='66:73:03:be:0b:26'
wireless.ibss_radio0.ssid='mesh.ffel'

Ja ein sysupgrade -n ist nötig!

1 Like

Oder wenn schon drauf ein „firstboot“ sollte es auch tun.

1 Like