Unifi AC Mesh/Pro


#50

@Frank Hast du das Image mal auf dem Pro Gerät ausprobiert?

Läuft die Software auf den AC Mech soweit stabil, dass man es mit dem AC Lite Image für den kommenden Sommer schon nutzen kann? Wie sieht der Gluon Support aus?

Liebste Grüße aus dem Norden!


#51

Leider noch nicht, mache mich nächste Woche dran…

Aus meiner Sicht ja, solange Du kein 5GHz Mesh machen willst. Das lief bei unserem Test am FFtag17 nicht.

Aber Obacht: Vor dem Flashen auf jeden Fall mit der orginalen FW von Ubiquiti updaten. Wir hatten ein Exemplar, bei dem die alte uboot Version nicht unsere FW starten wollte (Interessanterweise wird nämlich auch der uboot aktualisiert…).

Noch gibt es keinen, noch nicht mal LEDE: https://github.com/lede-project/source/pull/1018
Wird schon…
(PS: Hatte einen Pullrequest für den ath10k Treiber, welcher auch von dem Device benutzt wird, gesehen. Dieser soll Mesh ermöglichen :slight_smile: )


#52

Ging hier noch was voran? Vom AC Mesh Pro-Gerät fehlte noch ein flash-dump glaube ich, damit z.B. @Brother_Lal das besser mit dem UAP AC Pro vergleichen kann.
Alternativ kann ihm bzw. unserer community natürlich auch jemand lite/pro zuschicken (Gehäuse wird dabei aber beschädigt!)


#53

Schicke ich heute…

edit: Die Schnarchnase hat dann endlich den dump erstellt…


#54

Gut, das will ich hoffen. Wir wollen mit den Geräten unsere Innenstadt versorgen und uns Indoor von Gebäude bis Gebäude über 5Ghz mesh hangeln. 2,4 for Clients, 5 Ghz for mesh. 33 Geräte haben wir (auf deine Antwort hin) bestellt.

Würde es was bringen, wenn ich ein paar Geräte mit zum WCW bringe?

Ich drücke jetzt die Daumen, dass wir einen vollwertigen Support bie Sommer hinbekommen :raised_hands:


#55

:slight_smile: Wow, das nenne ich mal “Balls of steel”…

Probiert doch mal selbst, bin aktuell ziemlich eingespannt, folgende Commits sind interessant:

  1. https://git.lede-project.org/?p=lede/pepe2k/staging.git;a=commit;h=43a7a1a05e0906f8adacd9c09b5c0be79fc94de1
    Dieser bringt LEDE Support für den AC Mesh, die Pro Variante kommt noch
  2. https://git.lede-project.org/?p=source.git;a=commit;h=a1afee24a6e10054294923fa99938c5e5246ad14
    Der soll Mesh bringen.

Bitte Antwort in https://github.com/freifunk-gluon/gluon/issues/1021
Danke!


#56

Man tut was man kann :point_up:
Auf dem WCW haben ich mich den Geräten mal angenommen und konnte auch erfolgreich das Unifi-AC-Lite Image flashen. Die Anleitung von @Frank

hat meine AC-Mesh aber erstmal gebrickt. Mit folgenden Befehlen hat es auf der AC Mesh dann aber funktioniert:
mtd -r -e kernel1 write /tmp/gluon-ffnw-20170410-ubiquiti-unifi-ac-lite-sysupgrade.bin kernel1

Access Point + Ad Hoc funktioniert auf 2,4 Ghz soweit ich es messen konnte tadellos. Auf dem 5 Ghz Band bleibt bei Simultanbetrieb nur ne TQ von 4% gegen einen 3600 von Tp-Link. Schaltet man eins von beiden aus, war das 5 Ghz Interface auch problemlos nutzbar. TQ war dann 100% mit Ad Hoc. Das reicht für meinen Einsatzzweck auf jedenfall erstmal aus :smile:


#57

Also scheint das vorherige Löschen der Partition was gebracht zu haben… Interessant…
Welche Ubiquiti FW hattest Du drauf?


#58

Sind ja mittlerweile ein paar Monde vergangen…

Wie sind die Erfahrungen mit der UBNT UAP-AC-M,
funktioniert das “AC-lite” Image - was ist zu beachten?


#59

hi

mit Original Firmware und einen UAP-AP-M sehr zufrieden:

https://monitoring.freifunk-franken.de/routers/590ed2b29369c305f2b9c41d

hängt an einem Clientport eines WDR4900 (ohne Wifi) der eigenes DHCP macht und per L3 ans Freifunknetz angebunden ist. Wenn man sich die Trafficdaten ansieht, sieht man dass das Ding funktioniert.

mfg

Christian


#60

@ChrisD er frägt nach gluon und du antwortest mit einer Info zu Stock?

@biggesee hier läuft seit einigen Wochen ein UAP-AC-M mit dem AC-Lite image 2016.2.4 - er macht mesh-on-wan zu einem futro und bedient massen an clients ohne zu zucken.


#61

hab mal einen Bestellt…


#62

Ist er auch auf signierte Images beschränkt?


#63

nein, ging einfach so. ich kann die Ausführung zu signierten Images aus dem Nachbar-Thread weder für UAP AC PRO noch für UAP AC Mesh bestätigen.


#64

Nee :wink: war bei der UAP-AC-M easy (die PRO-Versione habe ich nicht getestet) brauchst zuvor keine URalt FW installieren…

  • ssh 192.168.1.20 (ubtn/ubnt)
  • “sysupgrade-image des AC LITE euerer Domäne” per scp ins /tmp des unify
  • mtd -r write /tmp/sysupgrade-image.bin kernel1

Welche FF Firmware für UniFi AC MESH?
#65

Da ich befürchte, dass hier noch Misverständnisse vorliegen oder wir aneinander vorbeireden:

Bei welchem hast Du es erfolgreich mit dem “Unifi-AC-Lite-sysupgrade”-Image benutzt? Beim UAP-AC-M oder beim UAP-AC-M-PRO? Oder bei beiden?


#66

habe nur eine “UAP-AC-M” => https://map.freifunk-moehne.de/biggesee/#!v:m;n:f09fc2de6ef8
diese wird (natürlich) “falsch” als Ubiquiti UniFi-AC-LITE angezeigt ist aber definitiv eine UAP-AC-M


#67

kleines update:
habe gestern 3 weitere unifi ac mesh lite bekommen

FW vom Windows PC mit WinSCP installieren. (UAP-AC-M)

  • mit original FW ist die unifi unter der IP 192.168.1.20 erreichbar => Anmeldung mit “ubnt” / “ubnt”
  • “sysupgrade-image des AC LITE euerer Domäne” per scp ins /tmp der unifi kopieren dort in firmware.bin umbennen
    Innerhalb von WinSCP “Putty” (SSH) öffnen/ausführen dann folgende Zeilen ausführen
  • “mtd -r write /tmp/firmware.bin kernel0”
  • “mtd -r write /tmp/firmware.bin kernel1”

#68

BTW debricking UAP-AC-M (“back2stock FW”) mit Windows Boardmitteln…
… - ggf. tftp in windows aktivieren => https://www.windows-faq.de/2016/09/26/tftp-client-bei-windows-10-aktivieren/

1.) original FW für “UAP-AC-M” besorgen und als UAP-AC-M.bin speichern
2.) Feste IP für PC einstellen (192.168.1.iergeneass außer 192.168.1.20- ist tabu, die ist für unser Unifi reserviert)
3.) Windws Console (DOS Fenster) öffen
4.) ftfp -i 192.168.1.20 PUT UAP-AC-M.bin*1 eingeben aber NOCH NICHT Enter drücken!!
5.) unifi stromlos machen
6.) RESET auf der Unifi drücken und halten
7.) Unifi wieder unter Strom setzen - Reset weiterhin halten
8.) Status-LED der Unifi beobachten! Wenn die LED BLAU-WEISS AUS BLAU-WEIS blinkt (nach ca. 20 Sec) RESET loslassen & ENTER drücken (tftp Befehl abschicken)
9.) WARTEN bis die Staus-LED konstant WEISS leuchtet (dauert!)

Unifi ist back-2-stock…

Ist etwas fummelig - hab auch nur 2 Hände :slight_smile: ist aber machbar

_Habe es so gemacht: UNIFI eingeklemmt/fixiert LAN Kabel am PoE-Adpter ca 5mm rausgezogen aber nicht ganz ausgesteckt. Mit der linken Hand RESET gedrück (und gehalten) mir rechts das LAN Kabel wieder vollständig in den PoE Adapter “gefummelt”

*1 “selbstverständlich” auf korrekte Pfadangaben achten :wink:


#69

Hallo!

Das Problem mit der hyperaktiven DFS-Detektion und das Springen auf Indoor-Kanäle ist bei Ubiquiti bekannt und es gibt eine (schon ziemlich stabile) Beta Firmware, die dieses Verhalten korrigiert.

Download:
Bei Ubiquiti Registrieren -> Am Beta Programm teilnehmen -> Forum: Unifi Beta -> Aktuellste Beta Downloaden

Viel Spaß damit! Das Teil versorgt bei uns im Alleingang einen riesigen Park und wirkt mit 30 Clients noch ziemlich gelangweilt.