WAN over WLAN (Anleitung: privates LAN über WLAN-Anbindung nutzen)


#21

Ich sabbel hier mal nen anderen Vorschlag dazwischen:

Stöpsel in deinen eigenen Router einen PowerLAN Adapter deiner Wahl. Am Aufstellungsort des Freifunk Routers der nur über Mesh angebunden ist, steckst du den zweiten PowerLAN Adapter in den blauen WAN Port und aktivierst dort das private WLAN im Konfig Modus.

Ist updatesicher und verbrät keine Airtime. Wenn PowerLAN läuft ist das in 10min fertig und schneller als alles was hier beschrieben wurde.


#22

Das ist auch bridgen. Nur das Medium ist ein anderes. :wink:


#23

@Tarnatos PowerLAN ist auch eine Idee, für den ein oder anderen mit ähnlichem Ziel.
Wäre aber fast zu einfach, benötigt ganz andere (zusätzliche) Hardware, nicht jeder mag PowerLAN (inkl. der Störstrahlung teils) und wäre bei mir außerhalb der Möglichkeiten, da nicht so ganz kabellos. (Schildere hier nur eine vereinfachte Darstellung, damit erfahrungsgemäß die Diskusion nicht ständig /dauerhaft abdriftet).

@MPW Schade das die IPv6-Subnetz-Delegierung noch nicht entsprechend umsetzbar ist. Ich werde da mal bissel mit OpenWRT spielen und mich belesen und hoffen das jemand irgendwann klar sagen kann was man dafür in OpenWRT machen muss.


#24

Das würde auch nicht in einem Subnetz enden. Wie von @Tarnatos und mir vorgeschlagen, bridgen ist die bessere Lösung.


#25

Schon klar, wenn man eh direkt im Netz ist. IPv6 irgendwie übers Subnetz nutzen können, für SSH auf andere Nodes draußen, wäre nur noch ein nettes Extra.

Sonst muss ich, bis es dafür (IPv6 über separates Subnetz) eine Lösung (werde mal damit experimentieren) gibt, den entsprechenden PC auf einen Freifunk Node so lange für IPv6 umstöpseln. Wobei das auch nur geht, wenn die Community öffentliches IPv6 hat.

Was ich mich noch frage, warum kann man bei einem Dualbandrouter mit FF-Firmware diesen über 5 GHz nicht als WLAN-Client benutzen und über 2,4 GHz dann noch Freifunk-WLAN machen? Jedes WLAN-Band hat ja einen eigenen Chip, der 5 GHz müsste doch WLAN-Client machen können während der Chip auf 2,4 GHz sein FF-Ding macht.

Finde der WDR3600 liegt mit WLAN-Client auf 5 GHz und dem einen dafür genutzten LAN-Port bissel brach. In der Ecke wo der steht wäre 2,4 GHz WLAN nett und könnte den auch zu einem anderen FF-Router auf der Seite per Kabel verbinden oder zweite VPN-Anbindung das privat-LAN-Subnetz nutzen.


#26

Klar kann man das. Muss man nur per Hand in die uci-Konfiguration frickeln.


#27

Könnte man, ist aber je nach Gerät unterschiedlich zu konfigurieren und der Anwendungsfall eher speziell, somit nicht Teil von Gluon.


#28

Das klingt gut (Gluon mit 5 GHz only als WLAN-Client nutzen, für ein privat WLAN mit Internetanbindung).

Die LAN-Ports wünsche ich mir dabei in einem privat Subnetz (192.168.1.254/24) und Internetanbindung über das privat 5 GHz WLAN (192.168.0.1/24).
Dann wüsste ich gerne genau, was man dafür über SSH machen muss.

vi /etc/config/network (unmodifizierter Auszug)

Zusammenfassung

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘2 3 4 5 0t’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘1 0t’

config interface ‘wan’
option igmp_snooping ‘1’
option ifname ‘eth0.2’
option multicast_querier ‘0’
option peerdns ‘0’
option auto ‘1’
option type ‘bridge’
option proto ‘dhcp’
option macaddr ‘ea:d1:45:52:14:b8’

für uci-Befehle (Auflistung zum Modifizieren)

uci show network

Zusammenfassung

network.loopback=interface
network.loopback.ifname=‘lo’
network.loopback.proto=‘static’
network.loopback.ipaddr=‘127.0.0.1’
network.loopback.netmask=‘255.0.0.0’
network.globals=globals
network.globals.ula_prefix=‘fd36:aaa1:8032::/48’
network.wan6=interface
network.wan6.proto=‘dhcpv6’
network.wan6.sourcefilter=‘0’
network.wan6.ifname=‘br-wan’
network.wan6.ip6table=‘1’
network.wan6.peerdns=‘0’
network.@switch[0]=switch
network.@switch[0].name=‘switch0’
network.@switch[0].reset=‘1’
network.@switch[0].enable_vlan=‘1’
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device=‘switch0’
network.@switch_vlan[0].vlan=‘1’
network.@switch_vlan[0].ports=‘0t 2 3 4 5’
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device=‘switch0’
network.@switch_vlan[1].vlan=‘2’
network.@switch_vlan[1].ports=‘0t 1’
network.wan=interface
network.wan.ifname=‘eth0.2’
network.wan.multicast_querier=‘0’
network.wan.peerdns=‘0’
network.wan.auto=‘1’
network.wan.type=‘bridge’
network.wan.proto=‘dhcp’
network.wan.macaddr=‘fe:2d:50:23:e1:30’
network.wan6_lookup=rule6
network.wan6_lookup.mark=‘0x01/0x01’
network.wan6_lookup.lookup=‘1’
network.wan6_unreachable=route6
network.wan6_unreachable.type=‘unreachable’
network.wan6_unreachable.table=‘1’
network.wan6_unreachable.target=’::/0’
network.wan6_unreachable.metric=‘65535’
network.wan6_unreachable.gateway=’::’
network.wan6_unreachable.interface=‘loopback’
network.ibss_radio0=interface
network.ibss_radio0.proto=‘none’
network.ibss_radio0_vlan=interface
network.ibss_radio0_vlan.proto=‘gluon_mesh’
network.ibss_radio0_vlan.ifname=’@ibss_radio0.61
network.ibss_radio1=interface
network.ibss_radio1.proto=‘none’
network.ibss_radio1_vlan=interface
network.ibss_radio1_vlan.proto=‘gluon_mesh’
network.ibss_radio1_vlan.ifname=’@ibss_radio1.61
network.mesh_wan=interface
network.mesh_wan.ifname=‘br-wan’
network.mesh_wan.auto=‘0’
network.mesh_wan.transitive=‘1’
network.mesh_wan.fixed_mtu=‘1’
network.mesh_wan.proto=‘gluon_mesh’
network.mesh_lan=interface
network.mesh_lan.igmp_snooping=‘0’
network.mesh_lan.ifname=‘eth0.1’
network.mesh_lan.transitive=‘1’
network.mesh_lan.fixed_mtu=‘1’
network.mesh_lan.proto=‘gluon_mesh’
network.mesh_lan.type=‘bridge’
network.mesh_lan.auto=‘0’
network.mesh_lan.macaddr=‘fe:2d:50:23:e1:34’
network.client=interface
network.client.type=‘bridge’
network.client.macaddr=‘60:e3:27:4a:83:8d’
network.client.proto=‘dhcpv6’
network.client.reqprefix=‘no’
network.client.robustness=‘3’
network.client.query_interval=‘2000’
network.client.query_response_interval=‘500’
network.client.peerdns=‘1’
network.client.sourcefilter=‘0’
network.client.ifname=‘eth0.1’ ‘bat0’
network.bat0=interface
network.bat0.multicast_router=‘2’
network.bat0.ifname=‘bat0’
network.bat0.macaddr=‘60:e3:27:4a:83:8d’
network.bat0.learning=‘0’
network.bat0.proto=‘none’
network.client_lan=interface
network.client_lan.unicast_flood=‘0’
network.client_lan.ifname=‘eth0.1’
network.mesh_vpn=interface
network.mesh_vpn.ifname=‘mesh-vpn’
network.mesh_vpn.transitive=‘1’
network.mesh_vpn.macaddr=‘fe:2d:50:23:e1:37’
network.mesh_vpn.fixed_mtu=‘1’
network.mesh_vpn.proto=‘gluon_mesh’
network.local_node_dev=device
network.local_node_dev.macaddr=‘16:41:95:40:f7:dc’
network.local_node_dev.ifname=‘br-client’
network.local_node_dev.name=‘local-node’
network.local_node_dev.type=‘macvlan’
network.local_node=interface
network.local_node.ifname=‘local-node’
network.local_node.ipaddr=‘10.61.3.3’
network.local_node.ip6addr=‘fdef:ffc0:3dd7::1/128’
network.local_node.netmask=‘255.255.255.0’
network.local_node.proto=‘static’
network.local_node_route6=route6
network.local_node_route6.target=‘fdef:ffc0:7030::/64’
network.local_node_route6.gateway=’::’
network.local_node_route6.interface=‘client’

uci show wireless

Zusammenfassung

wireless.radio0=wifi-device
wireless.radio0.type=‘mac80211’
wireless.radio0.hwmode=‘11g’
wireless.radio0.path=‘platform/ar934x_wmac’
wireless.radio0.htmode=‘HT20’
wireless.radio0.country=‘DE’
wireless.radio0.channel=‘11’
wireless.radio1=wifi-device
wireless.radio1.type=‘mac80211’
wireless.radio1.hwmode=‘11a’
wireless.radio1.path=‘pci0000:00/0000:00:00.0’
wireless.radio1.htmode=‘HT20’
wireless.radio1.channel=‘40’
wireless.radio1.country=‘DE’
wireless.ibss_radio0=wifi-iface
wireless.ibss_radio0.ifname=‘ibss0’
wireless.ibss_radio0.network=‘ibss_radio0’
wireless.ibss_radio0.device=‘radio0’
wireless.ibss_radio0.bssid=‘02:ca:ff:ee:ba:be’
wireless.ibss_radio0.mcast_rate=‘12000’
wireless.ibss_radio0.mode=‘adhoc’
wireless.ibss_radio0.macaddr=‘fe:2d:50:23:e1:32’
wireless.ibss_radio0.ssid=‘02:ca:ff:ee:ba:be’
wireless.ibss_radio0.disabled=‘0’
wireless.ibss_radio1=wifi-iface
wireless.ibss_radio1.ifname=‘ibss1’
wireless.ibss_radio1.network=‘ibss_radio1’
wireless.ibss_radio1.device=‘radio1’
wireless.ibss_radio1.bssid=‘02:44:ca:ff:ee:ee’
wireless.ibss_radio1.mcast_rate=‘12000’
wireless.ibss_radio1.mode=‘adhoc’
wireless.ibss_radio1.macaddr=‘fe:2d:50:23:e1:36’
wireless.ibss_radio1.ssid=‘02:44:ca:ff:ee:ee’
wireless.ibss_radio1.disabled=‘1’
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname=‘client0’
wireless.client_radio0.network=‘client’
wireless.client_radio0.disabled=‘0’
wireless.client_radio0.device=‘radio0’
wireless.client_radio0.mode=‘ap’
wireless.client_radio0.macaddr=‘60:e3:27:4a:83:8c’
wireless.client_radio0.ssid=‘Freifunk’
wireless.client_radio1=wifi-iface
wireless.client_radio1.ifname=‘client1’
wireless.client_radio1.network=‘client’
wireless.client_radio1.device=‘radio1’
wireless.client_radio1.mode=‘ap’
wireless.client_radio1.macaddr=‘fe:2d:50:23:e1:34’
wireless.client_radio1.ssid=‘Freifunk’
wireless.client_radio1.disabled=‘1’
wireless.wan_radio0=wifi-iface
wireless.wan_radio0.macaddr=‘fe:2d:50:23:e1:33’
wireless.wan_radio0.network=‘wan’
wireless.wan_radio0.encryption=‘psk2’
wireless.wan_radio0.device=‘radio0’
wireless.wan_radio0.mode=‘ap’
wireless.wan_radio0.key=‘2,4GHz-privat-WLAN’
wireless.wan_radio0.ssid=‘2,4GHz-privat-Schlüssel’
wireless.wan_radio0.disabled=‘1’
wireless.wan_radio1=wifi-iface
wireless.wan_radio1.macaddr=‘fe:2d:50:23:e1:37’
wireless.wan_radio1.network=‘wan’
wireless.wan_radio1.encryption=‘psk2’
wireless.wan_radio1.device=‘radio1’
wireless.wan_radio1.mode=‘ap’
wireless.wan_radio1.ssid=‘5GHz-privat-WLAN’
wireless.wan_radio1.key=‘5GHz-privat-Schlüssel’
wireless.wan_radio1.disabled=‘0’

Ich dachte dabei beispielsweise an sowas:

Zusammenfassung

vi /etc/config/network

config interface ‘uplink’
option proto ‘dhcp’

config wifi-iface ‘uplink’
option device ‘radio0’
option network ‘uplink’
option mode ‘sta’
option ssid ‘’
option encryption ‘psk2’
option bssid ‘<MAC-Adresse des Internet-Routers (steht in der Regel auf der Rückseite)>’
option key ‘’

config interface ‘uplink’
option proto ‘static’
option ipaddr ‘192.168.1.103’
option netmask ‘255.255.255.0’
option gateway ‘192.168.1.254’

oder

/etc/config/wireless: wifi mesh deaktivieren
/etc/config/wireless: clients eintragen
/etc/config/network:wifi clients unter dem interface “wan” mit eintragen
mesh on lan aktivieren

Finde leider zu wenig über WLAN-Client-Betrieb.

Ich würde, nach erfolgreicher Umsetzung, dafür auch (WLAN Client mit frischem OpenWRT und Gluon) eine ausführliche Anleitung schreiben


#29

Meines Wissen wird, um sich in einem wpa2-gesicherten Netzwerk anzumelden der wpa_supplicant benötigt.


#30

Eine ausführliche deutsche Anleitung kann man nun im Lösungspost von mir lesen, passend zu dem vorherigen Youtube-Video. Ich habe das die Nacht bis 4 Uhr durchgespielt und dabei ausführlich dokumentiert. Die Zusammenhänge mit u.a. Management und Port 80 hab ich mir nur grob zusammengereimt.

Über Anmerkungen zum Verbessern der Anleitung bzw. Beschreibung der genauen Effekte der einzelnen Punkte, würde ich mich freuen. Leider kann ich die IPv6-Adressen von Nodes damit immer noch nicht aufrufen, obwohl ich mich IPv4-mäßig zumindest im Internetrouternetzwerk direkt befinde.

Über Anmerkungen zur Dokumentation und IPv6-Lösungshinweise würde ich mich freuen. Auch in Bezug auf WLAN-Client-Nutzung, auf einem sonst ungenutzen 5-GHz-Band eines Gluon-Freifunkrouters.