WDR4300 mit defektem Switch - noch zu gebrauchen?

Hallo,
hatte letzte Woche 4 WDR4300 bestellt für 90€ inklusive Versand.
Am Dienstag hatte ich einen Alptraum - es wurden falsche Router geliefert, naja… Der trat irgendwie auch ein, keiner hat eine Original FW drauf, keiner vergibt via DHCP IP-Adressen, keiner „ging“.

Geld habe ich schon wieder, also habe ich jetzt 3 „defekte“ Router hier rumfliegen, einen konnte ich via Recovery tatsächlich retten.

Nun habe ich jedoch folgendes Problem: 2 Stück sind „gut“, nur der WAN/LAN Switch ist hinüber, alle LEDs leuchten dauerhaft und gehen nicht aus. Verbindet man einen PC mit dem Router sagt dieser „Kein Netzwerkkabel angeschlossen“.
Auf einen der zwei mit defektem Switch habe ich jetzt aus Spaß mal die FFKA-Firmware gespielt - hat geflasht und kam wieder hoch, dieser hängt jetzt jedoch wohl in der Einrichtungsseite.

Große Frage: wie bekomme ich die Einrichtungsseite „weg“?! Ich komme weder via WAN noch via LAN dran. Oder hilft es, wenn ich eine Console dran löte?

Vielen Dank im Voraus!

Grüße
Mitsch

Du kannst eine Firmware bauen die direkt im normalen Modus bootet und ab Werk einen ssh Schlüssel enthält.

2 Likes

Das würde ich dann beim 2. Gerät auf jeden Fall mal versuchen, aber das erste hat ja schon die „normale“ Firmware drauf, meinst du da wäre noch etwas via Console zu retten?

Wenn nicht schaue ich mir das morgen mal an und berichte… :wink:

Musst Du nicht löten. Stecken/Einhaken reicht.

Und ja, ich habe schon mehrere Nanostations „mit defektem Switch“ gerettet, einfach als „Wifimesh-Only“ fertig gemacht.
Ist zwar etwas Handarbeit, aber meines Erachtens den Aufwand wert, wenn die andere Option ist „kein Gerät mehr haben“, insbesondere wenn man keine Garantie/Gewährleistung hat bzw dann allenfalls Geld, aber kein neues Gerät mehr bekommt (wie hier beim WDR vermutlich)

1 Like

Hilfreiche Hinweise, wie man Firmware per X-Modem auf eine Kiste bekommt fände man eigentlich auf
https://wiki.openwrt.org/doc/howto/generic.flashing.xmodem
(zertifikat abgelaufen…Yadi Yadi Yada…)

Aber nein, im Wiki steht wenig hilfreiches… man muss ins Forum.
bis zur „uboot“ console sollte man noch kommen mit der seriellen Konsole.
(„TPL“-marathon") und dann „loadx“ plus ein Terminalprogramm auf PC-Seite, welches X-Modem-Transfers unterstützt.

@adorfer danke für das Feedback! Dann werde ich es mal wagen die Tage. Mein Nachbar wollte eh eine Node haben bei sich (der dann mit meinem Mesht) für Besuch. Der bräuchte kein LAN und ein Bekannter wollte auch einen Node auf dem Balkon installieren (hat schon einen drinnen stehen).
Geld habe ich sowieso wieder, die Router wollte der Händler nicht zurück - insofern doch etwas zu schade um Sie zu entsorgen.

Konkretes Vorgehen? Ich stelle es mir aktuell so vor:

  • Konsole dran löten
  • Starten
  • via Console drauf, Passwort setzen, SSH key werde ich wohl nicht abtippen…
  • dann noch die Startseite ausschalten mit:
    uci set gluon-setup-mode.@setup_mode[0].enabled=0 uci commit gluon-setup-mode reboot

fertig?!

Die erste Frage wird sein, was Du da auf der Konsole überhaupt zu sehen bekommst.
Denn nach derzeitigem Stand dürfte Dich da noch kein Gluon „anwinken“, sondern irgendwas, vermutlich aber nur ein Rescue-Bootloader.

@adorfer
hoffe nicht, Firmware habe ich drauf - nur wird er jetzt im Configurationsmodus hängen. (Normal bei uns, dass nach dem Flash erst mal Wifi aus ist und man eigentlich die Location, Name u.s.w. einstellt) und erst nach einem Neustart dann die Kiste mit eingeschaltetem Wifi läuft…

Wie ist denn die Gluon-Firmware draufgekommen, wenn doch der Switch „hinüber“ ist?
Oder ist der erst gestorben nachdem das erste Openwrt/Gluon aufgespielt wurde?

Via Webif über WLAN! :blush: ich weiß - schlechte Idee, aber wenn der Switch halt kaputt ist…

Der zweite läuft… :wink:
Flash-Chip (es handelt sich im Übrigen bei V1.7 des WDR4300 um einen winbond 25064FVSIG (oder 1G oder lG - die Augen lassen nach) 1334) von dem mit defektem Switch auf den anderen der nach dem Recovery immer neugestartet hat umgelötet und gut! :blush:
Kann selbst kaum glauben, dass es läuft - habe schon ewig nicht mehr SMD gelötet…

Habe es geschafft: via UART (nicht seriell) verbunden (über meinen Raspi - die Einrichtung von dem hat am längsten gedauert)

Via WLAN übers WebIF ein FFKA Image drauf, neu starten und dann hatte ich sofort die „normale“ Konsole, die ich nach einem Login via SSH habe. Einfach meinen Public-Key kopiert in (Datei gab es noch nicht):

vi /etc/dropbear/authorized_keys

Abschließend noch ein:

gluon-setup-mode.@setup_mode[0].configured='1'
uci commit
reboot

Achja, Node heißt: switch-kaputt :smile:
Bin echt sehr zufrieden… :wink: in Summe nun 2 voll funktionale WDR4300 und einen als WiFi only für umme…

8 Likes