841N Hardw. V7.2 update auf Freifunk Firmware funktioniert nicht

Hallo,

ich moechte meinen Router auch ganz gerne beim Freifunken mitmachen lassen, aber leider scheiter ich schon beim Firmwareupdate.
Ich habe einen TP-Link 841N mit der HardwareVersion 7.2, zumindest steht das auf der Unterseite des Routers. Wenn ich die WebGUI aufrufe, wird dort als Hardwareversion 6/7 angegeben.
Nungut, ich habe mir die Firmware vom Freifunk Kassel geholt, und zwar fuer die Version 7. Wenn ich die Firmware upgrade, sagt er zwar, dass er grade rebootet, aber nachdem das geschehen ist, hat der Router weiter das TP-Link Interface.
Die momentan aufgespielte Firmware von TP-Link ist die 3.13.9, und leider kann ich diese auch nicht weiter Updaten, weil es schon die neuste FW ist, die es fuer V7 gibt. Sonst haette man ja mal probieren koennen, ob er bei der original FW auch so bockt.

Zu Huelf, was mache ich falsch?

Wie ist die URL unter der Du die Firmware bezogen hast und wie heisst die Datei?

Die URL ist diese hier:
https://freifunk-kassel.de/Firmware?action=show&redirect=firmware

Die Datei heist gluon-ffks-2015.02.07.11-tp-link-tl-wr841n-nd-v7.bin
Ich habe auch mal die fuer V8 und auch V9 ausprobiert, ohne Erfolg.

das klingt ganz stark danach das die bootpartition nicht √ľberschrieben wurde, was bei einem sysupgrade != factory firmware der fall w√§re.
Du bist sicher die ‚Äěfactory‚Äú firmware genommen zu haben?

1 Like

Dem schließlich mich an.
Ich w√ľrde testweise mal ein Image einer anderen Community versuchen.
Mit einem ‚ÄěSysupgrade‚Äú kann man hinterher (‚ÄěParameter nicht behalten‚Äú) fix wechseln. Ggf mit dem Image was Du bereits hast.

Beim meinen frueheren Router-Updates? Ja, ich habe den Router erst einmal upgedated, da habe ich die Firmware von der Seite von TP-Link genommen.

@adorfer: Ich habe es jetzt mal mit der Firmware von FF Hamburg probiert, aber mit dem selben Ergebnis.

Unter Welcher IP hast du denn versucht dass Freifunk Interface zu erreichen?

Nochmal die Frage, weil das mir nicht klar geworden ist: Hast Du ein Freifunk Factory-Image genommen?

Immer, wenn Originalfirmware drauf ist (egal welche Version), muss ein Factory-Image mit Freifunk verwendet werden. Später dann sysupgrade.

Das oben von ihm verlinkte schaut zumindest sowohl von der Directory-Struktur als auch vom Filenamen her nach einer Factory-Firmware aus.

Oder anders gesagt: Ich gehe davon aus, dass der Fehler nicht beim TS liegt.
Daher mein Vorschlag, erstmal eine FW einer anderen Community zu flashen und dann ein Sysupgrade auf die KS-FW durchzuf√ľhren.
Umgekehrt gab es da auch mal irgendwas im Gluon-Builder…

oh… andere Idee: Könnte es sein, dass das eine .cn-Variante ist? Dann muss man evtl. ganz andere Firmware nahmen.

Unter 192.168.1.1, so steht es im Tutorial vom Freifunk KS.

Auf der Seite von FF Kassel gibt es diese Auswahl garnicht. Firmware - Freifunk Kassel

Woran erkenne ich das? Ich hab den Router, wenn ich mich recht entsinne, damals bei Amazon gekauft, ganz ausgeschlossen ist das also nicht.

Okay…

ich habe es jetzt mal auf einem anderen Laptop probiert, und es geht. :expressionless:

Der Laptop hat genau sie selbe Linux Mint Version, ja sogar genau die selbe Version von Firefox, aber irgendeine besch… Kleinigkeit ist wohl unterschiedlich.

Naja, vielen Dank fuer eure Muehen. Manchmal hilft das sture ausprobieren eben doch weiter.