Alle LEDs aus / kein Blinken GUI-Option

Hallo,

eine GUI Option zur Deaktivierung aller LEDs bzw zum Unterdrücken des Blinkens wäre wünschenswert. Manche Router stehen an gut einsehbaren Standorten und nerven mit einer Festtagsbeleuchtung.

Hat jemand evt für einen wdr3600 die SSH Befehle zu Hand?

Danke
apo

1 Like

Hi,
das haengt von der gluon-version ab, aber ich kann Dir hoffentlich einen Hinweis geben, wo du suchen und editieren musst.
Wir (ffka) benutzen aktuell das gluon release 2014.3 als Basis.
Dort werden die LEDs in /etc/config/system konfiguriert.
Was die Optionen bedeuten findet sich unter System configuration [Old OpenWrt Wiki] .

Probier mal bei allen Eintraegen jeweils alles bis auf „option name“ und „option sysfs“ auszukommentieren.
Anschliessend ein „/etc/init.d/led start“ aufrufen.

Hier ein Beispiel, was bei mir fuer einen TL-WR841N/ND passt:
(wo raute steht bitte das Zeichen einsetzen. Das Forum benutzt es leider fuer die Formatierung)

config led ‚led_wan‘
option name ‚WAN‘
option sysfs ‚tp-link:green:wan‘
raute option trigger ‚netdev‘
raute option dev ‚eth0‘
raute option mode ‚link tx rx‘

Evtl. musst Du Dir noch Eintraege hinzufuegen, die Du mit „ls -l /sys/class/leds/“ rausfindest.
Bei manchen hilft auch noch:
option default ‚0‘

Ich hab so, bis auf die Power-LED, alle Lampen ausbekommen.

3 Likes

Mit den nachfolgenden Zeilen konnte ich fast alle LEDs ausschalten. Nur die Leuchte mit dem Weltsymbol und dem „Saturnring“ drumherum blinkt weiter wie wild. Die Powerleuchte ist ebenfalls noch an, aber leuchtet stetig und stört daher nicht sehr.

config led ‚led_qss‘
option name ‚QSS‘
option sysfs ‚tp-link:blue:qss‘
option default ‚0‘

config led ‚led_phy0‘
option name ‚PHY0‘
option sysfs ‚ath9k-phy0‘
option default ‚0‘
option name ‚USB1‘
option sysfs ‚tp-link:green:usb1‘
option default ‚0‘

option trigger ‚usbdev‘

option dev ‚1-1.1‘

option interval ‚50‘

config led ‚led_usb2‘
option name ‚USB2‘
option sysfs ‚tp-link:green:usb2‘
option default ‚0‘

option trigger ‚usbdev‘

option dev ‚1-1.2‘

option interval ‚50‘

config led ‚led_wlan2g‘
option name ‚WLAN2G‘
option sysfs ‚tp-link:blue:wlan2g‘
option default ‚0‘

option trigger ‚phy0tpt‘

config led ‚led_system‘
option name ‚SYSTEM‘
option sysfs ‚tp-link:blue:system‘
option default ‚0‘

config led ‚led_qss‘
option name ‚QSS‘
option sysfs ‚tp-link:blue:qss‘
option default ‚0‘

config led ‚led_phy0‘
option name ‚PHY0‘
option sysfs ‚ath9k-phy0‘
option default ‚0‘

config led ‚led_phy1‘
option name ‚PHY1‘
option sysfs ‚ath9k-phy1‘
option default ‚0‘

2 Likes

Ich habe das Problem mit Leukoplast-Verband und einem Permanentmarker gelöst.
Damit sind die LEDs nur noch bei Dunkelheit (oder drübergelegter Hand zur Abschattung) zu erahnen.
Also „maximal gedimmt auf ‚gerade noch erkennbar‘“.
Vielleicht nicht überall gangbar. Aber im Störungsfall kann man so auf jeden Fall sofort wieder die LEDs einsehen indem man das Klebeband herunterreisst.