Änderungen der Netmon Crawler Konfiguration

Hi,

heute Nachmittag gab es eine Situation in der die Router faktisch online waren, in Netmon aber als Offline angezeigt wurden. Ich habe daraufhin die Konfiguration des Crawlers auf srv01.ffnw.de wie folgt geändert:

  • network_connection_ipv6_interface von br-mesh auf batfast geändert
  • interfaces_used_for_crawling um das Interface mesh-vpn ergänzt

Ist das soweit richtig? Bin ein bisschen raus was die Bedeutung der Interfaces angeht.

Wofür wird denn network_connection_ipv6_interface genutzt? Interface zum Crawling ist bei unsere Legacy-Firmware br-mesh und bei Gluon br-client.

@Floh1111 @bjo Sind momentan noch fast die Hälfte offline leider.

@Floh1111 @bjo online sind die Router, aber ca 50 % werden nur online angezeigt.

1 Like

@floh1111 Warum hast du eigentlich die VPN-Interfaces hinzugefügt? Ohne Batman erreicht Netmon ja nichts.

Das ist das Interface das auf dem Server für ping6 und curl zum crawlen genutzt wird.

Das war das einzige Interface über dessen Adresse das die Node erreichbar waren.

batfast ist dann aber schlecht, weil netmon dann nur die Router abfragt, die an srv01 hängen und nicht übers Mesh Router an vpn02 und vpn03. Folge: Es erscheinen nicht alle Router online. Aber warum hast du das denn auf batfast geändert? Letztlich wäre es ja einfacher, wenn die ULA statt LL genutzt wird.

Wenn du batfast nutzt, geht natürlich auch nur mesh-vpn und nicht br-client, da dir die Batman-Ebene fehlt.

Also ggf den eigenen Router so oft neu starten bis er zufällig an srv01 hängt?
Oder besser gleich die lokale fastd-Config ändern?

Warten, bis @Floh1111 das gefixed hat. Eine Änderung auf br-mesh führt jedenfalls dazu, dass netmon überhaupt keine Router mehr erreicht.

@bjo und wir haben uns schon gefragt warum nach mehreren Neustsrtars die Router wieder online angezeigt werden. Ist ja klar, wenn mir auf srv01 gecrawlt wird :smiley:

Das Problem dürfte jetzt behoben sein. Danke an @bjo :wink:

Für die Zukunft habe ich eine Wikiseite angelegt auf der wir auftretende Probleme sowie deren Lösung bzw. Lösungsansätze sammeln werden. Als initialstart findet sich da erstmal die Lösung zum aktuellen Problem: https://wiki.nordwest.freifunk.net/Server und Netzstruktur/Problem-FAQ

@Floh1111 super danke. Die nächsten 10 Router werden wieder online gezeigt. :slight_smile:

Seit Ende Februar wird mein Router (https://netmon.nordwest.freifunk.net/router.php?router_id=465) jeweils nur kurz online gelistet, und verschwindet dann wieder zu offline, obwohl er permanenten Netzzugang hat, und ich auch ohne Probleme darüber ins Netz komme. Kann das an den Änderungen der Konfiguration am Server liegen?

Hi Marmai,

es kann sein, dass die Statusanzeige einiger Router nicht korrekt funktioniert. Sie sollte daher nur als ungefährer Richtwert genommen werden. Solange dein Router ansonsten Problemlos funktioniert ist alles in Ordnung.
Netmon ist mittlerweile etwas in die Jahre gekommen und für eine tiefergehende Analyse dieses Problems fehlt es aktuell an Kapazität. Die Entwicklung eines Nachfolgers wird aktuell vorbereitet und ich gehe davon aus, dass dieser bis Ende 2015 Einsatzbereit sein wird. Dann wird sich dieses Problem vorraussichtlich von selbst lösen.

Viele Grüße
Floh1111

Bei der Durchsicht der Crawl-Logs ist mir aufgefallen, dass einige Crawl-Prozesse nicht zuende Crawlen (keine Gesamtzeit am Ende des Logs angegeben). Dadurch wurden einige Router einfach nicht gecrawled.

Darum habe ich jetzt nochmal folgende Änderungen vorgenommen:

  • Nicht zum crawlen genutze Interfaces wieder aus interfaces_used_for_crawling entfernt
  • Anzahl der Router eines Crawl-Prozesses von 15 auf 10 reduziert

Jetzt sollten alle Router mehr oder weniger richtig online angezeigt werden, unter anderem auch der Router von @marmai. Ein Crawl-Prozess braucht im Schnitt jetzt ca. 200 Sekunden.

Bei einigen Routern war auch mal wieder „Router sendet Daten selbstständig“ ausgewählt. Vielleicht sollten wir die Option komplett rausnehmen.

Ja.
Oder gibt es noch Szenarien, in denen das funktioniert?

@bjo für die Änderung wäre ich auch - 3 Router heute, die diese Einstellung wieder drin hatten :frowning: Oder evtl. Den Eintrag mit irgendwas STOP oder so kennzeichnen :smiley:

Oder schlicht nicht auswerten, egal was $USER einstellt?