Archer C5/C7 unter 2016.1.4

Vielleicht fehlt ein
git fetch origin; git checkout origin/v2016.1.x
vor dem
make update
?

1 Like

Danke!
Das war mein erster GLUON-Update ohne in einem neuen Ordner alles neu aufzubauen (git… hat gefehlt). Mit dem Patch für 2016.1.4 leuchet der C7 wieder wie ein Weihnachtsbaum und 5GHz funktioniert auch wieder.

2 Likes

Schön, dass es grundsätzlich jetzt läuft. Vielleicht könntest du irgendwann noch Feedback über die Stabilität geben. Wir haben hier in Aachen das Problem, dass ungefähr die Hälfte der C5/7 unter 2016.1.4 mindestens einmal am Tag spontan neu starten und suchen noch nach der Ursache.

Vor allem: Wie läuft es mit 802.11s, den 2016.1.4er-Treibern und 5GHz AC?

Den ersten Neustart konnte ich auch schon verzeichnen. Aktuell liegt die Speicherauslastung bei 89%. Die WLan-Led’s blinken nicht mehr (dauer an). Ich schätze, wenn der Speicher ausgeht gibt es einen Reboot. Werde es beobachten.
http://map.freifunk-moers.de/#!v:m;n:60e32727b318

Veto!
RAM-Statistik des genannten Router:

Das sah vor der Restart (vor ca. 3 h) sowohl in der Map, als auch der Webstatistik auf dem Router anders aus. 17:50 = 96% aktuell 51%. IP:2a03:2260:50:3f03:62e3:27ff:fe27:b318
Zum Zeitpunkt des Restart war ich nicht im Hause.

Bei mir Zeigt auch htop kurz vor dem Neustart die hohe RAM-Belegung. Die Übersicht der Prozesse gibt den Speicherverbrauch aber nicht her.

2 Likes

Im Filesystem scheint in diesem Moment auch alles OK
Werde nun nach und nach verschiedene Funktionen deaktivieren

  • Privates WLAN
  • Mesh auf 5GHz und/oder 2,4GHz
  • Direkte Internetverbindnung

    Der Übeltäter wird sich schon zeigen.

So sieht es aus, wenn die WLAN-LED’s auf Dauerleuchten schalten.


CPU-Last bei 100%
Ging nach ein paar weiteren Minuten wieder zurück auf ‚normal‘.
Seit Ihr sicher, dass der Kernel OK ist?

Nachtrag: Er Router war auslastungstechnisch eher idle (Grundrauschen).

Hier wird das Problem auch noch mal aufgegriffen:

2 Likes

Nach dem Neuflashen OHNE Übernahme der Konfiguration läuft der C7 (aktuell ohne WLAN Mesh, Internet über L2TP ohne Bandbreitenbegrenzung) ohne Probleme. Als nächtstes werde 2,4 GHz Mesh aktivieren.

Es gibt Router die funktionieren und andere nicht. Die Einfache Wiederholung des Flashens brachte bei mir Nichts.
Gehen vielleicht die Konfigurationsdateien beim Update mit Übernahme kaputt. Ich werde versuchen, sobald der Router trotz aller Funktionen laufen sollte, per Downgrade/Update das zu testen.

1 Like

Wir haben inzwischen wie erbeten unsere experimental Geräte mit der v2016.1.x-mac80211-test branch bespielt.

Leider ohne Besserung.

Was ist das?          

Eine Test Branch um wlan Problemen auf die Spur zu kommen:
https://github.com/freifunk-gluon/gluon/tree/v2016.1.x-mac80211-test?files=1

Siehe auch:
https://github.com/freifunk-gluon/gluon/issues/690#issuecomment-220411316

Das mit v2016.1.x-mac80211-test habe ich noch nicht angegangen. Meine Tests haben ergeben, dass der Router soweit funktioniert, solange ich das 5Ghz Mesh (zu dem es keinen Partner gibt) deaktiviert lasse.
Die Speicherauslastung scheint auf alle Fälle eine Funktion des Grundrauschens zu sein (inkl. Schwankung), denn ‚echte‘ Last scheint er problemlos und flott (>30MBit bei 2,4GHz und > 50MBit bei 5Ghz) wegzustecken.
Inkl. 5Ghz Mesh wird es wohl zu viel.
Kann es sein, dass für das Grundrauschen (Mesh: WLAN) viele kurze Verbindungen auf und abgebaut werden und die Speicherfreigabe (garbage collection / Speicherdefragmentierung o.ä.) zu lange hinausgezögert ist?

Das Problem im 5GHz ist bekannt, man kann nur Mesh oder Client wlan aktivieren. Das sollte sich mittelfristig ändern, insbesondere wenn wir das Mesh Netz umstellen (ad-hoc - > 802.11s)

Die Ursache für sie Abstürze ist recht dubios und betrifft in Aachen nur ganz wenige Geräte. Die Firmware bis 2016.1.2 ist überhaupt nicht betroffen.

Hier lohnt sich die weitere Diskussion aber nur auf github, da dort die Entwicklung stattfindet.

Achja, bei 2016.1.4 wurde schlicht der Treiber für den ath10k Chipsatz vergessen und deshalb lief das WLAN nicht.

Moin.
Finde ich eigentlich nicht.

Einen Erfahrungsaustausch über diese Geräte finde ich, als Betreiber 2`er C5 schon Informativ und interessant.

Vielleicht sollte man die Überschrift anpassen.

Archer C5/C7 mit GLUON ohne Version. Diese könnte man z.B in eckigen Klammern voranstellen, sowie vielleicht die Community ( [2016.1.4] [FF-Nord] )

Gruß

Wir haben inzwischen die Firmware für den ath10k im Verdacht, ich habe die bei uns problemlos funktionierende auf github hochgeladen:

Diese kann man einfach austauschen und den Router neu booten, danach war bei unseren Test schluss mit den Reboots, die RAM Auslastung bleibt über Tage stabil.

Ob auch die board Datei getauscht werden muss, darf, nicht getauscht werden darf ist unklar. Da hatten wir verschiedene Ergebnisse.

1 Like

Eine temporäre Lösung scheint es jetzt zu geben (für 2016.1.x, x > 3). Der Tread unter GitHub wurde geschlossen.
Leider sind alle meine Versuche die alternative Firmware auf den Router zu bringen gescheitert.

  • Löschen der firmware-5.bin und einfügen der firmware-2.bin (1)
  • Löschen der firmware-5.bin und einfügen der firmware-2.bin als firmware-5.bin (2)
  • Upgrade des Sourcebaumes (3)
  • Kompletten Sourcebaum neu aufbauen (4)
  • Modifikation der sysupgrade.bin ???

Einbinden eines alternative GitHub-Zweiges (fd237f6) ???

Entweder komme ich keine Änderung (1,3,4), da automatisch die firmware-5.bin nachgeladen wird, oder kommt, wie erwartet, zu einen Checksummenfehler beim Bauen (2).

Für Tipps bin sehr dankbar.