Arduino am LAN Port verliert Verbindung nach rund 24h

Hallo, seit der aktuellen Stable Version 2.1 verliert ein Arduino Client am LAN Port eines Freifunk Routers nach ungefähr 24 Stunden die Verbindung. Bei den Vorversionen war es nicht so.
Ich vermute, es ist gewollt, um Dauernutzer zu vermeiden.
Kann man es für eine bestimmte MAC Adresse oder die LAN Ports umgehen, damit diese Clients dauerhaft eine Verbindung erhalten?

Hallo @valhs,

Ich glaube nicht, dass hier so viele Frankfurter aktiv sind. Wahrscheinlich ist das über die Mailingliste einfacher: user@wifi-frankfurt.de

VlG Nitimax

Definiere doch mal „verliert verbindung“.
Ethernet-Link weg oder keine Antworten auf DHCP-Requests?
Und wie lässt sich das minimalinvasiv retten?
Recht „raus und rein“ von Lanlkabel? Oder Router rebooten?
Oder Client rebooten?

Ich tippe ja auf ein DHCP/Quertraffic-Problem.

Oder bist Du mit dem Setup schon in der Babel-Testdomain?

In der Babel-Testdomain bin ich nicht. Zumindest habe ich nichts bewusst dafür eingestellt. Nur ein sysupgrade mit der Version v2.1-stable-0220 gemacht.
Als Lösung drücke ich immer den Reset-Knopf am Arduino-Board.
Im Code verwende ich Ethernet.maintain(). Die Antwort, wenn die Verbindung abbricht, habe ich noch nicht protokolliert.
Wenn es in der neuen Freifunk Firmware keine bewusste Sperre für Dauernutzer gibt, dann suche ich mal weiter. :relaxed:

Dann vermute ich, dass Dein dhclient (oder was immer den DHCP-client macht) versäumt es, ein Renew anzufordern.
Da würde ich mal ins Log schauen.

1 Like

Hm, bei unserer neuen Firmware 2.1-stable gibt es keinen Zwangstrennungsmechanismus oder ähnliches, weder für den Up-Link noch für verbundene Clients.

Davon gehe ich auch aus.

Es gibt 3 mögliche Erklärungen

  1. DHCPclient des RPI verbaselt es irgendwie mit dem DHCP-renew, z.B. weil er keine DHCP-NAKs versteht nach Uplink-Gateway-Wechsel.
  2. Freifunk-Router hängt immer mal wieder an instabilen Supernode oder wechselt den Node und der Client bekommt seinen (Quer-)Traffic dann nicht mehr durch
  3. RPI ist schlicht instabil wegen Netzteil oder Einstrahlungen so dass das PHY sich weghängt.