ath79-Support for TP-Link TL-WR94x mit TP9343

Wenn ich den WAN-Port einstecke sagt er, dass eth1 up ist. Vorher war das eth0. Ich baue jetzt mal die UCI-Config um.

Edit: Kann ich überhaupt das Switch device mit OpenWrt umkonfigurieren?

Bei OpenWrt waren vorher schon die Switch-Ports seitenverkehrt. Also Port 4 beim Switch war Port 1 und umgekehrt. Also das MDIO-Interface scheint so zu sein wie bei OpenWrt. Wenn ich physisch in Port 4 was reinstecke, dann sagt swconfig, dass Port 1 up ist. Also nehme ich an, dass nur die Interface-Namen vertauscht sind.

Es gibt zwei Möglichkeiten:
Entweder es ist nur die uci config kaputt, dann muss man einfach eth0 und eth1 in 02_network vertauschen. (Das wäre wahrscheinlich und recht einfach zu reparieren).
Genau das gleiche musst du zum Testen in /etc/config/network machen: Überall eth0 und eth1 vertauschen (auch bei switch und VLANs).

Im schlimmeren Fall ist das Setup schon im DTS falsch. Das wird dann ekliger und recht schwierig ohne Gerät vor Ort.

Wenn du „swconfig dev switch0 show“ aufrufst, siehst du wo jeweils am internen Switch was angeschlossen ist. Da sollte bei 0 die CPU hängen und dann jeweils dort was spannendes stehen, wo du ein Kabel angeschlossen hast. Damit solltest du komplett unabhängig von der /etc/config/network sein.

Danke, danach habe ich gesucht!

Ach, die Switch-Ports sind falsch rum? Also 4=1, 3=2, 2=3 und 1=4?
Das war zumindest bei ar71xx nicht in der 02_network vermerkt.

Jo, hab die Namen in 02_network und /etc/config/network vertauscht und jetzt sieht es gut aus.

Ich denke NeoRaider hat sich da vertan mit den gespiegelten Ports. Die LED ganz links ist beschriftet mit Port 4, wird aber vom Switch als Port 1 gehandhabt.

Ich habe mal ein neues Topic erstellt, damit wir hier nicht weiter rumspammen:

Ich baue gerade ein aktualisiertes Image.

Der eth-swap hat es halt für manche Geräte besser und für andere schlechter gemacht. Da der C60 aber auch falsch rum ist (qca956x), macht es durchaus Sinn, dass es hier auch so ist.

Ich weiß nicht, wie das Netzwerk-Setup bei Gluon aussieht.

Bitte dann auf den Geräten jeweils einzeln das volle Testprogramm durchziehen:

  • Per swconfig kucken, welcher interne Port zu dem jeweiligen externen Port gehört. Dabei gleich schauen, ob die Port-LEDs stimmen.
  • Access-Point testen (disabled=0 in /etc/config/wireless entfernen, danach „reload_config“ ausführen; mit dem Handy verbinden und Speedtest; danach wieder WiFi ausschalten, damit der Test beim nächsten funktioniert)
  • WAN testen (inkl. LED)
  • RFKILL und RESET Knopf testen
  • An einem beliebigen Client-Port bei gleichzeitiger WAN-Verbindung testen, ob man IP bekommt und Speedtest per Ethernet
  • Ping-Test an jedem Client-Port

oder so ähnlich…

Für den 940v3 und den 941v6 bitte per TFTP Original-Firmware drauf machen und dann das factory per WebUI flashen. So können wir testen, ob die HWID richtig gesetzt ist. Wenn nicht, dann mit dem jeweils anderen Image probieren.

https://www.adrianschmutzler.net/upload/tiny.zip

Netzwerk-Setup sollte jetzt komplett passen (die internen Ports kann ich natürlich nicht ändern)

Das heißt eigentlich fehlt ein feature in OpenWrt, um den Ports eine alternative Portnummer zuzuweisen damit bei der Luci-Portkonfiguration die korrekten Nummern angezeigt werden?

Das heißt eigentlich fehlt ein feature in OpenWrt, um den Ports eine alternative Portnummer zuzuweisen damit bei der Luci-Portkonfiguration die korrekten Nummern angezeigt werden?

	tplink,tl-wr940n-v3|\
	tplink,tl-wr940n-v4|\
	tplink,tl-wr940n-v6|\
	tplink,tl-wr941nd-v6|\
	ubnt,airrouter)
		ucidef_set_interface_wan "eth1"
		ucidef_add_switch "switch0" \
			"0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
		;;

Das macht die Zahl hinter dem Doppelpunkt.
Nützt nur nichts für swconfig.

Also die Namen sind immer noch nicht geswappt. eth0 ist weiterhin LAN, obwohl es WAN sein sollte und eth1 ist WAN, obwohl es LAN sein sollte.

  • Per swconfig kucken, welcher interne Port zu dem jeweiligen externen Port gehört. Dabei gleich schauen, ob die Port-LEDs stimmen.

Port-LEDs stimmen alle.

Port 4 = Port 1
Port 3 = Port 2
Port 2 = Port 3
Port 1 = Port 4

  • Access-Point testen (disabled=0 in /etc/config/wireless entfernen, danach „reload_config“ ausführen; mit dem Handy verbinden und Speedtest; danach wieder WiFi ausschalten, damit der Test beim nächsten funktioniert)

Funktioniert

  • WAN testen (inkl. LED)

Funktioniert

  • RFKILL und RESET Knopf testen

Funktioniert

  • An einem beliebigen Client-Port bei gleichzeitiger WAN-Verbindung testen, ob man IP bekommt und Speedtest per Ethernet

Funktioniert

  • Ping-Test an jedem Client-Port

Funktioniert

Das Swappen der Namen an sich kann ich nicht beeinflussen, das kommt vom Treiber.
Ich kann nur dafür sorgen, dass die Konfiguration in /etc/config/network und die LEDs von Anfang an richtig sind.

Apropos: Um das richtig zu testen, musst du beim sysupgrade unbedingt mit „-n“ als Parameter flashen! Sonst übernimmt er einfach die alte Config!

Ach ich dachte der PR hier würde wirklich die Namen der Netzwerkinterfaces swappen: https://github.com/openwrt/openwrt/pull/2066

Der PR hat tatsächlich die Netzwerkinterfaces geswappt:
Die, die vorher falsch waren, waren danach richtig.
Die, die vorher richtig waren, waren danach falsch.

Nur ist das mit dem richtig/falsch da halt nicht so einfach zu definieren.

Der Testbericht klingt dann aber so, dass du jetzt alle Geräte testen darfst. :wink:

Ich habe sonst nur einen WR940N v3, aber ich bin mir 100% sicher, dass der komplett identisch mit dem WR941ND v6 ist. Der WR940N v3 hat sich auch geweigert das Factory-Image per TFTP zu akzeptieren. Er wollte nur das vom WR941ND v6 schlucken.

Jedenfalls verhält der sich genauso wie der v4. Also eth0 und eth1 geswapt usw.

Hast du eigentlich die MAC-Adressen angepasst?

Mit alter Firmware (und ich hatte überprüft, dass das mit der Stockfirmware übereinstimmte) hatte der v4:
WLAN=label MAC
LAN=label MAC - 1
WAN=label MAC + 1

mit deiner Firmware ist es:
LAN=label MAC

Edit: Das war aber das erste Image, was du mir geschickt hast. Mit dem neuen hatte ich es nicht getestet… Beim v3 ist es mit dem neuen Image:

WLAN=label MAC
LAN=label MAC - 1
WAN=label MAC + 1

und ich glaube so war das auch korrekt.

Also ist dann beim 940v3 wohl auch die HWID vom 941v6 zu verwenden? Kannst du das sicherheitshalber testen: Beim 940v3 Originalfirmware drauf und dann factory per WebUI flashen?

Ich habe mich an den mach-files orientiert:
Immer:
WLAN = label
WAN = label + 1

940v3/941v6:
LAN = label -1

940v4/940v6:
LAN = label

Kann auch nichts dafür …