Automatische Kanalwahl?

@PetaByteBoy hast Du ein undokumentiertes Feature in die neue Firmware eingebaut?
Bei mir stelle ich fest, dass seit jüngstem zwei von 4 Nodes immer Kanal 1 + 5 belegen, zwei nur 1
So weit ich mich erinnere, sagte Dustin mal, FF wäre fest auf Kanal 1.

Ist ok, alle anderen Sender in Reichweite haben sich mittlerweile weitab verzogen und sind nur noch auf 11 und/oder 7

Aber in dem Zusammenhang: wieso benutzt überhaupt keiner 13 ? (außer meine Fritzbox, wenn ich WLAN anschalte, was bei der immer aus ist, normaler weise, die geht automatisch auf 13)

Wenn eure Nodes mit HT40+ betrieben werden, dann belegen die Nodes den Kanal 1+5. Nur so können theoretisch maximal 300 MBit Brutto auf WLAN erreicht werden, Einige Communitys schalten schon freiwillig auf HT20. So sind dann zwar nur maximal 150 MBit Brutto drinne, jedoch sollen die Mesh WLAN Links dann stabiler sein.

mich irritiert a) dass das nur 2 von 4 machen und b) Dustins gegenlautende Aussage.
Tritt auch erst in jüngster Zeit auf, war früher nicht. Weshalb ich einen Zusammenhang mit der neuen Firmware vermute.

Jeder Node ermittelt anhand der Kanalbelegung und des Rauschens ob 40 MHz Kanalbandbreite verwendet werden kann. So ist es vorgeschrieben. Es gibt aber auch Möglichkeiten unter Missachtung des IEEE 802.11 Reglements das dauerhaft auf 40 MHz sprich 2 Kanälen gesendet wird. Manche Hersteller ignorieren diese Empfehlung. OpenWRT versucht sich meines Wissens daran zu halten.

Es könnte sein das diese Router „uci set wireless.radio0.noscan=1“ gesetzt haben, das beschreibt das von dir erwähnte Missachten aber auf Anweisung.

LG

PS: Ist geeignet andere Router von den Kanälen zu verdrängen ^^

Dann müsste es über die Firmware gemacht worden sein, und da alle dieselbe neue Firmware (0.7.0-20150522 / gluon-v 2015.1-5-ge68ec36) haben, ist es irgndwie komisch, dass das hier nur die 2 von 4 machen, die bei mir auf der Etage sind (ein 841 und das 1043, das am Offloader hängt). Die beiden, die zwei Etagen tiefer sind, machen nur 1, und das machte das 841 hier oben bislang auch nur. Einzig das 1043 sprang mitunter von 1 auf 1 + 5, noch zu Zeiten, wo mein Nachbar seine Fritzbox auch auf 1 hatte, der ist nun auf 7+11. Das war aber alles noch zu alten Firmware-Zeiten)
Aber beantworten kann das wohl nur @PetaByteBoy oder jemand, der in den Source schaut.

Dustin sagte damals (vor Monaten, war hier überall noch die 0.6. drin) FF sei fest auf 1

1 Like

Du liest meine Beiträge anscheinend auch nicht.

Die Nodes sind fest auf Kanal 1. Wenn sich für den Knoten die Möglichkeit aber ergibt, dann schaltet er Kanal 5 dazu um auf 40 MHz Bandbreite zu kommen. Was ist so schwer daran zu verstehen?

Du hattest nur den 2., nicht den ersten Satz, oben geschrieben und damit der Aussage einen anderen Inhalt gegeben.

Habe immer gesagt wir machen Kanal 1 auf 40 MHz, bei Kanal 1 ist es dann 1+ (also Kanal 1+5).

2 Likes