Bandbreitenlimit - ssh / uci befehle (simple-tc) geändert von gluon 2015.x auf 2016.x

Ich stelle fest, dass unter unserer aktuellen Firmware (eine SubDomain in der Domäne Möhne mit L2TP) einige SSH-Befehle nicht mehr funktionieren („uci: Entry not found“), die vorab noch wunderbar ihren Dienst tun. Offenbar wurde hier etwas geändert…

Als Beispiel seien die Befehle genannt, um das Bandbreitenlimit eines Knotens zu ändern:

uci set gluon-simple-tc.mesh_vpn='interface'
uci set gluon-simple-tc.mesh_vpn.ifname='mesh-vpn'
uci set gluon-simple-tc.mesh_vpn.enabled='1'
uci set gluon-simple-tc.mesh_vpn.limit_ingress='20000'
uci set gluon-simple-tc.mesh_vpn.limit_egress='920'
uci commit

Jemand eine Idee, wie die Kommandos angepasst werden müssen, damit sie wieder funktionieren?

Guck doch mal mit uci show nach, ob sich die Bezeichnung nicht einfach nur geringfügig verändert hat.

1 Like

Danke!
Das scheint’s schon gewesen zu sein. Das beginnende „gluon-“ ist wohl nun schlicht zu viel.

So scheints nun geklappt zu haben:

uci set simple-tc.mesh_vpn='interface'
uci set simple-tc.mesh_vpn.ifname='mesh-vpn'
uci set simple-tc.mesh_vpn.enabled='1'
uci set simple-tc.mesh_vpn.limit_ingress='25000'
uci set simple-tc.mesh_vpn.limit_egress='4000'
uci commit

In Gluon selbst ist die Änderung schon was älter.
https://github.com/freifunk-gluon/gluon/commit/26682b24b358df9299322b961f09f3d03aaff7c2

Aber dann wohl erst jetzt in der betreffenden Firmware angekommen. :wink:

1 Like