CPE210 - Originalfirmware


#1

Hi, wie kann ich von der Freifunk Software zurück zur originalen Software setzten? Wenn ich im Freifunk Panel die Original Software hochladen will gibt er eine Fehlermeldung. Bitte um Hilfe!

Gruß


#2

da steht eine Möglichkeit beschrieben:

http://forum.tp-link.com/showthread.php?81684-How-to-use-firmware-recovery-function-of-Pharos-CPE


#3

Mist, da war jemand schneller :wink:
Habe ich erfolgreich genau so durchgeführt, wie in phips Link (wenn auch mit einem Raspberry Pi als TFTP-Server)! Bei den meisten ist wohl Switch zwischen dem Server und dem CPE notwendig!
Viel Erfolg!


#4

BTW: Wenn es jemand hinbekommen sollte, das Management-Interface vom TP-Link auf ein Vlan zu setzen, dann sagt mal Bescheid.

Ach ja, zweite Frage: Kann die CPE eigentlich im WDS-Mode firewallen? Wenn man also sein heimisches Internet nur für Port53UDP/TCP und 10000/UDP freigeben möchte über den Link.


#5

Hallo.

Ich habe hier kein Windows. Weiß jemand ob ich das mit einem Mac oder min Linux auch machen kann? Danke


#6


https://www.google.com/search?q=linux+tftpd

Ich sach mal so… JA :wink:


#7

Ja, das geht. Einfach mal die von mir verlinkte Anleitung auf Linux anwenden. Ist nicht Trivial, aber TFTPd ist gut dokumentiert. Wenn was nicht klappt, hilft Wireshark.

Kleiner Tipp, ich musste die Taste länger drücken, als in der Anleitung beschrieben.


#8

Was tun? Die Stock-Firmware benützen?
Bedingt.
Die Pharos-Management-Konsole ist meines Wissens nur für Windows-(x86-32bit) verfügbar.
Also schon mit einem Windows-RT oder Windows-Phone würde man da in die Röhre schauen.

Andererseits finde ich sie nicht wirklich hilfreich, mir das keine Einsichten liefert, die mich intellektuell weiterbringen.
Kommt mir eher vor wie eine “Me-To”-Lösung (“Weil der Marktführer auch so etwas hat und wir bei Ausschreibungen da nicht verlieren möchten deswegen.”).


#9

Weil die Forensoftware das hier immer noch als ersten Treffer anzeigt: Ich habe gerade selbst ein paar CPE210er per TFTP zurück auf Originalfirmware gebracht:

  • Software von TP-Link runterladen, drauf achten, dass man die passende erwischt 1.0 ≠ 1.1 ≠ 2.0

  • Das Abbildung in recovery.bin umbenennen und nach /srv/tftp kopieren (oder wo halt der tftp-Server liegt, ein Kürzen der Datei ist bei der CPE nicht erforderlich

  • ip a a 192.168.0.100/24 dev eno1 am PC eingeben, wobei eno1 der Name des Netzwerkinterfaces ist (Die IP ist anders als bei den 841ern, dort ist sie 192.168.0.66.)

  • atftp starten: sudo systemctl restart atftp.service

  • tail -f /var/log/syslog laufen lassen

  • Resetknopf gedrückt halten, während man die CPE startet

  • Sobald im Syslog (siehe zwei Befehle weiter oben) die Meldung erscheint kann man den Resetknopf loslassen und einfach noch 2-3 Minuten warten:

    Nov 12 15:30:12 Server0 atftpd[2100]: Serving recovery.bin to 192.168.0.254:4003

Das Gerät ist anschließend unter http://192.168.0.254 erreichbar, die Standardzugangsdaten sind „admin“ „admin“.

Wenn keine Anforderung im Log kommt, dann kanne es ein Timing-Problem sein, insbesondere wenn z.B. ein USB-Ethernet-Adapter und/oder ein Desktoplinux-Networkmanager “zu lang” braucht nachdem der Ethernet-Link kommt.
In diesem Fall hilft ein zwischengeschalteter Switch (und seien es die LAN-Ports eines Plasterouters wie eines 841ers.)

Getestet mit Ubuntu 16.04. Viel Erfolg!

Grüße
Matthias

PS: Funktioniert genauso mit den Gluon-Factory-Abbildern. Diese muss man ebenfalls nicht kürzen. Das gilt aber nur für TP-Link, Ubiquity-Geräte brauchen im Allgemeinen ein verkürztes Image per TFTP, soweit mein gefährliches Halbwissen reicht.


#10

Bitte weise auf die Problematik von ggf. “lahmen” USB-Adaptern oder “lahmen Desktoplinux-Network-Manager” hin, so dass es notwendig werden kann, einen Switch zwischenzuschalten, da sonst das zeitfenster für den TFTP-Request nicht reicht nach “link up” beim boot, um PC-seitig das Interface zu biegen und auch noch dem TFTP-Server “Bescheid” zu geben über das neue Interface.


#11

Ist jetzt ein Wiki, gerne ergänzen.


#12

Hi,
ist es möglich dass Du Dein verwendetes BIN file sharen kannst, mit dem es geklappt hat?
Ich habe es gerade versucht einen CPE 210 v1.1 mit der letzten Pharos_2.0-up-ver2-1-6-P1[20170908-rel45233].bin als auch mit dieser ( TPlink CPE210 auf Original Firmware zurück nicht möglich) zu flashen, leider nimmt er zwar die Datei vom TFTP Server, aber letzten Endes bootet wieder die FF Firmware. Habe denke ich das gleiche Problem wie der OP in dem Thread.
Danke und Gruß
Heerde


#13

Bekommst du gleich per PN.

MD5 der Datei ist (für andere zum Abgleichen):

$ md5sum recovery.bin 
20eebb424db3298bc4904a5e91896dc8  recovery.bin

Zeig mal die Ausgabe des tftp-Servers.

Grüße
Matthias


#14

Danke für das File. Hat nur leider auch nicht geklappt.
MD5 stimmt. Habe es mit Windows und Kali probiert. Auf Win mit Tftp32 sehe ich den Transfer grafisch Bei Kali im Syslog sehe ich diese Zeile:

Nov 11 08:58:05 localhost atftpd[3102]: Serving recovery.bin to 192.168.0.254:4011

Nach kurzer Zeit ist wieder die FF Firmware aktiv - als wenn nichts gewesen wäre. Die Typangabe auf dem Typenschild lautet

Model: CPE210(EU) Ver:1.1

also gehe ich davon aus dass das File richtig ist?!?
Als nächstes probiere ich mal OpenWRT über die FF GUI zu flashen.
Gruß
Heerde


#15

Ne, die Firmware war für eine 1.0er.

Viele Grüße
Matthias