CPE210 will nicht via Offloader auf Hyper-V

Moin Zusammen, nachdem ich vieles hier im Forum gelesen habe und auch schon versucht habe, ist nun der Zeitpunkt mich doch mal hier an euch zu wenden.

Ich bin gerade dabei, Freifunk einer Gemeinde im Kreis Steinburg vorzustellen damit wir (die gemeinde Bürger) eventuell zumindest die Hardware von denen gefördert bekommen. Hierzu bin ich dabei bei mir am Standort den Ersten Freifunk Outdoor AP (TP-Link CPE210) auf das Dach zu bringen.

Da ich beruflich ITler bin und bei mir auf dem Dachboden ein kleiner Server läuft, dachte ich mir den Offloader zu Virtualisieren auf HyperV Basis. Das funktioniert dank der Anleitungen die hier sind auch prima!

Nun mein Problem

Folgendes Ziel habe ich welches ich nicht zum laufen bekomme:

Ich hatte nun den Beitrag von @citronalco versucht leider auch ohne Erfolg:

Falls die Frage noch offen ist, wie man an einer Gluon-VM WAN, Mesh und Clientnetz auf drei virtuelle Netzwerkschnittstellen bringt, hier meine Doku - ich hoffe sie stimmt noch:

  1. VM mit drei Netzwerkschnittstellen ausstatten.
  2. Mesh on LAN auf eth0 einschalten:
    uci set network.mesh_lan.disabled=0
    uci set network.mesh_lan.ifname=eth0
  3. WAN auf eth1 legen:
    uci set network.wan.ifname=eth1
  4. Client-Netzwerk auf eth2 legen:
    uci add_list network.client.ifname=eth2

Welchen Namen welche Netzwerkschnittstelle erhalten hat, kann man anhand der MAC-Adressen herausfinden.

Ich hab’s vor etwa 2 Jahren so eingerichtet, funktioniert seitdem updatesicher.

Wie ich es auch gestallte, der CPE210 will einfach nicht… Standallone Funktioniert er aber eben nicht via Offloader… :frowning:

Noch als ergänzung, ich hatte auch folgendes getestet/gesehen:
https://wiki.freifunk-dresden.de/index.php/Offloader_Konfiguration
Dabei möchte ich die Variante " Variante: Getrenntes Netz" erstellen und habe den CPE210 via SSH folgendes mitgegeben: „uci set network.mesh_wan.auto=1“

Bei VMware war es glaub ich notwendig den Promiscuous Mode zu aktivieren:
image

Bei Hyper-V ist es anscheinend folgende Einstellung (welche ich bereits eingeschaltet habe):
2022-10-20 14_13_53-192.168.1.30 - Remotedesktopverbindung

Ich habe bereits eine VM die im VLAN5 ist und welche via FreifunkVPN ins Internet kommt.
Daher gehe ich davon aus, dass der Offloader netzseitig funktioniert.

Die VM-Konfiguration mit UCI und den drei Interfaces funktioniert nach wie vor wie oben beschrieben.

Falls deine Community VXLAN benutzt:
Ich habe den Eindruck, das verträgt sich in OpenWRT/Gluon nur mäßig gut mit VLANs.

Schalte das mal probehalber auf dem Offloader und den Access Points aus (uci set network.mesh_wan.vxlan=0 bzw. uci set network.mesh_wan.vxlan=0)

Hab es letztens auch nicht hinbekommen, dass bei eingeschaltetem VXLAN ich den den WAN-Port für Internet und Mesh (beides in getrennten VLANs) zum Laufen bekommen hab. VXLAN aus, und es ging.

Welche Firmware nutzt du denn? Ich habe sehen das du für den offloader die Dresdner Anleitung genutzt hast. In Dresden benutzen wir kein Gluon.

Ab Gluon v2022.1 ändert sich das. Siehe: Wired mesh (Mesh-on-WAN/LAN) — Gluon 2022.1.1 documentation

Auf dem Bild steht was von gluon-ffnord-iz-2020.2.3.3-1264. Ob das natürlich die aktuell verwendete Version ist :man_shrugging:

1 Like

@citronalco hat leider nicht funktioniert.

@lodrich und @TomH es ist gluon-ffnord-iz-2020.2.3.3-1264

ich habe schon vieles versucht leider ohne Erfolg, daher habe ich mich hier an das Forum gewandt.

Dann ist es gluon. Da werden dir die Dresdner Anleitungen 0 bringen da wir kein gluon verwenden.

Ja gut, die Dresdener Anleitung war nur aufgrund der Infos von @citronalco eine abstrakte Ableitung.

Gibt es zu meinen Vorhaben denn eine Anleitung? Da ja anscheinend der Hyper-V Kram funktioniert?

OK, habe es wohl geschaft… irgendwas muss ich falsch interpretiert haben aber nun läuft es.

Zum Vorgang:
Alle Geräte nochmal zurückgesetzt und alles neu aufgebaut ( firstboot)
Den CPE210 das Mesh on WAN aktiviert nichts weiteres eingestellt (außer basics name, location und password)

Die Hyper-V VM auch zurück gesetzt und via GUI nur die basics eingestellt.
Danach via SSH die Befehle von @citronalco eingegeben:
uci set network.mesh_lan.disabled=0
uci set network.mesh_lan.ifname=eth0
uci set network.wan.ifname=eth1
uci add_list network.client.ifname=eth2

und nun Funktioniert es!

Hier ein neues Bild:

Auf jeden fall, danke @all

1 Like