Der allgemeine Kartenproblem-Thread (War ursprünglich: Unsere Karte steht mal wieder)

„Diese Daten sind von Donnerstag, 9. Juli 2015 12:26.“
Danach erfolgte keine Aktualisierung mehr.

@Lars Könntest Du mal… äh… gucken?

Läuft wieder. 20202020

2 Likes

Super. Vielen Dank. 2020202020

Moin,

ich möchte niemanden belehren oder jemandem, auf die Füsse treten, aber diese Karte ist höchst wichtig für unsere Aussendarstellung, weil sehr viele neue Freifuknodebesitzer dort ganz neugierig und stolz, permanent draugucken und sich über jeden Client freuen :smile:
Ebenso wird sie von uns immer wieder, zum Argumentieren oder zum Visualisieren benutzt um technisch nicht so affinen Menschen Freifunk zu erklären und schmackhaft zu machen.

Sowas darf ebensowenig passieren, wie die Tatsache das die Darstellung der Clients (die Köpfe unter der Clientanzahl wurden nicht umgebrochen, sondern ragten rechts in die Karfte rein) über Wochen bzw. Monate kaputt war.
Ich habe das sofort angemeckert, wurde zur Kenntnis genommen …

Frage:

  1. Kann man da nicht eine Art Watchdog installieren der bellt, wenn die Darstellung „ausfällt“?
  2. Haben wir so wenig Leute, die das „können/wollen“ oder woran liegt es, dass so ein Fehler - der meiner Meinug nach höchstens ein CSS Fehler gewesen sein kann- so lange ungefixt besteht.?

Nochmal, versteht es bitte nicht falsch, aber die Karte ist sehr sehr wichtig, auch wenn sie nichts mit der tatsächlichen Freifunk-Funktionalität zu tun hat.

Gruß Chris

Im Moment seh ich beim Aufruf nur …

TypeError: e.latlngs[0] is undefined

oder

TypeError: e is undefined

?

Gruß Chris

Die Außendarstellung von Freifunk sollte sein: Alles kann, nix muss.
Das sollte auch immer wieder so vermittelt werden. Wer nen 99,999% Uptime Dienst sucht, möge sich bitte an einen kommerziellen Anbieter wenden und mit dem ein SLA aushandeln. Die meisten Menschen die im Freifunk Dienste betreuen haben nen ganz regulären Job oder gehen noch zur Schule. Freifunk ist Hobby, und das steht nun mal bei den meisten Menschen hinter Gewerbsmäßiger Arbeit, Familie und Freunde hinten an.

Moin,

Ich mag Extreme nicht, in keiner Richtung.
Weil sie oft Ausreden dafür sind, nicht zu differenzieren bzw. nicht differenzieren zu wollen oder Ausreden zu suchen.

Ich habe durchaus begriffen, dass wir nicht kommerziell sind und auch kein Ersatz dafür sein wollen.
Das ist auch prima so.

Das hat aber nichts damit zu tun, dass man im Rahmen der eigenen und der Community- Möglichkeiten versucht, das bzw. ein Optimum rauszuholen bzw. es uns nicht unnötig schwer zu machen.

Nicht mehr und nicht weniger soll mein Posting aussagen.

Gruß Chris

Und ich mag Leute nicht die sagen das „andere“ etwas besser oder schneller machen sollen bei einem Hobby Netzwerk.

Gibt doch genügt Leute die schreien wenn was nicht geht.

Ich denke das ist das mit der Priorität. Der eine setzt die hoch an bei der eigentlichen FUnktion des Netzes, und ein andere halt das eine Map hübsch aussieht.

Zudem fahrt ihr immer noch ne ältere Version der Map. Es sind schon viele Bugfixes im aktuellen Master vorhanden und auch einige neue Funktionen.

Die Map funktioniert bei mir wieder.

Bei mir ist gerade wieder TypeError: e.latlngs[0] is undefined angesagt. :frowning:

Hallo zusammen,

der e.latIngs Fehler kam vermutlich durch ungültige alfred Daten. Leider kann ich nicht mehr genau nachvollziehen was war.

Der Fehler mit den Clients die in die Karte „laufen“ ist schon länger behoben. Unser meshviewer läuft mit der aktuellen Stable v3.

Viele Grüße,
Lars

1 Like

Moin

Mein node ist wiedermal seit Stunden offline (2 mal rebootet), obwohl er ordnungsgemäß funktioniert.
Mittlerweile hab ich da seit ner woche nen anderen Router dran … ändert aber auch nichts.

Chris

Ich beobachte bei Knoten, die mit Moehne202 verbunden sind immer wieder solche Aussetzer. Die sind dann bei vielen (allen?) Knoten mit einer Verbindung zu 202 an der selben Stelle, daher glaube ich nicht an tatsächliche Offline-Zeiten der Knoten.

Nein, keine der dargestellten Offline Zeiten der letzten Wochen, waren bei mir welche.

Mal ne Idee dazu. ALFRED überträgt ja seine Daten per IPv6 Multicast. Kann es sein das Multicast bei euch im Netz gefiltert wird und deswegen die ALFRED Daten nicht mehr richtig ankommen? Bzw. irgend ein Ratelimit greift?

Wäre eine Möglichkeit.
Den schalte ich den Switch mal auf unmanaged und beobachte das.
Allerdings habe ich da nichts entsprechendes konfiguriert.

Schaun mer mal …

Chris

BATMAN bzw. ebtables auf den Knoten oder Supernodes hatte ich damit im Verdacht, nicht deinen lokalen Switch. Denn der sieht ja normalerweise nur die die Pakete zwischen deinem Knoten und deinem Internet Router, in welchen dann der FastD Tunnel steckt.

Ja, komischerweise gehts nun !?


Mal weiter beobachten.

Moin,

also so langsam glaube ich doch an eine globale Verschwörung von Freifunk Möhne gegen mich bzw. meine Router!
Man muss mich ja nicht lieb haben, aber das es so schlimm ist … :wink:

Nu hab ich hier zwei Locos rumhängen und es geht schon wieder los.
Meine Beobachtungen sind sicherlich subjektiv, aber diese angeblichen Downtimes sind hier wirklich nur bei mir zu sehen.
1.
http://map.freifunk-moehne.de/meshviewer/#!n:687251065557

http://map.freifunk-moehne.de/meshviewer/#!n:687251065516

Bis auf ein zwei Reboots sind die Nodes immer online. auch jetzt gerade funktionieren sie.
Sie hängen direkt am Router.

Wieso immer ich !? :slight_smile:

Chris