[Düsseldorf] Neue Beta-Firmware

Hallo zusammen,

Gluon 2016.2.1 ist nun als Beta Version für Freifunk Düsseldorf verfügbar.
Wer bereits eine Beta Version verwendet und den Autoupdater aktiviert hat, wird sehr wahrscheinlich schon die neue Version installiert haben.

Falls ihr Nodes manuell updaten wollt so findet ihr die Beta Version wie gewohnt unter:
https://images.freifunk-duesseldorf.de/gluon/beta/

Gruß
Cyrus

1 Like

Das hat soweit scheinbar erfolgreich geklappt, nachdem ich heute mittag von stable auf beta umgestellt hatte.Meine isolierte Kiste hat im Moment kaum einen anderen Zweck.

Allerdings kam ich danach erst mal nicht wieder drauf ohne genaues Hinschauen, weil die Fbox eine neue Adresse vergeben hat - weil die Kiste jetzt eine neue ;Mac Adresse hat. Ist das normal ?

Zumindest nicht wirklich praktisch, Natürlich hatte ich die alte Mac auf eine feste Adresse und Namen gepinnt. Hier im Forum habe ich dazu noch keine Kommentare gefunden. Ich vermute, dass das auch evtl Image- und damit moeglicherweise community-abhängig ist.

Allerdings kam ich danach erst mal nicht wieder drauf ohne genaues Hinschauen, weil die Fbox eine neue Adresse vergeben hat - weil die Kiste jetzt eine neue ;Mac Adresse hat. Ist das normal ?

Ja das ist ein bekannter Bug der neuen Version, bei jedem neustart wird für den Wan-Port eine andere Mac-Adresse verwendet. Dies wird hoffentlich bald gefixt, mich stört es auch :smile:

Solange würde ich einfach die Public IPv6 Adresse des Routers verwenden.

Danke !

Schön wär’s ja wenn ich hier überhaupt ein IPv6 hätte. Die alte Arcor/VF Anbindung ist zwar sehr solide da kann ich nicht meckern, aber IP6 geht im Moment überhaupt nicht. Ich haenge noch am aDSL/ISDN. Wobei das schon mal gefunzt hat - wnigstens getunnelt vor 5 Jahren oder so. Aber das ist alles ein anderes Thema.
Aber insofern verhilft mir FF momentan wenigstens zu ein paar v6 Möglichkeiten für Tests.

Ich denke ich sollte das hier hinzufuegen:

opkg update schlaegt fehl:


Updated list of available packages in /var/opkg-lists/chaos_calmer_telephony.
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/management/Packages.gz.
Updated list of available packages in /var/opkg-lists/chaos_calmer_management.
Downloading http://images.freifunk-duesseldorf.de/modules/gluon-ddorf-v1.4.1-67/ar71xx/generic/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:

Ich kann/will eh von dort gerade nichts haben, will es aber halt mal vermerken.

Wollte gerade mein geliebtes lsof und strace nachinstallieren. Hoffe das passt noch.
[…lernphase…]

Gelernt:
passt noch, aber nur wenn man pro opkg nur 1 Paket plus Abhngk installiert.
Und zwar in absteigender Groesse.
Und wenn es mal schief geht, was anderes kleines loeschen. Dann das fehlgeschlagene drueber und evtl wieder runter, dann fliegen auch Truemmer wieder weg. Es sei denn man will es eh lassen.
Sonst muesste man den Verwaltungskram manuell aufraeumen und wer will das.
Dann das kleinere wieder nachinstallieren.

Erinnert mich verblueffend an ein 0/1-Rucksackproblem - nun mit Trümmerschwierigkeit…
das koennte NP-vollstaendig sein…

44K frei… (841) komme mir vor wie im Apple ][ Basic, nur war der da noch fast leer… :smile:

Hey @Dago

Ich hab die Modules vergessen zu kopieren, opkg update sollte jetzt klappen :smile:

1 Like

danke. Tut tututututututut

Ist die gluon-ddorf-v1.4.1-67 immer noch beta ?

Mir fiel bei dem neuen Knoten Noerdlicher Zubringer auf, dass sie da drauf ist, er aber stable anzeigt. Evtl hat er nachtraeglich den Level geaendert. Weiss ja nicht wo er da genau steht, aber mit so viel Beifang aus dem ganzen Hotelumfeld etc hat er sicher auch nicht gerechnet.
Faehrt aber scheinbar ganz ordentlich Achterbahn lt grafana (Saegezahn in der Uptime). Vllt kein schlechter Test an der Position…

Mir faellt bei meinem 841 uebrigens seit der gluon-ddorf-v1.4.1-67 auf, dass der log wie folgt etwa 2x/min geflutet wird:

Mon Nov 28 12:27:36 2016 daemon.info dnsmasq[1742]: using local addresses only for domain lan
Mon Nov 28 12:27:36 2016 daemon.info dnsmasq[1742]: using nameserver 2a03:2260:3004:25::10#53
Mon Nov 28 12:27:38 2016 daemon.info dnsmasq[1742]: reading /tmp/resolv.conf.auto
Mon Nov 28 12:27:38 2016 daemon.info dnsmasq[1742]: using local addresses only for domain lan
Mon Nov 28 12:27:38 2016 daemon.info dnsmasq[1742]: using nameserver 2a03:2260:3004:25::10#53
Mon Nov 28 12:28:07 2016 daemon.info dnsmasq[1742]: reading /tmp/resolv.conf.auto
Mon Nov 28 12:28:07 2016 daemon.info dnsmasq[1742]: using local addresses only for domain lan
Mon Nov 28 12:28:07 2016 daemon.info dnsmasq[1742]: using nameserver 2a03:2260:3004:25::10#53
Mon Nov 28 12:28:10 2016 daemon.info dnsmasq[1742]: reading /tmp/resolv.conf.auto
Mon Nov 28 12:28:10 2016 daemon.info dnsmasq[1742]: using local addresses only for domain lan
Mon Nov 28 12:28:10 2016 daemon.info dnsmasq[1742]: using nameserver 2a03:2260:3004:25::10#53
Mon Nov 28 12:29:11 2016 daemon.info dnsmasq[1742]: reading /tmp/resolv.conf.auto
Mon Nov 28 12:29:11 2016 daemon.info dnsmasq[1742]: using local addresses only for domain lan
Mon Nov 28 12:29:11 2016 daemon.info dnsmasq[1742]: using nameserver 2a03:2260:3004:25::10#53
Mon Nov 28 12:29:13 2016 daemon.info dnsmasq[1742]: reading /tmp/resolv.conf.auto
Mon Nov 28 12:29:13 2016 daemon.info dnsmasq[1742]: using local addresses only for domain lan
Mon Nov 28 12:29:13 2016 daemon.info dnsmasq[1742]: using nameserver 2a03:2260:3004:25::10#53
Mon Nov 28 12:29:43 2016 daemon.info dnsmasq[1742]: reading /tmp/resolv.conf.auto
Mon Nov 28 12:29:43 2016 daemon.info dnsmasq[1742]: using local addresses only for domain lan
Mon Nov 28 12:29:43 2016 daemon.info dnsmasq[1742]: using nameserver 2a03:2260:3004:25::10#53
Mon Nov 28 12:29:47 2016 daemon.info dnsmasq[1742]: reading /tmp/resolv.conf.auto
Mon Nov 28 12:29:47 2016 daemon.info dnsmasq[1742]: using local addresses only for domain lan
Mon Nov 28 12:29:47 2016 daemon.info dnsmasq[1742]: using nameserver 2a03:2260:3004:25::10#53

Das scheint immer in Intervallen von 1-3s oder 20-30s zu sein, wenn man mal den kompletten onboard log sichtet. Im Moment habe ich leider kein rsyslog.

Normal finde ich das nicht, weil Routinemeldungen nicht periodisch erscheinen sollten.

Edit: ich liefere gerne einen strace Output nach bei Bedarf.
Edit2: Natuerlich habe keine Symptome bemerkt, wenn ich den ab und zu mal selber benutze.

Hängt der Freifunk-Knoten vielleicht an einem Telekom-Anschluss?

Mir kam grad der Gedanke, ob es mit der Telekom-Großstörung zusammenhängen könnte.
Kann auch völlig daneben liegen.

Du meinst dnsmasq ? Nee, das macht er schon laenger.
Und wenn Du den weiter oben erwaehnten 841er meinst, nee der auch schon laenger. Aber der hat ja so richtig schön in ein Wespennest gestochen. Die Clients sind auch nachts noch da und liegen in Ihren Hotelbetten nehm ich mal an.

Hallo Dago, der ist in der Flüchtlingsunterkunft mitten in der Halle. Ich denke das dort die Bewohner online sind und nicht die Hotelgäste gegenüber, denn die haben 24 /7 eine besetzte Pforte. :wink:

Aber stimmt dafür das dort nur eine 16/1 Mbit DSL Leitung ist läuft der gut.

Und ja habe den mit Beta bestückt, da v11.1 aber er soll beim Autoupdate dann mal auf stabel gehen.

Hehe, das war Dir wohl einen Lacher wert, aber es ist in der Tat 5min her, dass ich im mehr durch Zufall auf Deinen Klarnamen gestossen bin und den Zusammenhang hergestellt habe. :smile:
Ich ging ja auch fast davon aus, dass sich da schon wer kümmert, aber über „Zubringer“ findet sich absolut nichts im Forum oder Slack.

Im Streetview steht da ein Buerogebaeude und ich bin da noch nicht wieder vorbeigekommen :-).
Ist fuer mich 1km weg.
Ich kann das im grafana nur schwer beurteilen, ob der jetzt gut oder schlecht laeuft, aber es irritiert, wenn die uptime diese Saegezahnkurve annimmt so mit 3h Periode. Da mutmasste ich Abstuerze.

Sieht die dnsmasq Meldungen noch jemand ausser mir ?