Ffmap am Rheinufer verschwunden?

seit einigen Stunden gibt es unter der bekannten
http://ffmap.freifunk-rheinland.net/
nur noch ein „404 Not Found / nginx“
Ist da ein Umzug im Gange oder nur so „Ausfall“?

Jetzt gibt es da die neue Map!

PS: Was hat’s mit Community Düsseldorf zu tun?

Ist mir auch schleierhaft.

URL habe ich oben in deinem Beitrag angeklickt
Hast du vielleicht Cache? -> Strg+F5

Ja, im Rheinland gibt es eine neue Karte.
Aber da finde ich die Client- und vor allem die Uptime-Statistik nicht.

(ich habe einige leider technisch instabile Nodes und da reicht mir die Angabe „Uptime seit letztem Boot“ leider nicht.)

(Trotz mehrmaligem Strg-F5)

Die Statistiken waren leider seit längerem nicht mehr granular genug. Mit der ansteigenden Datenmenge wurde das exportieren der Json Files für die Map immer langsamer. Daher wurden die Daten später nur noch alle 15 Minuten geschrieben. Deshalb hab ich die alte Map komplett abgeschaltet. Die neue Map wird früher oder später auch Statistiken bekommen.

Was den Blog angeht so verweist dieser wohl noch auf die alten Urls, die haben sich nun natürlich geändert.

Vielen Dank für die Aufklärung.

Dass die Statistiken nun weg sind ist naürlich schade.
Liesse sich das evtl. druch einen „privat aufgesetzten“ Server übergangsweise überbrücken? Oder braucht man dafür Zugriff auf den Node auf dem der Alfred-Master läuft?

Blog? Du meinst die Navigation auf http://www.freifunk-duesseldorf.de?

Ja richtig, sieht für mich so sehr nach Wordpress aus :smiley:

Ich frage mich nach wie vor, wo denn wohl mein „nadeshda-org-meshy“ bleibt.
In der alten Karte wurde er sowohl im Nodegraphen wie auch auf der Geomap angezeigt.
Und in der http://ffmap.freifunk-rheinland.net/alfred_merged.json ist er nach wie vor.
Restart vom Alfred hat nichts gebracht, ebenso kein reboot.

Was passt denn nicht auf dem Datensatz?

„ea:09:f6:4f:b2:c2“: {
„owner“: {
„contact“: "adorfer@nadeshda.org"
},
„hardware“: {
„model“: „Intel® Celeron® CPU G1610 @ 2.60GHz“
},
„location“: {
„longitude“: 6.8106383085251,
„latitude“: 51.212493452929
},
„network“: {
„mesh_interfaces“: [
„ea:09:f6:4f:b2:c2“,
„e4:00:27:ef:5d:0c“
],
„addresses“: [
„fe80:0:0:0:e809:f6ff:fe4f:b2c2“,
„2a03:2260:40:0:e809:f6ff:fe4f:b2c2“,
„fda0:747e:ab29:cafe:e809:f6ff:fe4f:b2c2“
]
},
„hostname“: „nadeshda-org-meshy“,
„software“: {
„fastd“: {
„version“: „v17“,
„enabled“: true
},
„firmware“: {
„base“: „gluon-v2014.4-66-g3056e8b“,
„release“: „2014.4-rel3_exp20150129-ad“
},
„batman-adv“: {
„version“: „2013.4.0“,
„compat“: 14
},
„autoupdater“: {
„enabled“: true,
„branch“: „experimental“
}
},
„system“: [],
„uptime“: 165484.25,
„rootfs_usage“: 0.30210056235528,
„memory“: {
„free“: 496488,
„cached“: 4968,
„total“: 513908,
„buffers“: 512
},
„clients“: {
„wifi“: 0,
„total“: 0
},
„idletime“: 158982.46,
„processes“: {
„total“: 49,
„running“: 1
},
„gateway“: „04:be:ef:ca:fe:04“,
„traffic“: {
„tx“: {
„packets“: 28844,
„bytes“: 5731847,
„dropped“: 4
},
„mgmt_tx“: {
„bytes“: 845301934,
„packets“: 3812508
},
„rx“: {
„bytes“: 526420511,
„packets“: 6305006
},
„mgmt_rx“: {
„bytes“: 3966758157,
„packets“: 24983378
},
„forward“: {
„bytes“: 19204206358,
„packets“: 23748201
}
},
„loadavg“: 0
},

Der Datensatz scheint keine NodeID zu beinhalten, dann wird dieser natürlich nicht verwendet.

Sie setze ich diese denn ggf. manuell?
uci set gluon-node-info.@node_id[0]=ea09f64fb2c2 scheint’s nicht zu sein.
Manuelles editieren von /etc/config/gluon-nodeinfo ist vermutlich angesagt.
Aber was muss dort dann hinein?
Oder wo kommt diese Info her?

system.@system[0].hostname=Knotenname

Der ist ja vorhanden.
Was im Datensatz fehlt ist die „node_id“, ich weiss nur halt nicht, wie ich die manuell gesetzt bekomme, da das automatische generieren dieser wohl irgendwie scheitert.

root@nadeshda-org-meshy:~# uci show|grep hostname
system.@system[0].hostname=nadeshda-org-meshy

Ich glaube die Gluon X86 version hat keine Node_ID weil es dort keine wirklich eindeutige Mac gibt, aber da kann ich mich natürlich auch irren.
Evtl kannst du das Lua Script selber editieren und die Node-ID hardcoded rein setzen?

Aus welchem der vielen Lua-Scripte sollte die denn herauspurzeln?

Was genau macht denn diese node_id, meine Router haben die auch nicht? Ist das was spezielles in eurer Community?

Was die tut?
Flapsig gesprochen: „Die Mac-Adresse enthalten und über dem Hostnamen stehen in der json“
z.B.

"node_id": "c46e1fc70736",
    "hostname": "ff-m253-jk",
    "hardware": {
      "model": "TP-Link TL-WR841N/ND v9"
    },

Bei der alten ff3d-map wurde das nicht gebraucht, bei der neuen jetzt wohl schon.

Die Node_ID is einfach die primäre Mac-Adresse des Routers und ist seit mindestens 2014.4 standard.

Du findest das Hauptscript + Unterscripts in /lib/gluon/announce

Dort befindet sich im Unterordner nodeinfo.d die Datei node_id mit dem folgenden Inhalt:

return require('gluon.util').node_id()

Evtl fehlt diese Datei ja bei dir komplett? Ansonsten lässt sich das return sicher anpassen das er einfach nur die Mac ohne Doppelpunkte zurück gibt? Alternativ halt hardcoded.

1 Like

Vielen Dank für Eure Hilfe.

die Datei „node_id“ ist zwar in /lib/gluon/announce/nodeinfo.d/ vorhanden gewesen.
Aber das Script hat halt nix sinnvolles geliefert.
ich habe stattdesen nun manuell
uci set system.@system[0].nodeid=ea09f64fb2c2
uci commit
gesetzt.
und dann angelegt
/lib/gluon/announce/nodeinfo.d/node_id

  return uci:get_first('system', 'system', 'nodeid')

Damit sollte es jetzt wieder laufen.

Betreibt hier noch jemand nen Custom Server und pusht zur Alfred? :wink:

Warning: invalid JSON object from 10:fe:ed:cd:5b:ca: '[' or '{' expected near ''
Warning: invalid JSON object from 10:fe:ed:cd:5b:ca: '[' or '{' expected near ''

Bitte mal nach schauen :smiley: