FFW-Firmware für TL-WA901ND V3.x


#1

Hallo, ich habe hier einen TP-Link TL-WA 901 Version 3.x und möchte diesen mir einer FFW-Firmware bestücken. Leider finde ich nur das File gluon-ffw-0.6.0-ffw-20150103-tp-link-tl-wa901n-nd-v2.bin. Ist es angedacht eine Firmware für die Version 3.x zu veröffentlichen?
Mich würe es freuen!

Gruß
Heiko


#2

Hallo Heiko,

wenn der Zeitstempel korrekt ist, ist die Version vom 03. Januar. Unterstützt wird die Version 3 erst seit Februar. Da müsste jemand aus der Community eine neue Firmware bauen.

Ich habe leider eure site.conf nicht finden können, sonst hätte ich dir konkret gezeigt, wie es geht.

Grüße
MPW


#3

Wie dringend brauchst Du die Firmware? Soll ich einfach eine generieren und Dich als Versuchskaninchen verwenden oder doch noch all die geplanten Funktionen implementieren? Ich würde gern bat15s Network Coding einschalten. Außerdem einen Skript, das die Anzahl der aufgebauten Tunnel bzw. den Tunnelaufbau gezielt steuert implementieren. So wie ich mich kenne dauert es noch eine halbe Ewigkeit. Ich starte am besten nun die Kompilierung, die in 160 Minuten abgeschlossen ist … vlt. auch etwas Länger, wenn was schief läuft.

Ich poste dann den Link.

@MPW das ist die Version3 … hust … Vorabversion … ach, ich weiß es nicht mehr – sie läuft so gut, dass wir die noch einsetzen. Nur die MTU ist falsch … Details …


#4

Danke für die schnelle Reaktion.

Gerne darfst Du mich als Versuchskaninchen einsetzen. Allerding brennt nichts. Es ist nur angedacht diesen Router zu verwenden, da aufs Dach zwei Antenne für Freifunk montiert werden sollen und sich dieser Router für meine Anforderungen anbietet.


#5

Oh je, die Firmwere ist seit eineinhalb Stunden online und ich habe sie nicht verlinkt

https://firmware.freifunk-wuppertal.net/experimental/20150628/

Ich habe sie noch nicht getestet … sie sollte aber laufen. Wenn nicht … wir haben Lötkolben :wink:

Was man da so alles einstellen kann, weiß ich nicht. Eigentlich steht da ja alles in Textform. Ich wünsche Dir viel Spaß und Erfolg beim Testen und Aufbauen von Freifunk. Bitte melde, wenn Dir etwas auffällt.


#6

Firmware soeben aufgespielt. Sie läuft!
Der Test folgt in den nächsten Tagen. Vielen Dank!


#7

Hoi,
dieselbe Experimental eben aufgespielt, läuft. Ich meld auch zurück, sobald es was zu berichten gibt, Freischalt-Request ging grade raus. Btw., die in der Firmware nach Aufsopielen angegebene keys@entenhausen.freifunk.net wirft mir einen “Relay access denied” raus. Ist die noch aktuell?

Greetz
Richie


#8

Die war dann wohl sehr experimental… Nein, du musst keine Keys mehr per Mail (oder anders) versenden.


#9

Oh jeh :slight_smile: Ich hab schon ein wenig rumgelesen, aber ich tu mich noch ein wenig schwer mit dem Verstehen, was jetzt eigentlich passiert und wie ich sehe, dass alles rund läuft. Ich krieg das Wolkenschaf in der Liste von FF Wuppertal angezeigt, es hat ein paar WLAN-Links, aber trotz entsprechender Einstellung in der Firmware keinen Uplink (oder ich seh ihn nicht). Gibts irgendwo einen Link mit dem “Nach der Konfiguration erkennt man, das alles rennt, anhand von a), b), c) und wenn nicht b), dann mach X”?
Sorry für N00bfragen, aber ich tu mich schwer mit der Übersicht und dem “Welche Infos gelten für welches Netz”…


#10

Du hast halt das Pech, dass eine neue Firmware in Wupptal schlicht überfällig ist. Und in der sinnvoll betreibbaren “stable” Dein Router nicht unterstützt wird.
Alternativ könntest Du natürlich eine Firmware selbst backen. Oder die Firmware aus einer ene Umlandgemeinde nehmen (Wupper-GL…?) und Dich quasi dort anschließen.


#11

Hmm, hmmm. Ich sehe, hängt doch nochmal mehr dran.Andere FF-Ecke, ich weiss nciht, ich sitz grade gegenüber von Utopiastadt, ich schätze, ich geh der Tage da einfach mal Leute nerven. Und ein wenig was generell über Netzwerke dazuzulernen, ist ja auch kein Fehler.
Hab jetzt intern nochmal im Configmodus eine 192.168.0… statisch vergeben und den lokalen Gateway für den uplink. Ratio eingestellt, die statische IP ist lokal pingbar, aber in der Karte taucht die Kiste nach wie vor nicht mit Uplink auf. Liegts an mir oder der FW, nun ja. Wie gesagt, ist die hier verlinkte experimental und weiter bin ich noch nicht. [WUP]Wolkenschaf / 30:b5:c2:21:6c:99 zeigt im Graph immerhin ein bisschen Durchsatz an, aber ich vermute, das ist dann alles Mesh?

Kurze Schlussfrage, die mir beim Experimentieren etwas sorgen machte: ich kann nun hier mit dem Freifunk-WLAN ins Netz. Vorhin konnte ich mich im Netz einbuchen (=meinem Accesspoint), aber hatte dann kein Internet, zwischenrein dasnn einfach ein “Verbindung zum netzwerk fehlgeschlagen”. ich will nur vermeiden, dass ich hier nen Accesspoint sichtbar habe und dann dort nichts ins Netz rein- oder rausgeht bzw. nur Leute frustriere, die drüber reingebucht werden.


#12

Aber das Kabel hast du in den blauen WAN Port vom WA901 eingesteckt und das andere ende steckt in einem LAN port (meist gelb) von deinem Internetanbieter-Router? Was für ein Router ist das? Bitte einen anschluss ohne “Gastzugang” nutzen. Wenn dein Router das hat. Zumindest für die Tests :wink:

Wenn du mit dem W-LAN “Freifunk-Wuppertal” verbunden bist, kannst du in deinem Browser 10.3.0.1 eingeben und bekommst dann die Statusseite deines Freifunk-Routers zu sehen.


#13

Der 901 hat nur einen Port, ist ein reiner Accesspoint. Ich hab hier auch reine TP-Link-Switchinfrastrukturl, seit ich dei Bude auf Gigabit gestellt hab. Sind ein paar Gigabit-Switche und am Ende eine Fritzbox an einem Unitymedia-Kabelmodem. Alles unbeschränktes Gedöns, nur eben hab ich ein Heimnetz in der 192.168.0.X-Range. Dem Freifunk-Router hab ich die 192.168.0.133 fix gegeben, die ist pingbar. Gateway die 192.168.0.1, das ist die DHCP-Fritzbox, über die gehts raus zum Kabelmodem.
Über WLAN auf Freifunk/10.3.0.1 komm ich drauf. Mesh scheint tadellos zu rennen:
Model: TP-Link TL-WA901N/ND v3
Firmware release: wup-20150628

16:15:50 up 1:13, load average: 0.48, 0.93, 0.81

6: br-client: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue
link/ether 30:b5:c2:21:6c:99 brd ff:ff:ff:ff:ff:ff
inet6 fda0:747e:ab29:e1ba:32b5:c2ff:fe21:6c99/64 scope global dynamic
valid_lft 86371sec preferred_lft 14371sec
inet6 fe80::32b5:c2ff:fe21:6c99/64 scope link
valid_lft forever preferred_lft forever

         total         used         free       shared      buffers

Mem: 28548 21916 6632 124 1648
-/+ buffers: 20268 8280
Swap: 0 0 0

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 2560 2560 0 100% /rom
/dev/mtdblock3 384 252 132 66% /overlay
Neighboursmesh0Joined IBSS 02:ca:ff:ee:e1:ba (on mesh0)
SSID: FFW-BATBONE
freq: 2412

Station ea:97:f7:68:29:ec (UTOPIAwerkSTADT) (on mesh0)
inactive time: 40 ms
rx bytes: 25008364
rx packets: 230648
tx bytes: 1411810
tx packets: 18262
tx retries: 10917
tx failed: 28
signal: -75 [-78, -78] dBm
signal avg: -74 [-78, -77] dBm
tx bitrate: 81.0 MBit/s MCS 4 40MHz
rx bitrate: 43.3 MBit/s MCS 4 short GI
expected throughput: 28.491Mbps
authorized: yes
authenticated: yes
preamble: long
WMM/WME: yes
MFP: no
TDLS peer: no
Station 12:01:ee:9c:29:0e (Utopiastadt-hinten) (on mesh0)
inactive time: 10 ms
rx bytes: 78668264
rx packets: 635738
tx bytes: 24129958
…usw.
aber…
VPN statusfastd running for 4380.706 seconds
There are 8 peers configured, of which 0 are connected:
mesh_vpn_backbone_peer_gw03: not connected
mesh_vpn_backbone_peer_gw05: not connected
mesh_vpn_backbone_peer_gw06: not connected
mesh_vpn_backbone_peer_gw07: not connected
mesh_vpn_backbone_peer_gw10: not connected
mesh_vpn_backbone_peer_gw09: not connected
mesh_vpn_backbone_peer_gw08: not connected
mesh_vpn_backbone_peer_gw04: not connected

Wie gesagt: er funkt und klinkt sich ein und man kann über ihn ins Netz. Nur kann ich nicht selber von meinem Netzzugang bandbreite stellen/Uplink spielen. Woran liegts?


#14

Da fehlen die Einträge für w0, w1 und w2. Wobei die Bezeichnung gwXX mir auch komisch vorkommt.

Ich habe die Wuppertaler experimental FW jetzt mal schnell auf einem nagelneuen 841v9 installiert. Es werden keine MeshVPN Tunnel aufgebaut. Ein Blick in /etc/config/fastd zeigt, dass dort auch nix eingetragen ist.

config fastd 'sample_config'
    option enabled '0'
    option syslog_level 'info'
    list method 'salsa2012+umac'
    option mode 'tap'
    option interface 'tap0'
    option mtu '1426'
    option forward '0'
    option secure_handshakes '1'

config peer 'sample_peer'
    option enabled '0'
    option net 'sample_config'
    option key '0000000000000000000000000000000000000000000000000000000000000000'

config peer_group 'sample_group'
    option enabled '0'
    option net 'sample_config'

config fastd 'mesh_vpn'
    list method 'salsa2012+umac'
    option mtu '1426'
    option group 'gluon-fastd'
    option status_socket '/var/run/fastd.mesh_vpn.socket'
    option packet_mark '1'
    option syslog_level 'verbose'
    option mode 'tap'
    option secure_handshakes '1'
    option interface 'mesh-vpn'
    option enabled '1'
    option secret 'c80e8f45da43a59b41f4117f7df791cee3ee2fff92cdb9fb6e7050cc858c9c58'

oder ist das jetzt in einer anderen Datei versteckt? Aber da müsste @phip mehr zu sagen können. In der site.conf unter firmware.freifunk-wuppertal.net/experinental steht es jedenfalls richtig drinn.


#15

Tut mir Leid, dass Ihr Euch mit so einer Lappalie herum nerven müsst. Ich liefere binnen 24 h eine Lösung.


#16

Oh :slight_smile: Grossen Dank! Find ich die FW dann an gewohnter Stelle? Oder holts der Router dann aus dem Stable-Updatepfad?


#17

Wie immer zu spät und wie immer ungetestet. @DSchmidtberg schau mal drüber

https://firmware.freifunk-wuppertal.net/experimental/20150926/

ansonsten schaue ich es mir heute Nachmittag an.


#18

Hmm, hmm. Ich hoffe, dass ist einigermassen qualifiziert und hilft weiter. Ohne Gewähr, dass das Problem an mir liegt:
Generell:

  • Ich komm in den Konfigurationsmodus und kann nach Belieben die Firmweares aufspielen.
  • Der Router rebootet, meldet sich aber nirgends an und kommt (wahrscheinlich) mit dem WLAN nicht hoch.
    Setup 1: Sysupgrade eingespielt, Einstellungen beibehalten
    -> Router rebootet, wird aber weder in der Knotenliste noch im WLAN gefunden. die lokal vergebene 192.168.0.133 ist im lokalen Netz nicht sichtbar/pingbar.
    Setup 2: factory eingespielt. Einstellungen waren noch vorhanden.
    -> Siehe oben
    Setup 3: Wieder in den Konfugurationsmodus. Interne IP geprüft, MESH für WAN aktiviert. Reboot, anschließend Kabel vom statisch ins 192.168.1.1-Netz gesetzten Konfigurationsrechner umgesteckt ins lokale Netzwerk (wo er die 192.168.0.133 und einen Gateway hat).
    -> siehe oben, aber: die FritzBox (lokaler Gateway) findet ihn nicht, aber ich kann ihn via 193.168.0.133 pingen. Ich könnte versuchen, ssh einzurichten (hab ich bisher nicht gemacht).

Ich würd gern den Status von 10.3.0.1 rübergeben, aber wie gesagt, er macht keinerlei WLAN-Connectivity/SSIDs auf.


#19

Danke für die (qualifizierte) Rückmeldung, danke für deine Zeit, entschuldige die unreife Firmware. Nach unseren Qualitätsstandards dürfte die Draußen gar nicht auftauchen. Ich konnte sie nicht „mal eben“ testen und Dustin war wohl „zu Tisch“, um sie freizugeben. Die Firmware ist schrecklich … die neue ist an selber Stelle, erkennbar an Uhrzeit kurz nach Mitternacht. Beim Fläschen von dem Fiasko auf die richtige FW auf jeden Fall die Konfiguration nicht behalten. Beim Fläschen über die Weboberfläche erscheint nicht die Warnseite, das die Energiezufuhr zum Router nicht unterbrochen werden darf. Es erscheint „Seite nicht gefunden“ vom Browser. Auf keinen Fall irgend etwas machen. Der Router schreibt ins ROM und startet danach neu. Einfach warten.

Sorry for the inconvenience. WLAN wurde vermurkst und eigentlich ist alles schief gelaufen, was schief laufen konnte …

https://firmware.freifunk-wuppertal.net/experimental/20150926/

… sollte laufen … getestet auf einem Zehndreiundvierziger.


#20

Hoi,
jupp, sieht gut aus und rennt soweit, das Wolkenschaf ist auch schon im Mesh wieder.
Einziges Probnlem nun nach wie vor: bandbreite zur verfügung stellen scheint nicht zu gehen. Ich hab werst mit statischer 192.168.0.133-IP wieder gearbeitzet, die war nicht pingbar. Auf DHCP gewechselt, dasselbe problem (ab davon, dass ich nicht weiss, was für eine IP das Ding nun im Hausnetz haben soll).
Die 10.3.0.1 wirft die bekannten WLAN-Connects aus, und am Ende nun
fastd running for 113.202 seconds
There are 10 peers configured, of which 0 are connected:
mesh_vpn_backbone_peer_wupper7: not connected
mesh_vpn_backbone_peer_wupper9: not connected
mesh_vpn_backbone_peer_wupper4: not connected
…usw.
Mal wieder das übliche “liegts an mir?”