Firmware: erster eigener Build-Versuch

ist hier in Velbert auch so… zumal ich dann auch gern die noch in Rheinufer befindlichen irgendwie gern automatisch ins Neanderfunk ziehen würde.

Ich hab jetzt einen ersten Testrouter aufgesetzt und muss sagen die Performance ist echt gut :smile: . Super Arbeit vom Adminteam!

Ein paar Tage dürfte es noch dauern. Umzug kommt aber erst, wenn das Netz mit ein paar Nodes mehr getestet wurde.

Gib doch noch mal die aktuell zu testende Version an. Ich würde gerne mit einer stable Version testen, die auch Autoupdate-fähig ist. Dann kann ich mindestens 10 Router für einen beta-Test ausrüsten.

Build läuft: https://buildbot.ffnef.de/builders/multiBranch/builds/64
Sobald es fertig ist, kann ich signieren und dann müsste autoupdate möglich sein.

2 Likes

Die Images landen jetzt unter https://download.ffnef.de/firmware/beta/
Hinweis: Sind mit branch=stable kompiliert, zum autoupdate testen bitte an entsprechender Stelle im Wizard den beta-Zweig auswählen.

Die neue Version auf WR1043V1 funktioniert nicht wirklich. Kein DHCP, kein Wifimesh (nur MAC). Firmware: gluon-ffnef-met-201602141148-stable-tp-link-tl-wr1043n-nd-v1-sysupgrade.bin

Status der Netzwerkverbindung:

DHCP-aktiviert: Ja
Automatisch konfigurierte IPv4-Adresse: 169.254.132.100
IPv4-Subnetzmaske: 255.255.0.0
IPv4-Standardgateway:
IPv4-DNS-Server:
IPv4-WINS-Server:
NetBIOS über TCPIP aktiviert: Ja
IPv6-Adresse: 2a03:2260:300e:70:f5ad:9792:2297:8464
Temporäre IPv6-Adresse: 2a03:2260:300e:70:6433:c800:fa17:7789
Verbindungslokale IPv6-Adresse: fe80::f5ad:9792:2297:8464%11
IPv6-Standardgateway:
IPv6-DNS-Server: fec0:0:0:ffff::1%1, fec0:0:0:ffff::2%1, fec0:0:0:ffff::3%1

/etc/config/wireless:

config wifi-device ‚radio0‘
option type ‚mac80211‘
option hwmode ‚11g‘
option path ‚platform/ath9k‘
option htmode ‚HT20‘
option channel ‚13‘
option txpower ‚20‘
option country ‚DE‘

config wifi-iface ‚client_radio0‘
option ifname ‚client0‘
option network ‚client‘
option disabled ‚0‘
option device ‚radio0‘
option mode ‚ap‘
option macaddr ‚66:72:03:cd:8c:24‘
option ssid ‚Freifunk‘

config wifi-iface ‚mesh_radio0‘
option ifname ‚mesh0‘
option network ‚mesh_radio0‘
option device ‚radio0‘
option mesh_fwding ‚0‘
option mesh_id ‚ffnef-erk-mesh‘
option mcast_rate ‚6000‘
option mode ‚mesh‘
option disabled ‚0‘
option macaddr ‚66:75:03:cd:8c:24‘

config wifi-iface ‚fallback‘
option macaddr ‚66:73:0c:cd:8c:24‘
option ifname ‚fallback‘
option network ‚fallback‘
option encryption ‚none‘
option device ‚radio0‘
option mode ‚sta‘
option disabled ‚1‘
option ssid ‚Freifunk‘

Ich hoffe, das hilft bei der Fehleranalyse.

Hallo Lutz, danke für’s Testen.

Ich habe jetzt mal auf einen 841v9 das neue Image, ebenfalls die Variante für Erkrath (die dürftest Du laut deiner Ausgabe ebenfalls haben), aufgespielt. Ich schreibe über diese Verbindung gerade diesen Post und kann keine Probleme feststellen.

Kannst Du Dich per ssh root@2a03:2260:300e:70::ffff auf dem Router einloggen? Falls ja, schicke mir bitte mal die Ausgabe von logread.

Viele Grüße,
Benedikt

gibt es eigentlich Probleme, wenn ein „alter“ und ein „neuer“ in Reichweite stehen und evtl. untereinander meshen ?

die IDs sind utnerschiedlich. Keine Probleme zu erwarten.
Nur bei MeshOnLan/MeshOnWan solltest Du sie nicht auf’s gleiche Lan-Segment stecken, da dort keine Unterscheidung stattfindet (kein Vlan-Tagging o.ä.)

Hi Benedikt,
ich habe dir eine Mail geschickt.
Viele Grüße,
Lutz

So, die Firmware nähert sich stable. opkg update funktioniert nicht, es lassen sich also nicht automatisch Pakete nachinstallieren. Das ist aber nicht releasekritisch. Ansonsten sieht alles gut aus. rsync ins Beta-Verzeichnis läuft gerade. Wird wohl auch noch ein paar Stunden dauern.

2 Likes

super! (und jetzt brauch ich noch ein paar Zeichen extra…)

Hallo zusammen,

ich habe heute einen D-Link DIR-505 mit der Firmware aus https://download.ffnef.de/firmware/stable/ffnef-met/factory/ bespielt. Funktioniert auch soweit alles, nur bekomme ich mit meinen Clients keine IPv4-Adresse. IPv6 bekomme ich zugewiesen, einen DHCP Offer für IPv4 sehe ich auch, aber meine beiden Testgeräte bekommen da nichts ausgehandelt.

Irgendwelche Ideen dazu?

Grüße
Jan