Forum umgezogen

Die Geschwindigkeit sollte höher geworden sein, da der neue Server wesentlich mehr Leistung bietet und besser angebunden ist. Mit einer Ausnahme: das IPv4-Routing geht derzeit noch über Berlin, wo anscheinend ein Link am Limit läuft. Meine Messung hat ergeben, dass dort höchstens 10 Mbit/s zu holen sind.

Bei IPv6 haben wir keine solchen Limits. Das Routing läuft da über Frankfurt und liefert mehrere Hundert Mbit/s.

Ich spreche heute über mögliche Änderungen am Routing mit dem Team des FFRL. Das muss besser gehen.

1 Like

In den ersten Tagen nach dem Umzug stimmten die Reverse DNS-Records des Forums nicht, so dass manche Server die Mails abgelehnt oder als Spam klassifiziert haben. Das ist erst seit Donnerstag behoben.

Hast du auch neuere Mails als Spam markiert bekommen?
Kannst du sehen, mit welcher Begründung dies geschehen ist?

Wir haben sowohl in unserem Freifunk Netz als auch an meinem Kabeldeutschland Anschluss echtes Dual Stack IPv6. Es ist von meiner Sicht aus gesehen egal ob ich mit v4 oder v6 das Forum benutze. Beides gleich langsam.

Bei mir ist es per ipv4 immer noch sehr flott.

ja, ist bei mir genauso

Bei mir ist Forum deutlich schnller geworden, auch IPv4.

Hmm. Mein Versuch, per Mail zu antworten, scheitert leider seit mindestens gestern:

root@death:~# tcptraceroute mail.forum.ffrl.de 25
traceroute to mail.forum.ffrl.de (151.80.64.178), 30 hops max, 60 byte packets
 1  albert.uu.org (192.251.226.33)  0.226 ms  0.246 ms  0.275 ms
 2  susan2nslug.uu.org (193.26.120.228)  36.368 ms  36.870 ms  38.746 ms
 3  xmws-gtso-de12.nw.mediaways.net (192.251.226.203)  38.955 ms  39.068 ms  39.221 ms
 4  xmws-gtso-de32-chan-2.nw.mediaways.net (195.71.9.5)  41.475 ms  41.627 ms  41.727 ms
 5  ae0-0.01.xmwc.99.ams.nl.net.telefonica.de (62.53.24.174)  58.533 ms  60.306 ms  58.617 ms
 6  * * *
 7  rbx-g1-a9.fr.eu (94.23.122.76)  57.611 ms  57.722 ms  59.738 ms
 8  rbx-97-n7.fr.eu (178.33.100.115)  59.821 ms  58.542 ms  58.861 ms
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *

v6 hab’ ich nicht; naja, hab’ zwar 'nen HE-Subnetz grade hergetunnelt, nur um festzustellen daß Port 25 bei HE geblockt ist … Aber, FTR, Port 80 zum Host sieht auch ungut aus:

root@death:~# tcptraceroute 2001:41d0:c:95c::178 80
traceroute to 2001:41d0:c:95c::178 (2001:41d0:c:95c::178), 30 hops max, 80 byte packets
 1  2001:470:1f0b:20e::1 (2001:470:1f0b:20e::1)  0.373 ms  0.449 ms  0.125 ms
 2  uusix-3.tunnel.tserv6.fra1.ipv6.he.net (2001:470:1f0a:213::1)  54.556 ms  54.349 ms  56.536 ms
 3  v399.core1.fra1.he.net (2001:470:0:69::1)  61.489 ms  61.334 ms  61.116 ms
 4  * * *
 5  2001:41d0::245 (2001:41d0::245)  67.390 ms  67.877 ms  68.400 ms
 6  vss-4-6k.fr.eu (2001:41d0::524)  131.486 ms rbx-2-6k.fr.eu (2001:41d0::6b2) 122.277 ms rbx-s3-6k.fr.eu (2001:41d0::1ce)  68.047 ms
 7  2001:41d0::2034 (2001:41d0::2034)  142.218 ms 2001:41d0::2035 (2001:41d0::2035)  82.570 ms  80.938 ms
 8  * * *
 9  * * *
10  * * *

Routingprobleme zu OVH bekannt? Bzw. Portblocking? Auch von EDIS.AT oder Hetzner ist ein „telnet -6 mail.forum.ffrl.de. 25“ erfolglos:

root@gw04:~# telnet -6 mail.forum.ffrl.de. 25
Trying 2001:41d0:c:95c::178...
telnet: Unable to connect to remote host: Connection timed out
root@gw04:~# traceroute6 mail.forum.ffrl.de.
traceroute to mail.forum.ffrl.de. (2001:41d0:c:95c::178), 30 hops max, 80 byte packets
 1  2a01:4f8:161:72aa::2 (2a01:4f8:161:72aa::2)  0.130 ms  0.118 ms  0.112 ms
 2  ex3k17.rz16.hetzner.de (2a01:4f8::a:16:17)  4.419 ms  4.423 ms  4.422 ms
[...]

Dito bei IPv4 von Hetzner …

root@gw04:~# telnet -4 mail.forum.ffrl.de. 25
Trying 151.80.64.178...
telnet: Unable to connect to remote host: Connection timed out

It’s dead, Jim!

Anscheinend funktioniert das Routing wieder einmal nicht so, wie es soll. Ich habe daher den DNS so eingestellt, dass er für den Mailserver auf die selbe IP-Adresse auflöst, wie bei forum.freifunk.net

So wird es funktionieren, wenn wir auch das Forum per Browser erreichen.

Sorry, dass das immer wieder failt. Das Setup ist … kompliziert.

1 Like

Was versucht Ihr denn zu erreichen? Bislang waren’s OVH-Adressen, das Forum selbst hat 'ne FFRL-IP (also wohl Tunnel), warum kompliziert routen?

Das Forum soll im FFRL-Netz betrieben werden. Dazu bauen wir von dort aus einen GRE-Tunnel zum Rheinland Backbone an und routen IP-Adressen aus dem Netz dort hin. Zwischenzeitlich lief das IPv6-Routing mit zwei von den Adressen nicht korrekt, so dass ich einfach die Adressen des regulären Netzwerk-Interfaces für Mail verwendet habe. Da stimmt jedoch etwas mit dem IPv4-Routing wiederum nicht seit ein paar Tagen.

1 Like

seufz

   ----- Transcript of session follows -----
... while talking to mail.forum.ffrl.de.:
 DATA
<<< 550 relay not permitted
550 5.1.1 ... User unknown
<<< 503-All RCPT commands were rejected with this error:
<<< 503-relay not permitted
<<< 503 Valid RCPT command must precede DATA

Sorry! Ich habe mich gerade vertippt. :blush:

Das klappt jetzt wieder mit dem SMTP.

1 Like

alles ok. danke schön.

1 Like