Fragen bezueglich Mesh Verbindungen

Wenn ich einen Router im Netzwerk habe welcher die VPN Verbindung für mehrere Router übernehmen soll und zwecks Airtime Reduzierung im lokalen Bereich über Kabel Meshen soll wäre mit der Standart Konfiguration der Aufbau wie folgt:
VPN-Router(aktiviert: Mesh-VPN + Mesh-WAN) am Switch an dem auch Internet und die anderen Router mit aktiviertem Mesh-WAN sind
In dem Fall hätte ich aber den Batman Hintergrund-Trafic im Hauptnetz oder ich müsste noch einen Router davor hängen welcher nur die VPN Verbindung raus lässt.

Meine Idee war nun im VPN Router Mesh-WAN deaktiviert zu lassen und ein Separates VLAN für lokalen Mesh anzulegen. Auszug aus der network Config:

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 2 3'

...

config interface 'mesh_lan'
        option ifname 'eth0.3'
        option mtu '1500'
        option proto 'batadv'
        option mesh 'bat0'

Rest der Config ist Original Nordwest Network fuer WDR3600. Funktioniert soweit gut.

Gehe ich recht in der Annahme dass, da Mesh-WAN deaktiert so nur der VPN Traffic vom WAN Port ab geht?

Wenn ja gehts weiter mit dem nächsten Punkt :wink:
Updatefestigkeit
Da die network Config in der Form nicht Updatefest ist habe ich den Autoupdater deaktiviert was auf dauer natürlich nicht komfortabel ist :grin:
Ist die /etc/sysupgrade.conf fuer den Gluon Autoupdater relevant?
Wenn ja wuerde ein Eintrag „/etc/config/network“ ja ausreichen um die Konfiguration Updatfest zu machen(Eventuelle Aenderungen an den MTUs mal abgesehen die man dann nachpflegen muesste).

Ich hoffe ich habe mich halbwegs klar ausgedrückt und keinen totalen Blödsinn geschrieben, bin noch nicht alzu fitt in der Thematik :sweat_smile:

1 Like

Ich habe meine gluons für mesh on vlan konfiguriert. Ich kann heute Abend mal meine config posten.

Das hab ich mir auch schon Mal überlegt. Die Frage ist doch: Was macht eine 0815-FritzBox mit den ankommenden VLAN-Paketen?

Werden die trotzdem über’s private WLAN ausgestrahlt? Dann hätte man nichts gewonnen. Oder verwirft die die? Die meisten Switche, die kein VLAN können, leiten die Pakete einfach weiter.

Dann bräuchte man einen VLAN fähigen Switch.

Ok, entweder versteh ich die Antworten nicht korrekt oder habe mich falsch ausgedrückt.
In meiner Konfiguration meshe ich nicht über Tagged VLAN sondern 2 Ports des Router eigenen Switches. Demnach die Belegung wie folgt:
Ports: 1 - Mesh-VPN(Mesh-WAN deaktiviert)
Ports: 2&3 - Mesh-LAN
Ports: 4&5 - FF-Clients

Mein Frage war diesbezüglich ob bei ausgeschaltetem Mesh-WAN und eingeschaltetem Mesh-VPN über den WAN Port noch andere Verbindungen(bzw Batman Packages) ausser dem VPN Tunnel abgehen.
Und ob die Konfiguration des mesh_lan Netzes korrekt ist(funktionieren tut sie). Wie im Eingangspost gezeigt habe ich zwei Ports in der VLAN Switch Belegung genommen und diese als separates mesh_lan Interface angelegt.

Ja das ist sinnvoll und wuerde auch schon als Erweiterung erkannt. Muss nur jemand umsetzen in der default Firmware in der auswahl Oberflaeche. Um genau zu sein ist es an der Umsetzung ports settings je Modell haengen geblieben. Fast Jeder router hat ja andere ports und Zuweisungen. Ein paar koennen wohl auch den switch/lanports nicht separieren. Also teilen. Freifunk lan auf den lanports ist zu 95% ueber. Mesh waere das echt wichtiger.

1 Like

Also wenn ich dich jetzt richtig verstehe willst du Mesh on Lan aktivieren.

Dies sind die uci-Befehle

Hab ich noch nicht getestet, ist aber glaube ich der Sinn hinter dem ganzen.

Nach dem Inhalt zu urteilen ja. Jetzt ist die Frage ob diese Datei nicht auch überspielt wird. :wink:

Die Konfiguration kenne ich, aber für mich nicht sinnvoll da ich auf FF-LAN Ports benötige.
Daher das separate Mesh-LAN in meinem Ansatz.

Dachte ich auch jedoch schadet Fragen nicht bevor ich etwas derartiges in Produktiv Netze lasse :wink:

Und genau das war die zweite Frage :smiley:
Wenn nicht müsste ich mir einen Script in rc.loccal schreiben mit folgender Funktion:

  • Speichere die aktuelle Versionsnummer in eine Datei falls nicht vorhanden
  • Falls aktuelle Versionsnummer = Versionsnummer aus Datei erstelle Backup der network Konfig
  • Falls aktuelle Versionsnummer != Versionsnummer aus Datei überschreibe network Konfig mit Backup / speichere aktuelle Versionnummer in Datei / Reboot

Das müsste dann ja dafür sorgen das die anderen Router maximal ein paar Sekunden im falschen Netz sind(nach einem Update welches die network Konfig überschreibt).

1 Like

Ah ok hört sich sehr interessant an.^^ Wenn man fragen darf, was hast du denn mit den 2 freien FF-Clients vor?

Momentan im Heimnetz für meinen Standrechner zwecks SSH Zugriff auf die Router. Der zweite Port ist momentan ungenutzt aber vorgesehen für Testsysteme(RPI für interne Dinste).
Sollte ich das Setup Updatefest kriegen würde ich es gerne in größeren Hausinstallationen einsetzen als Zentraler VPN Uploader. Hier ist mir eben wichtig die Möglichkeit zu haben Server für interne Dinste betreiben zu können und die vorhandenen Netze nicht mit dem Mesh Verkehr zu fluten.
Da hier davon ausgegangen wird das der VPN Router bei der restlichen IT steht machen hier die Ports für Server Sinn. Alle weiteren Router haben zwar auch freie Client Ports sind jedoch meist an Stellen die der WLAN abdeckung diehnlich sind und nicht für den Betrieb eines Servers.

1 Like