Freifunk hinter pfSense (Ping und DNS geht, kein Web)


#1

Ich habe ein Problem sobald der Freifunkrouter hinter meiner pfSense betrieben wird.

Über das Freifunknetz bekomme ich ohne Probleme ein IP-Adresse, Ping und DNS funktionieren ohne Probleme jedoch funktionieren keine Webseiten. Sobald der Router direkt an die FritzBox angeschlossen wird funktioniert er ohne Probleme.

Wenn ein PC statt des Routers angeschlossen wird funktioniert alles ohne Probleme. Über die Webseite ipv6-test.com bekomme ich 20/20 Punkten, also IPv4 und IPv6 funktionieren.


#2

Ich vermute das ist nichts neues für Dich aber das hört sich aber komisch an. Ich betreibe hier einen FF Router an einer pfsense in einem Vlan. Also es geht eigentlich.
Noch mal in anderen Worten um sicherzugehen das ich es richtig verstehe.

  • Du schließt eine FF Router an die pfsense
  • dieser bekommt eine IP adresse von der pfsense
  • und ist im FF Netz auf der Karte zu sehen => die pfsense ist nicht relevant
  • Wenn Du jetzt in das FF Netz mit einem PC gehst bekommst Du eine FF IP Adresse
  • kannst pingen, dns machen
  • aber keine webseiten aufrufen?

Ist das so?


#3

Ja, genau so ist es.

Zusätzlich, der Vollständigkeit halber:

  • Von der Telekom bekomme ich ein /56
  • Die pfSense bekommt von der FritzBox ein /60
    Firewall der FritzBox ist ausgeschaltet
  • Das Interface für den Freifunkrouter bekommt von der pfSense ein /64

Gluon hat die Einstellung sich nur per IPv6 zu verbinden.


#4

da bin ich raus. mit ipv6 habe ich noch keine Erfahrungen. Aber wenn der FF Router eine FF IP Adresse bekommt würde ich die pfsense als Fehlerquelle ausschliessen.


#5

Du hast den Fehler soweit ja schon gut eingekreist…
Als nächstes solltest Du überprüfen, ob dein Freifunk-Netz noch andere Zugänge zum Internet nutzen kann (über Freifunk-Nachbarn).
Du verwendest Gluon, bekommst Du da als Client wie gewohnt eine IP vom Gluon-Supernode-VPN-Server oder eine aus deinem lokalen Netz? (ipv4+ipv6 checken!) Vielleicht willst Du ja gerade einen lokalen DHCP-Server betreiben und dabei gibt es Probleme?

Mit einem weiteren Computer könntest Du Dich auch mal (per Kabel und IPv6) via ssh auf einem der Freifunk-Router einloggen und via batctl nach dem batman-adv-Gateway schauen, den anpingen usw.

Merkwürdig klingt, dass IP-Vergabe, Ping und DNS scheinbar immer funktionieren… Mit normalem Gluon und dessen VPN-Struktur müssten dann eigentlich auch Webseiten funktionieren. Da lohnt sich gar nicht zu fragen, ob Du ipv4-ping oder ipv6-ping meinst und ob die Test-Webseiten ipv4 oder ipv6 waren.
Probleme an den Gluon-VPN-Servern können wir vielleicht ausschliessen, da es ja direkt an der Fritzbox klappt? Oder es geht nur einer der Gluon-VPN-Server nicht und Du hattest durch Zufall beim Testen gerade den erwischt?

Vielleicht ist es ja auch ein MTU-Problem. Oder Du könntest das Gluon-VPN auch mal von ipv6 auf ipv4 stellen…


#6

@DSchmidtberg, ist das Fastd oder Tunneldigger? Falls letzteres tippe ich mal auf irgendwelche Filter in der pfSense.

Viele Grüße
Matthias


#7

Es ist fastd. Verbindung ist immer nur über IPv6 an 0.wup.wupper.ffrl.de