Freifunk mit DD WRT

Ich habe einen WR841NDv8 im Einsatz, welchen ich bereits mit DDWRT geflasht habe. Leider schaffe ich es zur Zeit nicht, nun auf gluon zu flashen.
Daher frage ich hier mal an, welchen Vorteil gluon bietet, wenn ohnehin kein lokales Mesh in der Nähe ist.

  • Kann ich die VPN Verbindung auch mit ddwrt herstellen?
  • Wie kann ich meinen Router (auch ohne Gluon) in die Übersichtskarte eintragen?
  • Wenn gluon, dann würde ich gerne eine Multi-SSID erstellen, bei dem ein virtueller AP stets lokal in meinem Netzwerk ist. Das ist Grundvoraussetzung für den Umstieg auf Gluon.
  • Bietet die VPN Vorteile in Bezug auf Abmahnungen?

Bitte nur technisch begründete Antworten.

Kann ich die VPN Verbindung auch mit ddwrt herstellen?

Grundsätzlich sollte das möglich sein, du wärst aber damit alleine auf weiter Flur. Du müsstest quasi die gesamte Arbeit von Gluon duplizieren, also zumindest fastd, alfred etc. aus den Repos zusammenziehen, ggf. auf DD-WRT neu bauen. Zu Erwägung zu ziehen wäre da imo zumindest ein Wechsel nach OpenWRT, wobei ich nicht genau weiß, wie stark die Unterschiede sind, insbesondere im Userspace.

Das ist nicht-trivial, z.B. brauchen wir auch eine speziell gepatchte BATMAN-Version oder sowas.

Wie kann ich meinen Router (auch ohne Gluon) in die Übersichtskarte eintragen?

Sobald das VPN/fastd läuft, sollte das kein Problem sein, wobei ich das noch nicht ausprobiert habe, das mit nicht-Stock-Gluon mal auszuprobieren. Du musst dazu halt noch alfred einrichten, um die Daten an die Alfred-Masters zu schicken.

Wenn gluon, dann würde ich gerne eine Multi-SSID erstellen, bei dem ein virtueller AP stets lokal in meinem Netzwerk ist. Das ist Grundvoraussetzung für den Umstieg auf Gluon.

Kommt afaik darauf an ob der AP das kann. Auf OpenWRT hab ich mit dem WR841ND mal ein Multi-SSID-Netz aufgesetzt, um einen Repeater für ein WLAN zu haben. Wo ich jetzt so drüber nachdenke, sollten alle Geräte die Gluon unterstützt das auch können, immerhin braucht man ja einen AP und ein Ad-Hoc-Netz mindestens.

Du bist natürlich davon eingeschränkt, dass beide SSIDs dann auf dem selben Kanal funken müssen, das kann der 841ND nicht anders.

Bietet die VPN Vorteile in Bezug auf Abmahnungen?

Mit dem VPN sind Abmahnungen mit an Sicherheit grenzender Wahrscheinlichkeit ausgeschlossen, da aller Datenverkehr ins Internet nur verschlüsselt an die Supernodes geht, und von dort weitergeleitet wird. Dein Router erhält eine genattete IPv4 aus dem privaten 10.0.0.0/8 sowie eine IPv6 aus der Range vom Freifunk Rheinland e.V. daher ist von außen kein Rückschluss auf die IP deines Internetanschlusses möglich.

Hi :smile:

Langa Antwort: Ja

Kurze Antwort: Nein

Gluon hat nicht nur eigene Pakete sondern auch einige Kernel-Patches, Treiber-Patches, modifizierte Basis-Pakete usw.
Das ist der Grund warum auch ein normales OpenWRT nicht ohne weiteres verwendet werden kann ohne das dadurch Einschränkungen oder Fehler auftreten die unter Umständen nicht nur das eigene Gerät stören sondern das gesamte Mesh. Daher ist experimentieren direkt im Mesh immer ein wenig problematisch weil man damit eben schnell auch mal andere Mesh-Teilnehmer in Mitleidenschaft ziehen kann.

Also wie @yayachiken schon schrieb musst du die meisten Features auf DD-WRT portieren was nicht so trivial ist wie es sich anhört.

Edit:
Im übrigen kann man mit Gluon gar nicht ohne VPN oder direkte Verbindung zu einem Gateway (Supernode) Internet bereitstellen.

Gruß
Cyrus

Ich muss ja gar nicht Teil des Mesh werden, ich will einfach nur Leuten ein freies WLAN anbieten.
Bisher tat ich das unter „Free WLAN“, jetzt heißt es „Freifunk“, jetzt wäre natürlich noch toll, wenn ich mit einer VPN Verbindung hätte, um das Risiko der Störerhaftung zu minimieren. Ein Mesh wird es nicht geben, da die Wahrscheinlichkeit, dass der einzig erreichbare Nachbar auch ein Freifunk aufbaut eher gering ist.

Das habe ich bei mir mit Gluon so laufen. Mein lokales LAN kommt über den WAN Port rein und wird sowohl auf die LAN Ports als auch auf ein WLAN mit eigener SSID gebridged. Die Freifunk SSID und die mesh SSID laufen parallel dazu. Ich suche mal meine config raus und poste sie.

Hier ist die Config die ich nutze um auf Gluon ein zusätzliches privates Netz bereitzustellen:

Folgendes in die /etc/config/wireless hinzufügen:

config wifi-iface 'tisoft_media_rep' 
	option network 'wan'            
	option device 'radio0'          
	option mode 'ap'                
	option ssid 'tisoft_media_rep'  
	option encryption 'psk2'        
	option key 'XXX'

Damit wird ein neues verschlüsseltes WLAN bereitgestellt, dass mit dem WAN Port gebridged ist. Mit der Änderung funktioniert die Freifunk SSID weiterhin, über die wifimesh-blabla SSID wird weiterhin gemashed und das private Netz geht auch. Leider kann es sein, dass sich durch die Änderung die MAC Adressen auf den Interfaces verschieben. Das hat zur Folge, das die Übersichtskarte nicht mehr die richtigen Daten anzeigt. Deshalb vorher besser einmal die MAC Adressen der Interfaces mit ifconfig auslesen und falls sie sich durch das zusätzliche Netz geändert haben, statisch setzen. Die /etc/config/wireless sieht jetzt bei mir so aus:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11ng'
	option path 'platform/ar934x_wmac'
	list ht_capab 'LDPC'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option channel '3'
	option htmode 'HT40+'
	option country 'DE'

config wifi-iface 'tisoft_media_rep' 
	option network 'wan'            
	option device 'radio0'          
	option mode 'ap'                
	option ssid 'tisoft_media_rep'  
	option encryption 'psk2'        
	option key 'XXX'   
	option macaddr '62:66:B3:FC:FB:84'
                                                        
config wifi-iface 'client_radio0'
	option device 'radio0'
	option mode 'ap'
	option network 'client'
	option ssid 'Freifunk'
	option macaddr '64:66:B3:FC:FB:84'
	
config wifi-iface 'mesh_radio0'
	option network 'mesh_radio0'
	option mcast_rate '12000'
	option device 'radio0'
	option mode 'adhoc'
	option bssid '02:CA:FF:15:AA:EE'
	option ssid 'wifimesh-moehne'
	option macaddr '66:66:B3:FC:FB:84'

Ich habe nur die option macaddr ‚…‘ Zeilen hinzugefügt. Alles andere ist so geblieben, wie es vorher war. Die Änderungen haben auch ein Firmware Update überlebt.

Ich habe das in der Möhne Domäne gemacht, sollte aber in der Ruhrgebiet Domäne genauso klappen.

Sobald du Teil des VPN bist, bist du Teil des Mesh. Innerhalb des VPN wird auch über das Meshingprotokoll kommuniziert.

(Korrigiert mich bitte, wenn ich falsch liege)

Gruß
David

Wie komme ich mit dem WR841ND_v8 denn von ddwrt auf das Austauschteilchen der stärksten aller Elementarkräfte?

Sysupgrade-Firmware für den WR841v8 suchen für Deine Community (Ruhrgebiet, Rheinufer, Möhne, Wupperthal… da wo Du halt meshen können möchtest).
Die Datei wahweise per SCP nach /tmp kopieren.
oder auf der shell per wget nach /tmp laden.
Und dann ein „sysupgrade -n“ plus dem Dateinamen das Update durchführen. Falls alles durcheinander ist und Du Dir mit der Datei aber 100% sicher bist, dann auch noch „-f“ dazu.
Alternativ natürlich im Failsafe-Mode (30-30-30-Methode)
Oder per Weboberfläche
Oder per RS232-CMOS im Terminal…

Gibt noch ein halbes Dutzend Möglichkeiten…

Soweit ich weiß geht einfach sysupgrade nicht, da DD-WRT und OpenWRT den Flash anders aufteilen.

Ich hab mal schnell gegoogelt und anscheinend ist es am besten zuerst zur Original-Firmware zurückzuwechseln, und dann normal wie einen neuen Router per Webinterface zu flashen.

Das DD-WRT Wiki ist irgendwie nicht so toll. Zum Glück hat OpenWRT auch Anweisungen für das Flashen der Stock-Firmware bei DD-WRT…

Es kann sein, dass man auch direkt mit mtd OpenWRT/Gluon drüber flashen kann, aber ich würde es nicht probieren.

1 Like

Crossgrade von DD-WRT zu OpenWRT / Gluon geht problemlos mit dem mtd-Tool. DD-WRT hat keinen sysupgrade-Befehl, deshalb muss man das sysupgrade-Image direkt per mtd auf das Flash schreiben. Unterschied zu OpenWRT ist auch, dass das Flash-Layout ein anderes ist, so heisst die zu überschreibende Partition bei DD-WRT linux:

cd /tmp
wget http://.../gluon-...-sysupgrade.bin
mtd -r write gluon-...-sysupgrade.bin linux

Es werden keine Einstellungen von DD-WRT übernommen.

Gruß, Markus

3 Likes

Vielen Dank Atoro, vielen Dank markusl,

Ich konnte die Firmware zwar flashen und komme auch auf das initiale Webinterface, sobald ich hier jedoch Grundeinstellungen tätige und die Kiste neustarte, vergibt sie nur noch IPv6 Adressen und ist nicht mehr erreichbar.
Ist das irgendwie Konzept des ganzen, dass ich selbst nicht mehr auf meine Hardware komme, oder ist das alles noch nicht ausgereift?
Wo vergebe ich ein root Passwort, damit ich die Netzwerkconfig von Atoro pasten kann?

Die IPv4 kommt vom Server „im Mesh“, also hinterm Supernode.
(die IPv6 prefixe und routen werden lokal anhand der MAC-Adressen ausgewürfelt und funtkonieren daher auch ohne Mesh-Link)

Heisst umgekehrt: Kein IPv4-DHCP->Mesh läuft vermutlich nicht.
was sagt denn die Ausgabe von
batctl gwl?
Oder gibt es zumindest bei
batctl o
ein paar Zeilen output?

Wenn du den Wizard für das Setup verwendet hast, ist die Kiste nach der Einrichtung erstmal „zu“. Du müsstest sie erstmal wieder in den Konfigurationmodus versetzen, damit sie auf 192.168.1.1 mit dem Webinterface antwortet.

Im Expertenmodus kannst du den Fernzugriff einrichten.

Danke für die Antworten. Ich hab es jetzt hinbekommen, aber obwohl ich bereits über eine ganze Menge Erfahrung mit embedded devices aller Art, insbesondere aber OpenWRT verfüge, ist die Konfiguration nach eigenen Vorstellungen bei dem Gerät wahrlich kein Zuckerschlecken. (ff-ivenae, ja, ich hätte mich vorher über die Namenskonvention schlau machen sollen, aber - hey - es funktioniert!)

Wo genau das Problem lag, vermag ich nicht einmal mehr zu sagen. Ich glaube es war, dass einige Einstellungen im config-mode nicht übernommen wurden. Das hat mich glauben lassen, dass auch ssh Passwörter nicht übernommen wurden. Dazu kam, dass ich die statische IP natürlich an den WAN Port gesetzt hatte und der Router über die neue IP demnach nicht über die LAN Ports erreichbar war, in die aber mein Kabel eingesteckt war.

Die Sache mit den ipv6 finde ich immer noch ein wenig irritierend, na ja, ich hab ein offenes WLAN bei geringem Risiko. Ich wohne an einer Fahrradstrecke, direkt an einer Kreuzung, da halten immer wieder Leute mit ihrem Bike. Manchmal stellen sogar Leute irgendwelcher Schulen ihre Bänke an unsere Hauswand, weil sie dort für irgendwelche Schul-Läufe eine Mittelstation sind. Ich persönlich halte es für strategisch wichtig, an dieser Stelle ein offenes WLAN zu haben. Außerdem ist es auf der Straße verfügbar, mein Navi synchronisiert mit meinem verschlüsselten WLAN immer die TMC-Staudaten über Internet. Zugleich wechseln gerade meine Nachbarn, da ist man froh, wenn man direkt Internet hat. Das möchte ich einfach teilen.

Edit:
Anbei noch meine wireless config. Merkwürdigerweise musste ich den Modus erst manuell auf ng stellen, vorher gabs nur „g“. Ich bin übrigens aus der Region Rheinufer. Als ich Ruhrgebiet im Thread markiert hab, wars sehr spät und die Buchstaben waren so ähnlich :wink: Vielen Dank an alle hier!

config wifi-device ‚radio0‘
option type ‚mac80211‘
option hwmode ‚11ng‘
option path ‚platform/ar934x_wmac‘
option channel ‚6‘
option htmode ‚HT40+‘
option country ‚DE‘

config wifi-iface ‚mesh_radio0‘
option mcast_rate ‚12000‘
option network ‚mesh_radio0‘
option macaddr ‚a2:f6:c2:d8:b5:86‘
option device ‚radio0‘
option mode ‚adhoc‘
option bssid ‚32:CA:FF:EE:BA:BE‘
option ssid ‚wifimesh-rheinufer‘

config wifi-iface ‚fritzbox‘
option network ‚wan‘
option device ‚radio0‘
option mode ‚ap‘
option ssid ‚FRITZ!Box Fon WLAN 7490‘
option encryption ‚mixed-psk‘
option key ‚XXX‘
option macaddr ‚00:04:0E:D3:F3:66‘

config wifi-iface ‚client_radio0‘
option device ‚radio0‘
option mode ‚ap‘
option network ‚client‘
option ssid ‚Freifunk‘
option macaddr ‚00:12:34:56:78:90‘

Toll, dass es jetzt geklappt hat!

Das ist das Konzept. Setzen eines Passworts ist auf der Einstellung Seite möglich. Dazu muss der Router per Hardwatetaste in den configmodus zurück. → 10 sec reset drücken