Freifunk und IPv6 bzw. DS-Lite

Hallo zusammen,

ich habe derzeit noch IPv4 via Telekom, dort funktioniert der Freifunk Router problemlos.
Der Versuch, ihn an Unitymedia Fritz Box zu betreiben, wo nur noch IPv6 existiert (bzw. die Sammel-IPv4 vie DS-Lite) schlägt fehl, der Router geht nicht online.

Was kann/muss ich tun, damit es via IPv6 funktioniert? Da ja alle IPv4-Adressen mittlerweile belegt sind wird der Umstieg auf komplett V6 nicht mehr allzu lange auf sich warten lassen…

Grüße vom Möhnesee
Stefan

1 Like

Was für einen Router (oder genauer: Welches Gluon) hast Du probiert?
Denn mit der 2014.4 („beta“) sollte IPv6 auch auf dem VPN-Mesh/Wan funktionieren.

Hallo,

es ist folgendes: http://moehne-vis.freifunk-rheinland.net/images/stable/factory/gluon-moehne-0.5+0-stable20140926-tp-link-tl-wr841n-nd-v9.bin

Da ich ja an der Möhne wohne :smiley:

Grüße
Stefan

1 Like

Tja, bislang hat es auch noch nicht funktioniert, hier im Forum die „site.conf“ für „Freifunk-Möhne“ zu finden.
Sonst würde ich ja mal was compilieren zum Test. Und ich weiss halt auch nicht, wen ich da fragen könnte.

Das Problem ist afaik eher die Unitymedia Anbindung. Versuch doch mal einen VPN Tunnel aufzubauen, guck mal bei wieistmeineip.de nach Deiner IP…
Ich habe UM innerhalb der 2 Wochen wieder zurückgegeben, da sie mit dem neuen DS-Lite kein Internet, sondern nur „surfen und mailen“ verkaufen. Einen Server zuhause oder ähnliches lässt sich nicht betreiben…

Hmm, normalweise ist das doch bei UM „Dualstack“, also eine echte IPv6 „mindestens“, oder?
Sprich: Damit sehe ich kein Problem.
(Oder wenn man wirklich einen Server daheim betreiben will, dann nimmt man halt ein ein UM-Business.)

frag mal @breaky bezüglich der möhne site.conf :slight_smile:

die site.conf kann aus jeder laufenden Installation eingesehen werden

cat /lib/gluon/site.conf

Mag die mal jemand von Euch in ein Pastbin eigener Wahl schieben?
(site.mk wäre auch schön.)

Guten Morgen,

Also bei DS-Lite ist es so, daß alle v4-Anfragen zusammengefasst werden auf eine Adresse, also quasi wie eine große NAT, nur halt nicht für einen Endkunden, sondern für sehr viele. Darum geht auf dem Rückweg keine Verbindung von außen zu dem jeweiligen Kunden.
Trotzdem hat man aber eine vollwertige v6-Adresse, dafür muß aber halt der Tunnel vom Freifunk auch mit v6 gehen.
Breaky brauche ich nicht zu Fragen, das ist mein Schwager und hat davon keine Ahnung, eher Thomas der hat aber keine Zeit dafür im Moment.
Den fertig installierten Router habe ich ja, Wer braucht eine Datei?

Habe Freifunk über einen Unitymedia-Anschluss mit DSLite laufen. Funktioniert tadellos. Allerdings hat mir Unitymedia einen Router von Technicolor zur Verfügung gestellt, keine FritzBox.

ich hatte vorher den Technicolor, auch damit lief es nicht. Dann hast du wahrscheinlich eine andere Firmware, mit dieser geht es nicht…

Ich habe auch Unitymedia (mit Fritzbox) aber noch natives IPv4 und zusätzlich einen SIXXS Tunnel. Kann das Probleme bringen?

Bzw. könnte das der Grund dafür sein, dass mein Freifunk zu hause nicht funktioniert.

1 Like

Nochmal: Mit einer auf Gluon 2014.4 basierten firmware sollte das Problem („läuft nicht an IPv6 als Mesh-VPN“) nicht mehr vorhanden sein.
Es dürfte sich also nur noch um Tage (oder Wochen) handeln, bis das Problem aus der Welt ist.

(Für Rheinufer und Ruhrgebiet gibt es entsprechende beta-firmware. Für andere kann ich gern welche backen, benötige dafür aber irgendwo lesbar die „site.conf“ und „site.mk“ der jeweiligen Community.)

1 Like

Rückfrage: wo findet man denn die aktuelle site.conf und site.mk vom Rheinland und Ruhrgebiet?

Rheinufer:
https://github.com/ffrl/sites-ffrl/tree/master/site-rheinufer

Ruhrgebiet:
https://github.com/ffruhr/site-ffruhr

wie bekomme ich denn raus ob ich eine 2014.4 basierte Firmware habe?

http://moehne-vis.freifunk-rheinland.net/images/stable/factory/gluon-moehne-0.5+0-stable20140926-ubiquiti-nanostation-m.bin ist bei mir drauf.

Was liefert
cat /lib/gluon/version/core
Was liefert
uname -a
Was liefert
/lib/gluon/release

(Anhand des release-Datums und Datums würde ich sagen: 2013.3.0. Wobei das keine schlechte Version ist, sie ist zumindest nach meiner Erfahrung stabiler als alles was danach gekommen ist. Nur wenn ein Feature wirklich real „fehlt“, dann hat man ja keine Wahl.)

root@ff-abg-bgh-i41:~# uname -a
Linux ff-abg-bgh-i41 3.3.8 #2 Fri Sep 26 18:51:15 WEST 2014 mips GNU/Linux
root@ff-abg-bgh-i41:~# cat /lib/gluon/version/core
3-v2014.3
root@ff-abg-bgh-i41:~# cat /lib/gluon/release
0.5+0-stable20140926

Ich tapere echt im dunklen und habe keine Ahnung mehr warum mein Router immer offline angezeigt wird. IPv6 ist nur ein Strohhalm muss also nicht daran liegen.

Besonders irritiert mich ja folgende Meldung im log

Nov 17 15:08:00 ff-abg-bgh-i41 daemon.info fastd[1671]: sending handshake to <mesh_vpn_backbone_peer_moehne0>[185.24.221.32:1337]…
Nov 17 15:08:00 ff-abg-bgh-i41 daemon.info fastd[1671]: received handshake response from <mesh_vpn_backbone_peer_moehne0>[185.24.221.32:1337] using fastd v12
Nov 17 15:08:01 ff-abg-bgh-i41 daemon.info fastd[1671]: 185.24.221.32:1337 authorized as <mesh_vpn_backbone_peer_moehne0>
Nov 17 15:08:01 ff-abg-bgh-i41 daemon.info fastd[1671]: new session with <mesh_vpn_backbone_peer_moehne0> established using method `salsa2012+gmac’.

Wo wird der Router denn „offline“ angezeigt?
Alfred? ff-map?

Ansonsten: Kannst Du Dich währenddessen einloggen? Oder eingelogt bleiben?
ggf. „während offline“ mal schauen ob
batctl gwl noch was gibt und ob
batctl p mit der MAC-Adresse(!) eines Gateways antwortet funktioniert.

Wenn das gegeben ist, dann ist „nur“ das ff-Map-Problem (batman vs alfred…) in dem auch anderorten heftig gekämpft wird und bei dem vermutlich verbastelte Hobbynodes im Netz für den Unmut sorgen.