FreiFunkNord Router verlieren Verbindung

In dem verlinkten Wiki-Artikel.

Soweit komme ich.

Dann hat Dein router nichtmal eine Verbindung zu Deinem Heimnetz!
(Wo hast Du denn die 192.168.8.140 her? Ping auf die Adresse geht auch nicht?)

Die Adresse wid dem Router (eigentlich) vom DHCP Server zugewiesen. Wurde zumindest so in der Config mit der MAC-Adresse eingetragen

  1. Du kannst ihn nicht pingen
  2. die Mac-Adresse, die du im DHCP eingetragen hast Du wo her?

Du weißt, dass das eine private IP-Adresse ist, die du nur benutzen kannst, wenn du in demselben privaten Netz bist, über das der Router seinen VPN-Tunnel aufbaut? Also quasi das WLAN derselben FritzBox oder was auch immer für ein Internetrouter verwendet wird.

Ich tippe drauf, dass es einen Kurzschluss im Netz gibt. Dieses Verhalten, was du beschreibst, dass es immer mal wieder stockt, hatten wir auch schon mal. Da werden die Admins von FF-Nord mal ranmüssen. Evtl. kannst du mal im Log deines Knotens nach den Symptomen aus diesem Artikel schauen. Aber lass dich nicht abschrecken, das ist schon für Fortgeschrittene.

Viele Grüße
Matthias

Es klingt in der Tat nach einem Verkabelungsfehler.
Also z.B. „Heim-Lan auf Freifunk-LAN gesteckt“.
Oder „Mesh on Wan aktiviert, obwohl gleichzeitig MeshVPN aktiv ist“

Darüber hinaus finde ich es sehr mutig, die Wan-Mac-Adresse eines Freifunk-Routers irgendwo einzutragen und davon Dinge abhängig zu machen.
Die ändert sich schließlich regelmäßig… zwar nur einmal im Jahr oder so… aber da denkt dann niemand mehr dran „wenn das Freifunk nimmer geht plötzlich“

seh dir mal die reboot zeiten der 841 im ffnord an.
zb. burg/dithmarschen mal auf einen der zahlreichen 841 dort im mesh clicken
zudem ist irgendwas im ffnord komisch.
827 Knoten, davon 434 Knoten online mit 408 Nutzern auf 3 Gateways
aktuell, 25.07.00:46
( sollten normal so bei 800 knoten sein )
verschwinden auf den map immer wieder massenhaft knoten im minutenabstand

Kannst du mal auf der Statusseite des Routers schauen, wie lange die uptime des Routers ist? Also ob der Router eventuell oft neu startet, oder ob der durchgängig läuft und nur die Verbindung abbricht wäre interessant.

Um welche Router handelt es sich überhaupt? dann könnten wir ja selbst mal auf der Karte gucken

https://statistik.hamburg.freifunk.net/d/000000030/freifunk-knoteninfo-knoten-id?panelId=5&fullscreen&orgId=2&from=now-2d&to=now-1m&var-region=ffnord&var-knoten=f4f26d3fe6aa&var-mintervals=900s&var-minterval=900&var-retention=l3

so siehts überall in burg aus. hw def kann also ausgeschlossen werden

Es ist wohl immer noch so, dass die Router mit nur 32mb Ram oft abstürzen. Vor allem wenn so ein kleiner Router auch den Uplink bereitstellt.

Besser läuft z.b. Der 1043er von TP-Link.

Du könntest mal vorsichtig die experimentelle Firmware ausprobieren, ob die dann stabiler laufen:

Index of /nord-firmware 2018.1.0

Bevor wir herumprobieren, arbeitet doch erstmal die Liste ab!
Dieses herumgerate „Internet geht nicht richtig“, „nehmen wir mal andere Firmware“, „nehmen wir mal einen größeren Router“… das ist schlicht nicht nur frustrierend, sondern sorgt dafür, dass Freifunk seinem Bildungsauftrag nicht gerecht wird.

2 Likes

Ich denke dass er diese sehr gute Liste schon beachtet hat: Mein Freifunk funktioniert nicht mehr – wiki.freifunk.net

Leider zeigte die Liste nur, was man tut, wenn der Router nicht geht und noch nicht, was wenn er manchmal geht, manchmal nicht.

Ich habe das Wiki jetzt ergänzt!


Wichtige Info wäre jetzt vor allem: welche Router und ob sie rebooten

Warten wir Mal ab bis sich @Mclovin meldet

1 Like

Also…
Habe einen sehr dummen Fehler gemacht und war mit meinem Rechner im falschen Subnetz weshalb ich den Router weder per Ping noch per SSH erreichen konnte.

Ich bin gerade mal die liste aus dem Wiki durchgegangen…

  • next_nodes lassen sich anpingen (ipv4 UND ipv6)
  • Gateways lassen sich alle auch anpingen
  • Der Test ob das Internet erreichbar ist funktioniert nicht
  • Beim Versuch den Router über seine globale IPv6 anzupingen bekomme ich als Antwort „permission denied“

Jetzt schaue ich mir den von @MPW verlinkten Artikel einmal an.

Also z.B. “Heim-Lan auf Freifunk-LAN gesteckt”.

Was genau meinst du damit?
Ich habe alle Router mit dem „HeimRouter“ verbunden und immer die WAN Buchse verwendet.
An den FFN-Routern sindkeine anderen Geräte angeschlossen.

Mesh on Wan aktiviert, obwohl gleichzeitig MeshVPN aktiv ist

Mesh on WAN ist überall ausgeschaltet und MeshVPN ist überall aktiviert.

Wichtige Info wäre jetzt vor allem: welche Router und ob sie rebooten

Scheinbar rebooten nur einen Teil der Router, denn der eine von ihnen ist seit 2 Tagen Online wohingegen andere gerademal 30 minuten online sind. Alle haben jedoch dass Problem.

Es handelt sich dabei um den Router ffn1_boehme-zeitung (fd42:eb49:c0b5:4242:ee08:6bff:fe7c:f86a)

https://statistik.hamburg.freifunk.net/d/000000030/freifunk-knoteninfo-knoten-id?var-region=ffnord&var-knoten=ec086b7cfb3a&panelId=5&fullscreen&orgId=2&from=now-2d&to=now-1m
der rebootet ständig…

soltau?
hrm… eigendlich ffnh, nicht ffnord…
https://nordheide.freifunk.net/wiki/Hauptseite
http://map.freifunk-nordheide.de/firmware/stable/

gruss aus sprötze!

Nur kurz mobil: Wenn du das Gateway pingen kannst, ist es kein Kurzschluss in der Domäne. Wende dich an die Gateway-Admins.

Grüße

Matthias

Drei von den vier sind 1043er, die haben die gleiche Symptomatik wie die 841er, das kann man also als Grund auch ausschließen.
Ich bin da so schnell nicht wieder vor Ort um Dinge zu prüfen, gehe aber nicht von einem lokalen Problem aus, da es offenbar in ganz FFNord so ist.

kommst du per ssh da ran?

Nein. Wenn das überhaupt eingerichtet ist, sind die Daten dazu jedenfalls nicht da wo ich bin… Die laufen schon eine ganze Weile unproblematisch und mit Autoupdates, ohne dass sich jemand darum gekümmert hat.

Ohne Shell auf den den Routern wird’s leider bei Spekulationen, Kaffeesatzleserei und vor allem gegenseitigen Schuldzuweisungen bleiben. Zumal dann noch nicht einmal klar ist, was denn „in ganz FFNord so ist“.

Tipp: „offline-Anzeige“ in einer Map und ggf. „Fehlstellen in Graphen“ sind nur ein Symptom für eine Liste von mindestens 20 verschiedenen möglichen Ursachen selbst wenn es „alle Router“ der Domain betrifft.

Bis hin zu: die „Offlineanzeige“ passiert auch bei Knoten bei denen „das Internet/Freifunk“ vor Ort durchgehend problemlos funktioniert… aber auch bei Knoten, bei denen „das Freifunk“ wackelt.
Aka: „zwei völlig unabhängige Dinge“, die je mehr man sie korreliert, desto absurdere Schlussfolgerungen ergeben (Piraten auf Weltmeeren vs. Klimaerwärmung…)