[gelöst] Probleme mit dem privaten 2,4GHz-WLAN seit Update auf 0.8.1.6-20160825-pre (Domäne Bochum)

Guten Abend zusammen,
nachdem man mir mitteilte, dass der IRC-Kanal #ffruhr auf irc.freenode.net so gut wie tot sei, wende ich mich nun an das Forum hier.

Zu meinem Problem:
Ich habe seit kurzem Probleme mit meinem FF-Router (Dual-Band, TP-Link TL-WDR4300 v1) - und zwar hatte er im Netzwerk plötzlich eine andere lokale IP-Adresse. Erstmal nicht schlimm, ich wollte aber, dass er wieder seine alte bekommt, also in den Config-Mode und einmal neu eingestellt (dort dann ne feste IP-Adresse eingegeben)
Nach dem Restart standen die beiden privaten WLANs wieder auf einem einzigen Namen. Ich möchte aber gerne _5 und _2,4 als Benennung hinter der SSID haben. Also habe ich das per SSH eingestellt. Im Anschluss uci committ wireless und wifi. leider erscheint das _2,4 Netz nicht. Das _5er Netz ist da. Vom Freifunk sind beide Netzte da (habe das 5er FF-Netz extra umbenannt um das zu prüfen).
Bei einem uci show wireless wird mir auch alles so angezeigt, wie ich das gerne hätte. Nur das _2,4er Netz ist einfach nicht da. Bis vor dem Update hat das immer ohne Probleme funktioniert…

Ausgabe uci show wireless:

wireless.radio0=wifi-device
wireless.radio0.type=‚mac80211‘
wireless.radio0.hwmode=‚11g‘
wireless.radio0.path=‚platform/ar934x_wmac‘
wireless.radio0.channel=‚1‘
wireless.radio0.htmode=‚HT20‘
wireless.radio0.country=‚00‘
wireless.radio1=wifi-device
wireless.radio1.type=‚mac80211‘
wireless.radio1.hwmode=‚11a‘
wireless.radio1.path=‚pci0000:00/0000:00:00.0‘
wireless.radio1.channel=‚44‘
wireless.radio1.htmode=‚HT20‘
wireless.radio1.country=‚00‘
wireless.wan_radio0=wifi-iface
wireless.wan_radio0.disabled=‚0‘
wireless.wan_radio0.network=‚wan‘
wireless.wan_radio0.encryption=‚psk2‘
wireless.wan_radio0.device=‚radio0‘
wireless.wan_radio0.mode=‚ap‘
wireless.wan_radio0.key=XXXXXX
wireless.wan_radio0.ssid=‚XXXX_2,4‘
wireless.wan_radio1=wifi-iface
wireless.wan_radio1.disabled=‚0‘
wireless.wan_radio1.network=‚wan‘
wireless.wan_radio1.encryption=‚psk2‘
wireless.wan_radio1.mode=‚ap‘
wireless.wan_radio1.key=XXXXXX
wireless.wan_radio1.device=‚radio1‘
wireless.wan_radio1.ssid=‚XXXX_5‘
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname=‚client0‘
wireless.client_radio0.network=‚client‘
wireless.client_radio0.disabled=‚0‘
wireless.client_radio0.device=‚radio0‘
wireless.client_radio0.mode=‚ap‘
wireless.client_radio0.macaddr=‚30:b5:c2:56:81:ca‘
wireless.client_radio0.ssid=‚Freifunk‘
wireless.client_radio1=wifi-iface
wireless.client_radio1.ifname=‚client1‘
wireless.client_radio1.network=‚client‘
wireless.client_radio1.disabled=‚0‘
wireless.client_radio1.device=‚radio1‘
wireless.client_radio1.mode=‚ap‘
wireless.client_radio1.macaddr=‚f6:90:c7:86:e9:53‘
wireless.client_radio1.ssid=‚Freifunk (5GHz)‘
wireless.mesh_radio0=wifi-iface
wireless.mesh_radio0.ifname=‚mesh0‘
wireless.mesh_radio0.network=‚mesh_radio0‘
wireless.mesh_radio0.device=‚radio0‘
wireless.mesh_radio0.mesh_fwding=‚0‘
wireless.mesh_radio0.mesh_id=‚ffbo.mesh‘
wireless.mesh_radio0.mcast_rate=‚12000‘
wireless.mesh_radio0.mode=‚mesh‘
wireless.mesh_radio0.disabled=‚0‘
wireless.mesh_radio0.macaddr=‚f6:90:c7:86:e9:51‘
wireless.mesh_radio1=wifi-iface
wireless.mesh_radio1.ifname=‚mesh1‘
wireless.mesh_radio1.network=‚mesh_radio1‘
wireless.mesh_radio1.device=‚radio1‘
wireless.mesh_radio1.mesh_fwding=‚0‘
wireless.mesh_radio1.mesh_id=‚ffbo.mesh.5‘
wireless.mesh_radio1.mcast_rate=‚12000‘
wireless.mesh_radio1.mode=‚mesh‘
wireless.mesh_radio1.disabled=‚0‘
wireless.mesh_radio1.macaddr=‚f6:90:c7:86:e9:54‘

Es wäre wirklich sehr super, wenn mir jemand Vorschläge unterbreiten könnte, was ich noch versuchen kann, damit mein privates 2,4 GHz-WLAN wieder auftaucht. Vielen Dank im voraus :smile:

Hallo,

du müsstest die SSID in der hostapd-Konfiguration ändern können.

Grüße
Matthias

Danke für die Antwort, aber leider habe ich irgendwie keine Ahnung, was du damit genau meinst. Was ist hostapd und wie konfiguriere ich darüber die SSIDs?

mache mal das Komma weg und schreibe 2-4 für 2,4 GHz

Sonderzeichen sind in der seid soweit mir bekannt nicht erlaubt

genauso wie die Klammern → weniger ist mehr :wink:

Ohne , habe ich es schon getestet. Leider brachte das auch nichts. Und vorher ging es ja auch mit ,.
Auch die Klammern sind offensichtlich kein Problem und sogar offiziell in der Bochumer Firmware vorgegeben. Ich stelle das nur immer um, sodass beide Freifunk Netzwerke einfach „Freifunk“ heißen.

Die hostapd-Konfiguration liegt in /var/run.

Grüße
Matthias

Sofern besagte Firmware auf dem gluon-Master basiert ist das ein bekannter Bug und wird in Kürze behoben:

manuell kann man das Problem beheben, indem man in /etc/config/wireless das Problem der doppelten MAC-Adresse behebt (diese Fehlermeldung sieht man in „logread“)

2 Likes

Das sieht tatsächlich genau nach meinem Problem aus. Dann werde ich heute nachmittag mal testen, ob ich das manuell beheben kann.
Danke für die Hilfe :slight_smile:

Das wars! Ich habe in /etc/config/wireless für die Radios ohne MAC welche vergeben, gespeichert, wifi restart und es läuft wieder!
Vielen Dank für die Hilfe :+1: