Gestörter Internetzugang, Grund vermutlich DNS

Mein Nachbar hatte seit einigen Wochen 24/7 einen WR841N ohne Probleme am laufen. Gestern berichtete er mir, dass der Internetzugang darüber seit ein paar Tagen nicht mehr funktioniere. Ich hatte das Gerät daraufhin kurz an meiner Fritzbox eingestöpselt, keine Probleme.

Heute habe ich meinen eigenen WR841N wieder mal in Betrieb genommen. Auch dort bekam ich sofort Internetzugang. Auch das Meshing mit meinem Nachbarn funktioniert. In der Map sind beide Geräte sichtbar, mit aktueller Firmware.
Ein paar MInuten später konnte ich dann keine Webseiten im Browser mehr erreichen. Meine Clients verbinden sich anstandslos mit dem Freifunk-AP und erhalten auch eine IPv4.
Pings auf IP-Adressen laufen, aber die DNS-Auflösung scheint mit Timeout abzubrechen.

Welche DNS werden dir denn mitgeteilt?

Habe meinen Router nun nochmal aus- und eingeschaltet. Seit 10:05 Uhr habe ich nun einen stabilen Internetzugang. Auch ist mir aufgefallen, dass die Statusseite jetzt 2014.4-stable-2.4.1 als Version anzeigt. Dies war bis vorhin noch die ältere 2014.4-stable-2.3, die auch immer noch beim Nachbarn läuft.

Nachtrag: Gerade eben hat Nachbars Router nun auch die 2.4.1 bekommen. DNS-Auflösung immer noch in Ordnung. Falls nochmal Probleme auftreten melde ich mich.

Der DNS Server der per DHCP Verteilt wird ist immernoch der Slave 10.188.1.23.

Es sollte 10.188.1.100 als Master und 10.188.1.23 als Slave sein! @DSchmidtberg

Und IPv6 geht auch noch nicht.

Offenbar ist das Nameserver-Problem behoben. Bei mir bekommen die Clients die DNS in der richtigen Reihenfolge:

cat /etc/resolv.conf
search in.troisdorf.ffwtal.net
nameserver 10.188.1.100
nameserver 10.188.1.23

Weiterhin bekommen die Clients bei mir keine IPv6-Adresse. Auch kann ich meinen Server update2.infra.fftdf nicht mehr via IPv6 aus dem „Internet“ erreichen.

IPv6 ist momentan nicht verfügbar. Voraussichtlich ab Übermorgen sollte es wieder laufen.

Tut mir leid, dass es kein IPv6 gibt. Das was auf den Servern eingestellt wurde um IPv6 anzubieten, war wohl extrem flüchtig als ein paar eingegebene Befehle und nicht von Dauer. Ich brauche einen Tag, um mich da einzuarbeiten. Entschuldigt bitte die Unannehmlichkeiten.

Die Server haben ein Update erfahren und mussten neu gestartet werden.

$ cat .bash_history

Danke fürs Reparieren!

der war gut :wink: irgendjemand™ hat heute den Server neu gestartet und .bash_history ins Datennirvana befördert. Frag mich jetzt bitte nicht wie das passieren konnte, da ich es selbst nicht begreife. Außer mir und Dustin hatte noch Stefan neuerdings Zugriff … und heute startet auf ein mal wupper1 vor meinen Augen neu.

Vor meinen Augen auch!
Die bash History war aber schon leer als ich das erste mal drauf wollte, da ich gucken wollte was so vor mir passiert ist, damit ich da nicht Irgendwo reingrätsche

entweder $HOME in ein git oder (sowieso sehr praktisch) etckeeper installieren, die .bash_history (nur der Einfachkeit halber) nach /etc/ verschieben und ~/.bash_history dahin symlinken.

1 Like

Da würde ich ja „last“ befragen :wink: Der weiß vielleicht, wer irgendjemand™ ist bzw. von wo der sich eingeloggt hat.

das bringt auch nichts, die beiden, die mit mir eingeloggt waren, streiten jeglichen Reboot ab:

  • 15:56 – unbekannt
  • 16:10 – unbekannt
  • 16:18 – ich, um alles wieder in Ordnung zu bringen

na gut, es bringt doch was, es hat sich zumindest niemand rein gehackt (zumindest hat dieser seine Spuren verwischt)

remote syslog - aber ich trolle … :wink:

1 Like

abgesehen davon, dass wupper1 gebootet hat, ohne dass jemand die Änderungen permanent gemacht hat (Startskripte anpassen!), ist dies wohl auch auf wupper0 versäumt worden!

wupper0 benutzt wieder die alte MTU, die bereits vor Wochen geändert wurde. Daher funktioniert zur Zeit das gesamte Freifunk in Troisdorf nicht.

Bitte, @DSchmidtberg und @phip, kann jemand von euch die MTU wieder korrekt konfigurieren? Und bitte permanent! Danke.
@stefan hat keinen Zugang mehr zu wupper0/1…

Rebootfest sollte die conf schon gemacht werden, insbesondere wenn man wie wir Freifunker Software nutzt die nicht unbedingt stable sein muss (batman, fastd, etc)…im Grunde weiß man ja nie, wann dann doch mal wieder ne Panic kommt…

wupper0 hatte 1426 und wupper1 1406

Habe bei wupper0 jetzt auch 1406 eingestellt.

Da stimme ich dir zu. Bei wupper0 bin ich mir nicht sicher ob die nicht schon immer mit 1426 lief und es bis jetzt noch nicht aufgefallen ist.

Sobald @thomasDOTwtf uns die Server in Deutschland freigeschaltet hat werden wir alles von Anfang neu machen und ordentlich dokumentieren.

Ich habe mir einen kleinen Urlaub vom Freifunk genehmigt, nachdem ich gesehen habe, wie viel Zeit ich dafür ausgebe.

Wenn Dustin dies und jenes in meiner Abwesenheit angepasst hat, dann hat er es gemacht. Wenn das nicht bootfest eingerichtet wurde, dann muss ich es halt bootfest einrichten …

wie ich bereits gestern in der PN schrieb: ich weiß nicht, ob Stefan FFRL-Mitglied ist, ich weiß nicht, ob er drauf darf. Mysteriöse Reboots sind aufgetreten … sein Zugang wurde nicht abgesprochen …