Gluon 2019.1.x Knoten erscheinen nicht in der Map (respondd)

Wie hast du denn das gelöst?

Ich hab gestern yanic so wie im issue angepasst was nicht funktionierte.

Dann hab ich:

ip -6 route add ff05::2/128 dev eth0 table local

Ausgeführt Fehlanzeige.

Derzeit denke ich drüber nach das wieder auf fd02 zu ändern…

 # multicast address to destination of respondd
 # (optional - without definition used batman default ff02::2:1001)
-#multicast_address = "ff05::2:1001"
+multicast_address = "ff05::2:1001"

Hier war glaube ich wirklich nur einkommentieren nötig.

1 Like

Wo hast du den Schnippsel her? Kann das nicht zuordnen.

das selbe problem bei hopglass-server statt yanic, wie löst man das problem da? bzw. ist das bekannt?

btw: vielleicht mal den titel umbenennen in „2019.1.x Router …“

Bei Yanic war ich bisher nicht in der Lage das Problem zu lösen.

Ich werde daher auch den rhein-sieg Patch einbauen.

vielleicht kann @PetaByteBoy da einen Tipp geben

Nein. Kann er nicht.
https://github.com/hopglass/hopglass-server/issues/107

Das ganze wird nicht einfacher in Map-Setups, die auf mehreren Batman-Interfaces in unterschiedlichen L2-Domains hängen.
Ich gehe davon aus, dass man nun um getrennte Routingtabellen (plus tagging der Pakete) nicht mehr herumkommen wird.
Ist vermutlich trivial, es muss nur jemand tun.

1 Like

Ich verstehe gerade das Problem nicht, wir haben yanic mit 12 batman Interfaces und ff05::2:1001 am Laufen von Anfang an seitdem wir die neuen Gateways haben.

Unser Config für ein Interface sieht zum Beispiel so aus:

[[respondd.interfaces]]
ifname = "br-muc_cty"
port = 45124

[[respondd.interfaces]]
ifname = "br-muc_nord"
port = 45124

Diesen Config Eintrag kann man beliebig oft und für jedes Interface wiederholen.

Auch auf unseren Gateways ist der respondd entsprechend eingestellt.

1 Like

In Gluon gab es eine Änderung der Adresse, und die neue Adresse ist keine link-local multicast-Adresse, wodurch die Adresse nicht mehr so verwendet werden kann wie die alte(n). Was genau nötig ist weiss ich nicht.

Scheinbar aber nichts, was nicht vorher bei uns auch schon so war.

Das Node taucht sauber auf der Karte auf mit unserem Setup.
https://map.ffmuc.net/#!/en/map/18e829c0aaae

Und was ist das für ein Backend?

Wie oben erwähnt Yanic, nachdem es da hieß dass es auch nicht geht von @anon68922371.

Also mit yanic funktioniert das mit gluon 2019.1 super einfach die zweite Adresse konfigurieren und alles klappt. Mit hopglass server allerdings habe ich auch noch meine Probleme. Wir beitreiben beides, um Redundanz zu haben.

Für Yanic führt man einfach zwmail die config

[[respondd.interfaces]]
ifname = „bridge interface“
multicast_address = „ff02::2:1001“

[[respondd.interfaces]]
ifname = „bridge interface“
multicast_address = „ff05::2:1001“

auf und alles ist gut.
Ich wäre trotzdem sehr an einer Lösung für hopglass interessiert, da ich zumindest bis zum switch auf batman 15 noch gerne mit hopglass arbeiten würde. Wenn das Netz komplett geswitcht ist wäre mir dass dann egal

Habe den patch mal von Hand auf einem Router ausgeführt:

sed -i '/procd_set_param command $DAEMON -d \/usr\/lib\/respondd -p 1001 -g ff02::2:1001 $meshdevs -g ff05::2:1001 $clientdevs/c\        procd_set_param command $DAEMON -d \/usr\/lib\/respondd -p 1001 -g ff02::2:1001 $meshdevs $clientdevs -g ff05::2:1001 $clientdevs' /etc/init.d/gluon-respondd
reboot

aber hat nichts gebracht

1 Like

Sowohl yanic als auch gluon respondd scheinen noch Probleme zu haben. Fehlerberichte dazu finden sich unter

Die Autoren in diesen Tickets zu Informieren ist vielleicht sinnvoller als hier im Forum schlechte Workarounds zu basteln. Denn mit einer sinnvollen Loesung in den Softwarepaketen, kann man vielen Leuten helfen ohne mit der Zeit in seinen eigenen Hacks zu ersticken.

1 Like

Hab den Patch vor dem build ausgeführt und funktioniert einwandfrei.

der patch müsste doch einfach die datei /etc/init.d/gluon-respondd ändern, bovor sie in die router images kopiert wird, oder? dann müsste das doch auch im router funktionieren im nachhinein.

vielleicht gehts ja auch, bloss in kiel haben wir ein anderes Problem als in Nord :wink:

@anon68922371, womit werden in nord nochmal die kartendaten generiert?

yanic

Und auf dem Mapserver wurde KEINE explizite Route für ff05-prefix gesetzt?