Gluon-aptimeclock package


#22

Hallo Collimas,

das ist echt nicht böse gemeint, aber dir fehlt da noch ein wenig die Erfahrung. Alle Sachen, nach denen du gefragt hast, findet man leicht bei Google. Es ist einfacher, das zu programmieren, als dir das zu erklären. Deshalb wird es auch niemand tun. Lies dich mal im OpenWrt-Wiki zu sysupgrade etc. ein und guck dir mal bei gluon die Sachen im Ordner packages an und vor allem die upgrade-scripte, die auf so einem Router laufe n. Wenn du das verstanden hast, solltest du das alles hinkriegen.

Schöne Grüße,
Vincent


#23

Hallo Vincent,
klar fehlt mir die Erfahrung, sonst müsste ich ja nicht fragen… :joy:

Allerdings muss ich dir mit Google widersprechen, da finde (zumindest ich) nichts Konkretes, was mir weiterhilft. Es ist ja auch schön, wenn jede Community etwas zum Freifunk beiträgt, nur haben die allermeisten Programmierer hier das Dokumentieren nicht erfunden. Da ist es schwer, sich einzuarbeiten.

Ich wäre dir sehr dankbar, wenn du mir ein paar Links zum Thema nennen könntest.
Eigentlich möchte ich nur die Pakete gluon-aptimeclock und gluon-vpnlimittimeclock wieder zum Laufen bekommen, dann wäre ich schon mehr als zufrieden. Ich dachte mir aber, falls ich die Chance habe, etwas lernen zu können und die Anpassungen selber vornehmen zu können, wäre nicht nur mir geholfen.

Viele Grüße,
Michael


#24

Woran scheitert es denn konkret(!). Fehlt bei den Änderungen von @rubo77 noch was?
(Du bist sicher, dass Du “-v lede” ausgecheckt hast. Nein, ich werde jetzt keine Diskussion zum Thema ‘LEDE heisst doch jetzt wieder OpenWRT’ führen.)


#25

Danke, den neuen Branch habe ich einfach nicht gesehen! Dann werde ich mal neu bauen.


#26

Habe jetzt mal neu gebaut, leider läuft es nicht. Wenn ich die Befehle per uci set setze, werden die Zeiten auch schön brav in die /etc/config/wireless eigetragen, aber zum programmierten Zeitpunkt passiert nichts. Das Client-Netz wird nicht ab- oder angeschaltet.

Was tun? Ach so, gebaut wurde vom Release v2017.1.4.


#27

Bei den Skripten aptimeclock und vpnlimittimeclock ist ein Leerzeichen zuviel in der Shebang. Habe das mal gelöscht und baue neu.


#28

Wo meinst du genau? Ist die Änderung irgendwo im git? Habe auch gerade mit dem package unter lede getestet und festgestellt, dass nichts passiert.


#29

In das Original-Repo habe ich es nicht gepusht, die Änderungen kannst du in unserem eigenen Repo sehen: https://github.com/freifunklippe/packages


#30

Das reicht immer noch nicht. Wenn ich die /lib/gluon/aptimeclock/aptimeclock.sh manuell ausführe, kommt folgende Ausgabe:

sh: 0550: unknown operand
uci: Entry not found

Die zweite Zeile dürfte andeuten, dass es auf meine 1043v4 kein Client.Radio.1 gibt. Aber was soll die erste Zeile bedeuten? Leider ist logread nichts genaueres zu sehen.

Das Leerzeichen in der Shebang hat auch keine Auswirkung, egal ob da oder nicht.


#31

Cool, noch einer der das bestätigen kann das nichts passiert :wink:
Wir sind leider zum gleichen Ergebnis gekommen.
Hat noch einer einen Tipp wonach man gucken könnte?


#32

Mal ins blaue geraten:

Sind denn die uci Einträge die mit get abgefragt bzw. Mit set gesetzt werden vorhanden ?

Edit: gerade getestet:

uci set jjj=q
uci: Entry not found


#33
root@Freifunk-Lippe-LEDE-Test:~# uci get wireless.client_radio0.disabled
0

root@Freifunk-Lippe-LEDE-Test:~# uci get wireless.radio0.client_clock_on
0550

root@Freifunk-Lippe-LEDE-Test:~# uci get wireless.radio0.client_clock_off
1800

Die Einträge sind vorhanden, trotzdem kommt diese Ausgabe:

sh: 0550: unknown operand
uci: Entry not found

Was bedeutet uci set jjj=q ?


#34

Sehr wahrscheinlich habe ich den Fehler gefunden, muss nur noch neu bauen.

Im Script steht folgender Code:

CurrentTime=$(date +%k%M)

Dies funktioniert in der in LEDE verwendeten BusyBox-Shell nicht mehr. Da wurde scheinbar etwas an der Syntax verändert.

Wenn man die Zeile abändert in:

CurrentTime=$(date +%H%M)

läuft die aptimeclock.sh ohne Fehler durch. Das gleiche Problem besteht in der vpnlimittimeclock.sh

Man kann das sehr schön testen, wenn man per SSH auf dem Knoten eingeloggt ist und

date +%H%M

eingibt. Dann sollte die aktuelle Uhrzeit im Format HHMM angezeigt werden.

Durch diesen Befehl wird die Variable $CurrentTime gefüllt. Wenn diese leer bleibt, bricht das Script ab und der Schaltvorgang findet nicht statt.


#35

Pull-Requests welcome


#36

Pull-Requests sind erstellt.


#37

Danke, ich habe gemerged.


#38

Danke!


#39

Könntet ihr euch bitte einmal das Script vpnlimittimeclock ansehen? Das funktioniert immer noch nicht. Startet man die vpnlimittimeclock.sh manuell, dann läuft diese auch ohne Abbruch durch.

Dummerweise wird die Bandbreitenbegrenzung nicht eingeschaltet, auch wird in die /etc/config/simple-tc nichts vom Script hineingeschrieben.


#40

Das vpn-limit funktioniert leider “so” nicht, ist leider bekannt.
Ich finde leider trotz einigem Suchen den Thread nicht wieder.
Das geht wohl nur, wenn man massiv mehr an den network-Interfaces tut.


#41

Was heißt “so” nicht? Funktioniert es denn irgendwie anders?