Gluon-aptimeclock package


#1

Dieses Paket hab ich jetzt mal bei mir eingebaut und über die Konsole

wireless.radio0.client_clock_on='0700'
wireless.radio0.client_clock_off='2100' 

gesetzt und noch mit uci commit gespeichert. Uhrzeit stimmt und jetzt ist es 21.50h

Leider scheint nichts zu passieren. uci show zeigt noch
wireless.client_radio0.disabled=‘0’ und im logread gibt es keine verdächtigen Einträge.


Installation Evangelische Kirche Lohmar mit nightswitch
Client-AP zeitgesteuert deaktivieren
#2

hier funktioniert es.
Es tauchen dann im logread Zeilen auf wie

   Wed May 18 22:10:15 2016 user.notice gluon-aptimeclock: APradio0 deaktiviert

   Wed May 18 22:15:10 2016 user.notice gluon-aptimeclock: APradio0 aktiviert

#3

Die aptimeclock.sh unter /lib/gluon/aptimeclock/ hat nicht die nötigen Rechte (0664). Hab diese mal manuell auf 0775 gesetzt. Jetzt funktioniert das Script.

Bleibt die Frage: Wie kann ich der Firmware die Rechte richtig mit geben? Oder ging da beim Firmware bauen was schief?


#4

Vermutlich bei letzerem, denn hier sieht es so aus nach dem Clonen ("+x" hat’s)

Oder aus dem Plasterouter selbst dann:


#5

Ich nutze das git per Web Oberfläche. Da gingen die Rechte der Datei irgendwie verloren. Hab das jetzt mal Manuell richtig gesetzt. Aber ins git bekomme ich die Rechte per Web Oberfläche nicht mehr richtig rein :frowning: Aber das ist dann ein anderes Problem.

Wie kann ich aptimeclock deaktivieren, wenn die Zeitsteuerung nicht wirken darf, und statt dessen die manuell unter wireless.client_radioX.disabled='X ’ gesetzte Einstellung wirksam bleiben soll?


#6

sauber:

uci delete wireless.radio0.client_clock_on
uci delete wireless.radio0.client_clock_off
uci delete wireless.radio1.client_clock_on
uci delete wireless.radio1.client_clock_off

Dirty: (pro “Radio-Band” mindestens einen Schlüssel auf etwas setzen, was nicht 4 Stellen hat)

uci set wireless.radio0.client_clock_off=99
uci set wireless.radio1.client_clock_off=99

#7

Was kann es sein, wenn die Zugriffsrechte passen (0775) und 2x uci: Entry not found als Ausgabe erscheint? Im logread ist überhaupt nichts zu sehen.


#8

dann gibt es beide Schlüssel nicht im Uci.
Welch Gluon-Version?


#9

Version 2016.1.5 - Master


#10

Hast du noch eine Idee was man checken kann? Habe gestern einen jungfräulichen Router geflasht und die Rechte stehen auf 0775. Das Script wird ausgeführt aber bei manueller Ausführung kommt “Entry not found”.


#11

Das “Entry not found” bezieht sich vermutlich auf das 5GHz.
Das Script holt sich halt zum Test sowohl die Settings für 5GHz wie auch für 2,4GHz.
Auf einem Futro wird man also in der Regel sogar zwei Mal ein “entry not found” bekommen.

ich tippe darauf, dass entweder die micrond-Cron nicht läuft oder aber die Keys nicht persitiv gesetzt sind.


#12

Die Meldung erscheint wie gesagt zweimal. Und ein 2,4 GHz Modul existiert auf dem 841er definitiv.
micron.d läuft da unser Nightboot-Script vom micron.d ausgeführt wird.
Was meinst du mit persitiv?


#13

Ob die Werte auch geschrieben sind.

Poste mal die Ausgabe von

 uci show| grep wireless.radio0.client_clock

#15

Da wurde mal die Syntax geändert, oder? Ich befürchte unsere Doku entsprach noch dem alten Stand.
Ich teste ob es jetzt funktioniert.


#16

Ja, wurde es, da leider der alte Schlüssel zwar funktionierte, jedoch beim Autoupdate nicht übernommen wurde.
Und statt das mit zwei Workaround-Script über das Sysupgrade zu retten habe ich dann lieber den Schlüssel in einen “sicheren” Bereich verschoben.


#17

Ok, Asche auf unsere Häupter. Kaum macht man’s richtig, schon funktioniert’s…

Sorry, wollte dir keine Arbeit machen damit.

Mit was anderem vielleicht schon. Was hältst du davon, die Zeitsteuerung um Wochentage zu erweitern? Habe den konkreten Fall, dass der Router nur an bestimmten Tagen und zu bestimmten Zeiten laufen soll.

So als Beispiel:

uci set wireless.radio0.client_clock_on=010815 (01 = Montag - Rest Uhrzeit 8 Uhr 15 wie gehabt)
uci set wireless.radio0.client_clock_off=032045 (03 = Mittwoch - Rest Uhrzeit 20 Uhr 45 wie gehabt)

Wäre so etwas mit vertretbarem Aufwand möglich?


#18

Meinst Du, dieses Format ist vermittelbar?
Wär toll, wenn jemand da ein Gluon-(advanced-)configmodul für bauen würde.


#19

wäre es da nicht sinniger gleich die cron eigene Syntax zu nehmen?
die kann ja minuten, stunden, day_of_month month und day_of_week
würde dann ja
15 8 * * 1 uci set bla on … bzw 45 20 * * 3 uci set bla off…
weis nicht genau wie das script dazu passt.


#20

Die Cron-Syntax wäre schon in Ordnung. Man müsste halt verhindern, dass die Config bei einem Sysupgrade verloren geht.
@adorfer: gibt es Doku wie man config-Module erstellt? Habe nichts per Google gefunden und auch sonstwo nichts Passendes.


#21

Ich möchte den Thread hier noch mal pushen: wie mache ich dieses Paket unter LEDE lauffähig? Oder besser gefragt: gibt es irgendwo eine Doku, wie man Openwrt-Pakete anpasst?