Gluon auf PC Engines APU.3C4

schnapp dir nen usb stick. e2b drauf installieren.
http://www.easy2boot.com/download/
in das danach darauf zu findende linux verzeichniss wirfst du das debian netinstall image.
dann bootest du $gerätx86amd64 deiner wahl mit monitor von dem stick, installierst dir das deb netinstall darauf. apt updte && upgrade && install opensssh-server…
checkst, ob du via ssh drauf kommst.
übers netzwerk brauch ich dir nnu hoffentlich nix vorzubeten…
die hdd/ssd verbaust du nu ins apu und kopierst dir via dd das gluon auf /dev/woistmeinem2ssd

Jetzt habe ich es geschafft in dem ich auf einen stick openwrt geflash habe, und auf einen anderen das gluon image gelegt habe. openwrt gebootet, per serieller konsole 2 stick gemountet und image auf die SSD geschrieben. Bootet jetzt. extrem umständlich aber fürs erste klappt es.
Merkwürdig finde ich das der Config mode nur auf LAN3 erreichbar ist. Und was müsste ich anstellen um nun je auf einem LAN Port vpn, mesh und client zu haben? Webconfig erkennt offenbar nur 2 Ports.
Nachfolgend die Interfaces nach Abschluss der ersten Einrichtung.

bat0      Link encap:Ethernet  HWaddr 00:0D:B9:53:71:60  
          inet6 addr: fe80::20d:b9ff:fe53:7160/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:92 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:22 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3864 (3.7 KiB)  TX bytes:0 (0.0 B)

br-client Link encap:Ethernet  HWaddr 00:0D:B9:53:71:60  
          inet6 addr: fe80::20d:b9ff:fe53:7160/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:99 errors:0 dropped:0 overruns:0 frame:0
          TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3220 (3.1 KiB)  TX bytes:6462 (6.3 KiB)

br-wan    Link encap:Ethernet  HWaddr 32:2F:85:81:97:F0  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr 00:0D:B9:53:71:60  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:fe600000-fe61ffff 

eth1      Link encap:Ethernet  HWaddr 00:0D:B9:53:71:61  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:fe700000-fe71ffff 

eth2      Link encap:Ethernet  HWaddr 00:0D:B9:53:71:62  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:fe800000-fe81ffff 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:746 errors:0 dropped:0 overruns:0 frame:0
          TX packets:746 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:70297 (68.6 KiB)  TX bytes:70297 (68.6 KiB)

local-node Link encap:Ethernet  HWaddr 16:41:95:40:F7:DC  
          inet addr:10.137.0.1  Bcast:10.137.255.255  Mask:255.255.0.0
          inet6 addr: fde8:21c6:9d82::1/128 Scope:Global
          inet6 addr: fe80::1441:95ff:fe40:f7dc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:103 errors:0 dropped:0 overruns:0 frame:0
          TX packets:97 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7199 (7.0 KiB)  TX bytes:8482 (8.2 KiB)

local-port Link encap:Ethernet  HWaddr 00:0D:B9:53:71:60  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:97 errors:0 dropped:0 overruns:0 frame:0
          TX packets:103 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8482 (8.2 KiB)  TX bytes:7199 (7.0 KiB)

mesh-vpn  Link encap:Ethernet  HWaddr 32:2F:85:81:97:F7  
          inet6 addr: fe80::302f:85ff:fe81:97f7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1426  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:327 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:18998 (18.5 KiB)

primary0  Link encap:Ethernet  HWaddr 32:2F:85:81:97:F3  
          inet6 addr: fe80::302f:85ff:fe81:97f3/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1532  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:161 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:12222 (11.9 KiB)

bootlog?
logread?

Keiner eine Idee?

Ich habe da noch etwas andere merkwürdiges. Ich habe einen Speedtest direkt zum Gateway (über die interne IP) gemacht. Leider schaffe ich es nie über 65 Mbit, während ich über meinen Internetanschluss selbst gut 100mbit bekomme.
Ganz konkret ein Speedtest, 64,1mbit und etwa 23% (39% als kurzer Peak) CPU Auslastung auf dem APU2 Board. Am Gateway 1-2 Prozent. Woran kann es liegen das ich nicht auf 100 Mbit komme?
Gemessen alles über Gigabit LAN.

Hab meine Glaskugel nicht dabei… Fastd?

Fastd

Gestern Abend bin ich noch auf ca 70-80 Mbit gekommen, was ich noch viel merkwürdige finde.
Das Gateway ist mit 1gbit angebunden. Mein Internetanschluss hat 100mbit. Wenn ich normal übers Internet gehen, schaffe ich stabile 100Mbit zum Gateway. Gehe ich über mesh VPN schwankt es sehr stark, meistens etwa 60 Mbit, zeitweise bis zu 80 Mbit. Ich verbinde mich extra über die Freifunk Interne IP, um das ExitVPN aus der Sache raus zu halten.

wie sieht den die last auf dem gw aus ???

8 CPU Kerne die zwischen 0 und 8 Prozent schwanken. Mesh VPN war gestern im Schnitt bei 20 Mbit/s http://gate04.pinneberg.freifunk.net/

Edit:
Könnten 20-25% Overhead durch die Protokoll Wrapper von batman und fastd entstehen? Beim Upload komme ich auch nur etwa auf 18 Mbit, obwohl es normal 20 sind.

ja, kann gut sein. insbesondere deine/eure hohe MTU von 1426 kann an vielen Internetanschlüssen für zusätzlichen Overhead sorgen.