Hardwareauswahl - Nutzen einer externen Antenne

Scheinbar ist die Information ja nicht korrekt, wie @gomaaz sagt.

So ich hab meinen Fehler gefunden. Ich Trottel hab die Firmware für Aktualisierungen (unten) geflasht, statt die richtige für neue Geräte (oben).

Ein 30/30/30 hat gerade nicht funktioniert. Hat jemand zufällig einen Link, wie ich an den Bootloader rankomme und ihn zum installieren einer anderen Firmware überrede?

Die meisten Restore-Links setzen voraus, dass vorher schonmal OpenWRT drauf war, das ist ja in meinem Fall nicht der Fall.

Grüße
MPW

Abgesehen davon, dass der Flaschenhals eher bei den Supernodes zu sehen ist:
Mit „salsa+umac“ (statt „salsa+gmac“) gibt’s nochmal 50-80% mehr… also mehr als die Supernodes uns derzeit zu geben bereit wären.
(Auf die Gefahr dass jemand sagt „nicht alles was hinkt ist ein Vergleich“: Die Betrachtung der CPU-Geschwindigkeit ist bei den realen tecnischen Freifunk-Problemen ziemlich illusorisch. Das klingt für mich nach einem Autobesitzer, der über Stoßdämpferabstimmungen philosophiert während seine Karre regelmäßig wahlweise gar nicht erst anspringt oder unterwegs immer wieder mit Problemen an Zündung, Benzinpumpe und Lichtanlage ins Straucheln kommt.)

Du hast mal manuell das Lan auf 192.168.0.9 festgenagelt und dann die 192.168.0.1 dauergepingt während der Bootversuche?
Oder das gleiche mit 192.168.1.9 mit ping auf 192.168.1.1?
Wenn da eine von antwortet: Telnet auf der Adresse versuchen und dann weiterschauen… und hier vermelden.

Ich vermute aber mal. Du hast das Ding gleich im ersten Anlauf gebrickt. Darf also in die Post zu jemandem mit einem CMOS-RS232-Kabel.

Nix zu machen, beides probiert. Mehrfach.

Nah toll :smile:
Ich werd mal hier in Münster per Mail nachfragen, ob die sowas haben.

„Büchersendung - Maxi“ kostet 1€90. Da musste schauen, wie weit Du dafür mit dem Auto oder dem Bus fahren kannst.
(Sprich: Bei Bedarf unbricke ich Dir das Ding)

Danke für das Angebot, ggfs. schreibe ich dich die Tage nochmal an. Du scheinst auf jeden Fall schon Mal gemacht zu haben :D.

Kurzes Update:

Mit Hilfe des tollen Mailsupports hier aus der Münsterraner Freifunk Community, ist es mir gelungen den Router in den Bootloader-Modus zu bringen.

Dazu muss nach dem Start mehrfach kurz der Resetschalter gedrückt werden, bis die LED unter dem Zahnrad ganz schnell blinkt.

Dann kann er am WAN(blau)-Interface (nicht LAN/gelb) auf 192.168.1.1 angepingt werden.

Das hochladen der korrekten Firmware ist mir leider noch nicht gelungen:

$ tftp 192.168.1.1
tftp> binary
tftp> put gluon-ffms-v2014.3.1+107-tp-link-tl-wr841n-nd-v8.bin
Transfer timed out.

Egal, wie schnell nach dem Start man das macht, es kommt immer ein Timeout. Ein Ping geht aber durch, die connect-Ausgabe von tftp ist eher ein Witz. Der zeigt auch „connected“ an, wenn der Router noch gar nicht an ist. Vermutlich gibt es da noch Schwierigkeiten den FTP-Server wirklich anzusprechen.

Ich glaub du befindest dich da im OpenWRT failsafe Modus.

Alle Details dazu gibt es hier: [OpenWrt Wiki] Failsafe Mode, Factory Reset, and Recovery Mode
kurz: telnet (nicht ssh) zu 192.168.1.1 (vorher deinem Laptop eine andere statische IP vergeben, z.B. 192.168.1.2 )
„firstboot“ ist der Befehl, den du suchst.

Berichte mal, ob es geklappt hat.

Grüße
Lukas

Versuch mal eine Switch dazwischen zu hängen!
Das könnte evtl. helfen.

Ich würde garnicht erst versuchen per TFTP Daten zu laden, es sei denn Du hast Dein Netz perfekt unter Kontrolle.
Oder anders formuliert: TFTP ist ein sehr, sehr anfälliges Protokoll war $YOUNAMEIT angeht.

Mein Vorschlag:
Per Telnet drauf,
dann
mount_root
dann
passwd root ein passwort setzen.
Dann mit winscp drauf einloggen und das richtige Image $FILENAME nach /tmp pumpen
dort dann (immernoch mit dem ersten Telnet-Login) den sysupgrade -n $FILENAME starten

Können wir gern auch gemeinsam mit einem Fernwartungswartungstool des Geringsten Misstrauens machen (Teamviewer, GoogleHangout…)

Hallo,

vielen Dank für eure Hilfen.

Also die Idee von @Maltis und @adorfer gehen ja in die gleiche Richtung, nämlich per telnet. Leider weigert sich das Ding das Root-Filesystem zu mounten.

root@(none):/# mount_root
mount: mounting /dev/mtdblock3 on /tmp/overlay failed: Input/output error
switching to jffs2
root@(none):/# mount_root
mount: mounting /dev/mtdblock3 on /tmp/overlay failed: Input/output error
switching to jffs2
root@(none):/# mount_root
mount: mounting /dev/mtdblock3 on /tmp/overlay failed: Input/output error
switching to jffs2
mount: mounting overlayfs:/overlay on /mnt failed: Invalid argument
mount: mounting /proc on /overlay/proc failed: No such file or directory
jffs2 not ready yet; using ramdisk
mount: mounting overlayfs:/tmp/root on /mnt failed: Invalid argument
creating directories… done
setting up symlinks… done
pivot_root: No such file or directory
Could not open mtd device: rootfs
Could not open mtd device: rootfs
root@(none):/# passwd
Changing password for root
New password:
Retype password:
passwd: /etc/passwd: Read-only file system
passwd: can’t update password file /etc/passwd
root@(none):/#

Beim dritten Mal ändert sich die Ausgabe immer und er springt auf eine ramdisk. Trotzdem kann ich da kein Passwort setzen.

/edit:

Also natürlich nochmal die Fehlermeldung gegooglet, das bringt mich auch nicht weiter:

rootfs_data zu löschen geht nicht, firstboot will auch nicht.

root@(none):/# mtd -r erase rootfs_data
Could not open mtd device: rootfs_data
Could not open mtd device: rootfs_data
root@(none):/# firstboot
grep: /proc/mtd: No such file or directory
awk: /proc/mounts: No such file or directory
awk: /proc/mounts: No such file or directory
Could not open mtd device: rootfs_data
Could not open mtd device: rootfs_data
mount: mounting on /overlay failed: Invalid argument
grep: /proc/filesystems: No such file or directory
grep: /proc/filesystems: No such file or directory
mount: mounting /proc on /mnt/proc failed: No such file or directory
root@(none):/# ls /proc/
root@(none):/# ls /dev/
console mtd1ro mtd5 mtdblock5 tty ttyS14 ttyS7
full mtd2 mtd5ro null ttyS0 ttyS15 ttyS8
kmsg mtd2ro mtdblock0 port ttyS1 ttyS2 ttyS9
mem mtd3 mtdblock1 ptmx ttyS10 ttyS3 urandom
mtd0 mtd3ro mtdblock2 pts ttyS11 ttyS4 zero
mtd0ro mtd4 mtdblock3 random ttyS12 ttyS5
mtd1 mtd4ro mtdblock4 shm ttyS13 ttyS6
root@(none):/#

Also hier ist doch der Wurm drin. Habe gerade mal meine Idee mit dem Übertragen per http probiert:

root@(none):/tmp# wget http://192.168.1.2:8000/gluon-ffms-v2014.3.1+107-tp-link-
tl-wr841n-nd-v8.bin
Connecting to 192.168.1.2:8000 (192.168.1.2:8000)
gluon-ffms-v2014.3.1 100% |*******************************| 3840k 0:00:00 ETA
root@(none):/tmp# md5sum gluon-ffms-v2014.3.1+107-tp-link-tl-wr841n-nd-v8.bin
5c6e9760f1e0d8c7279e32dbb1cfa54e gluon-ffms-v2014.3.1+107-tp-link-tl-wr841n-nd-v8.bin
root@(none):/tmp# sysupgrade -n /tmp/gluon-ffms-v2014.3.1+107-tp-link-tl-wr841n
-nd-v8.bin
grep: /proc/mtd: No such file or directory
Invalid image, hardware ID mismatch, hw: image:08410008.
Image check ‚platform_check_image‘ failed.
root@(none):/tmp#

Die md5sum stimmt. Hab es 3x überprüft:
https://freifunk-muenster.de/mitmachen/firmwareliste/

Unter Erstinstallation → WR841N(D) → V8 → Stable.

/edit: Die originale Firmware nimmt er auch nicht.

root@(none):/tmp# sysupgrade -n wr841nv8_en_3_15_9_up_boot(140724).bin
/sbin/sysupgrade: eval: line 1: syntax error: unexpected „(“
/sbin/sysupgrade: eval: line 1: syntax error: unexpected „(“
/sbin/sysupgrade: eval: line 1: syntax error: unexpected „(“
/sbin/sysupgrade: eval: line 1: syntax error: unexpected „(“
Invalid image type.
Image check ‚platform_check_image‘ failed.
root@(none):/tmp# mv wr841nv8_en_3_15_9_up_boot(140724).bin wr841nv8_en_3_15_9
_up_boot140724.bin
root@(none):/tmp# sysupgrade -n wr841nv8_en_3_15_9_up_boot140724.bin
grep: /proc/mtd: No such file or directory
Invalid image, hardware ID mismatch, hw: image:08410008.
Image check ‚platform_check_image‘ failed.
root@(none):/tmp#

So, ich glaub ich hab’s.

Also folgende Schritte sind notwendig:

Kabel in den WAN-Port (nicht LAN) des Routers stecken (blau) und beim einschalten mehrfach den Rest-Knopf kurz drücken, damit man in den Bootloader kommt. Das Zahnrad blinkt dann sehr schnell.

Am Rechner manuelle IP-Konfiguration vornehmen, ggfs. den Network-Manager stoppen, weil er sich immer dazwischen drängelt.
sudo ifconfig eth0 192.168.1.2 netmask 255.255.255.0
Firmwareimage herunterladen und per http anbieten:
cd Downloads && python -m SimpleHTTPServer
(oder wohin man es halt gespeichert hat)

telnet 192.168.1.1
cd /tmp/
wget http://192.168.1.2:8000/gluon-ffms-v2014.3.1+107-tp-link-tl-wr841n
-nd-v8.bin
sysupgrade -n -F gluon-ffms-v2014.3.1+107-tp-link-tl-wr841n
-nd-v8.bin

Warum hier die Option „-F“ gebraucht wird, verstehe ich nicht.

1 Like

Argl… hatte ich übersehen…
Der sysupgrade vergleicht, ob die neue FW „zur alten“ passt, also zur vorhandenen Hardware…
(Da er davon ausgeht, das die vorhandene irgendwie „passt“…)

Weil aber in Deiner Kiste da nur Unfug steht, scheitert die Prüfung.
Aber jetzt läuft es? Fein!

Ganz ehrlich: Kompliment. Das schaffen nur wenige! (und sind zudem so hartnäckig dabei)

Ah okay. Das macht Sinn. Als er die originale nicht genommen hat, war irgendwie klar, dass man ihn zwingen muss.

Man man so viel Ärger, nur wegen einem falschen Klick.

Der Router ist mittlerweile freigeschaltet und steht im Fenster. Werde dann mal mit verschiedenen Positionen experimentieren und überlegen, wie ich ihn draußen aufhänge.

Ein flaches Kabel habe ich schon, aber dieser PoE-Adapter kommt erst kurz vor Weihnachten aus China.

2 Likes

Das Problem mit den stark dämpfenden Fenstern kenne ich.
Ich habe es bei ein paar Installationen so gelöst:

Klappt mit Kunststoffrahmen hervorragend. Es reicht, wenn eine Antenne im Rahmen ist, die andere kann drinen bleiben und die „in-House“-WLAN-Versorgung machen.

1 Like

Schöne Idee, aber anscheinend lässt sich die Antenne vom TL-WR841ND gar nicht abnehmen.
So kann ich auch gar nicht probieren, ob mein Fensterrahmen nicht zu eng ist, es könnte zumindest knapp werden.

Dann hast du wohl einen TL-WR841N

Denn das D in ND steht für Detachable :wink: (Und deswegen sind die ND-er auch ~5€ teurer)

1 Like

Man kann die Antenne beim N modell trotzdem abnehmen indem du den Router aufmachst und dann die Einsraster klemmst,.dann bekommt man ca 7 cm Antennenkabel rausgezogen. Oder das Kabel ablöten und ein Neues dran mit anderer Antenne.
Nicht vergessen: Jeder Lötstelle und Anschluss 1 dB Verlust

Wenn man es gut gemacht hat!
Wenn nicht, dann sehr viel mehr Verlust.

Problem: Die Wenigsten von uns haben das notwendige Testequipment, um das Ergebnis kontrollieren zu können.
Das ist wie Lampen-Basteln wenn man blind ist und zum „messen“ maximal eine Solarzelle und ein Multimeter mit Sprachausgabe hat. Geht schon, ist aber nicht einfach. Und schon gar nicht „mal eben“.

1 Like